IFI iNANO DAC..Sound distorted when playing MQA

Hello there

Have been wery impressive with this DAC
Playing from NUC > DAC > AMP
All files from16, 24, 32 bit op 384khz + DSD op to 256 sounds great
MQA doesnt…sounds like its distorting kind off…tried to change the setting in MQA setting…doesn’t help
Settings in “Clock Priority” what should it be?..Ask because it has some influence on the sound
Any thoughts…thnks

MQA should be set to ‘Renderer only’ for the iFi nano. Is it running the latest (5.30) firmware?

See: https://ifi-audio.com/nano-idsd-bl-xmos-firmware/

Clock priority settings should only matter when different zones are grouped together.

Can you share a screemdump of your audio path in Roon, like this:

Have listening to this…his voice only…altså just this album

Listening…my favorit…Hoff Ensemble…this sounded realy great

So…i dont now…any suggestions?

Btw…Firmware is 5.30

Hello @Morten_Valbjorn,

It appears that you are doing everything correct, I’m not sure why you are hearing these distortions. My only recommendation having to do with Roon would be to increase the “Resync Delay” setting to “500ms” and seeing if that changes the behavior.

If you connect the iFi iNano DAC to a PC and use the Tidal application, do you hear the same thing when streaming MQA? I would recommend reaching out to iFi support as well, they may have an idea of what’s going on with the DAC.

-John

Thnks

Be back