iFi Zen DAC V2 will not work with Roon?

I’ve tried to connect to Roon directly with the iFi via ethernet and using a microRendu. While recognizes the iFi (and microRendu), it will not play music. The play button is grayed out. I’ve hooked it up directly to my iMac and used Tidal directly and it works fine. I’ve enquired with iFi and they say they are working on getting it Roon capable. Really? It seem like there are folks on here who have it working. I’ve tried every setting and nothing works. My main system with an opticalRendu and Benchmark DAC works just fine. Does anyone here have suggestions or know when iFi will have this resolved? Thanks so much.

How do you have the ifi zen DAC connected?
You will need to connect the microrendu to Ethernet and then USB to the Zen DAC.

Roon should “see” a DAC connected that way.
Then enable that new audio zone in settings:audio

I believe you are correct in that there are people here using it with Roon.

But like my Gustard x16, that is not identified by Roon but still works connected by USB to my streamer.

You also might want to check that the Zen firmware is the latest available.

Thanks for the answers. Connected just as noted with ethernet to the microRendu and USB from there to the iFi DAC. Firmware is fully updated. Plus, iFi says they are working on it being Roon Ready. It just doesn’t make sense that others have made it work.

Looping in @Michael_Harris
As I know he has a Zen DAC working and is much more familiar than I.

I have the Original Zen DAC and it has worked perfectly with every streamer and device I have plugged it into. I would expect the Zen DAC 2 to work in exactly the same way.
I have used a Pi, a Zen Stream and a PC and all have worked perfectly.

Andrew are you able to try it in a PC or Mac with Roon and try it and see if that works.

Michael: thanks. Yes, I have the iFi hooked into my iMac directly now. I’m using it to play from my Tidal app. However, Roon will not recognize it all. All Roon sees is my ultraRendu that streams on my main system to my Benchmark DAC, plus two Apple TVs. The firmware is up to date. I’m wondering if I should return it - I have until January 31. Thanks

When you say Roon wont recognise it, what do you see under settings:audio:device setup for the microrendu.
Because thats where Roon will see it.
You need to select the microrendu as the audio output zone once you have configured it under device setup.
It is probably just showing the zen dac as an unidentified device.
see my setup which shows as unidentified and i select the streamer/bridge as the audio zone and it plays.

Thanks to all. I got it to work. Every time I’d hook it through the microRendu, I’d see it in devices, Roon Ready, Settings and the bridge would be the microRendu and the audio device the iFi HD USB Audio BUT the play button wold be grayed out and could not get music to play. I use Bookmarks extensively to play my favorite tracks from various artist. In frustration this time, I switched to another artist and selected the shuffle option and voila, IT PLAYS. I can’t believe I didn’t try that the other multiple times I hooked it up that way. But why the play button is initially grayed out, I have no clue. Again, thanks to all.

2 Likes

Does Roon see it connected to your Mac and doesn’t play or just doesn’t see it at all.

I’m sure there are other people here using the Zen DAC 2 as there is at least one other thread about MQA settings

Good News and ignore my Last post then.

In my hobby room (where the Nucleus resides) I have an iFi zen 2 dac connected to my nucleus via USB and it works like a charm when controlled via Windows. The same goes for another room where I have connected my PC to a simple dac via optical out on my PC. All on the same network. Of course in my main listening room I use a Naim streamer/dac via ethernet, but I bought the iFi Zen dac especially for the direct connection to the Nucleus.

Sorry, I just realized this topic was not about connecting a Nucleus…