I'm getting an error message for 1.8 update - "There was an error checking for an update"

Roon Core Machine

MacOS Monterey 12.1, Imac 2019 4K retina, 3.6 ghz, quad core i3

Networking Gear & Setup Details

Netgear GS105 gigabit switch, WiFi

Connected Audio Devices

Ipad pro 15.2 (WiFi), PSAudio Directstream (ethernet)

Number of Tracks in Library

My Ipad won't connect because it says my Core needs an update. I've run the update 20 times and once it finishes downloading and gets a little bit into installing it stops and i get an error message "There was an error checking for an update". On my Ipad, it also keeps telling me i need an update and i have reinstalled the app three times with still no luck moving forward. Still telling me i need an update. Help!

Everything was working perfectly before the update!

Have you tried to download the MAC installation file from Roon’s Download Page and manually just run install? Just make sure you are downloading and installing the correct software you need.

Read this link from Rebeka to another user with a similar issue.

Thanks Daniel - once I completely deleted the Roon downloads from my Mac and then went to the website and completely started over with the downloads - it worked! Thanks so much!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.