I'm having problem for finding Roon Core

Roon Core Machine

Mac mini M1(16GB) OS 11.5.2, I installed both Roon server and Roon App v.1.8/build 831.

Networking Gear & Setup Details

Network T-mobile Router dual band WiFi,
Allo USB signature OS DietPi Wired to Router->
NAS Synology DS920+ wired to Router
Make sure they are all under the same network route as Mac mini

Connected Audio Devices

Gustard X26 USB DAC → Audio Amplifier.

Number of Tracks in Library

Around 40k Tracks

Description of Issue

The Roon core and remote are both installed in Mac mini, however, at the remote setup not been able to find Roon Core since day1. I tried another remote in my Samsung mobile, the same result was not able to find nor connect to core. Below link for my zip file of the server and remote logs file. Thanks for the help!


Make sure your wifi and Lan connection to the mini are on the same IP address ranges or perhaps add the wifi connection to the mini in addition to the lan connection. make also sure the wifi network is not a guest network too.

make sure also the apps have been removed and reinstalled on the mobile devices.

make sure you dont have the firewall turned on on the macmini too

I connected the wired ethernet cable to mini, the result is the same no improvement. My firewall is all turned off in the mini and router. I’ve reinstalled roon in the mini but the same result, strange. I’m sure my wifi network is not a guest network, and it is sure they are in the same IP address range(192.168.29.xxx), the IP is only the last part difference.

I have no idea if the following is relevant (it’s beyond my expertise or knowledge to say) but your logs indicate that Roon Server is discovering a couple of bridged networks in addition to your 192.168.29.xxx LAN as follows:

11/10 17:17:00 Trace: [ipaddresses] FOUND lo0
11/10 17:17:00 Trace: [ipaddresses] SKIPPED gif0: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED stf0: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED anpi1: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED anpi0: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED en0: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED en4: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED en5: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED en2: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED en3: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED ap1: no ipv4
11/10 17:17:00 Trace: [ipaddresses] FOUND en1
11/10 17:17:00 Trace: [ipaddresses] SKIPPED bridge0: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED awdl0: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED llw0: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED utun0: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED utun1: no ipv4
11/10 17:17:00 Trace: [ipaddresses] SKIPPED en7: no ipv4
11/10 17:17:00 Trace: [ipaddresses] FOUND bridge100
11/10 17:17:00 Trace: [ipaddresses] SKIPPED en8: no ipv4
11/10 17:17:00 Trace: [ipaddresses] FOUND bridge101

I don’t know if this is even relevant, let alone the cause of the problem, but it struck me that it might be complicating matters.

The found Bridge that is I have a virtual machine Parallel installed, and it Shared Mac. network, it has 2 share modes:
a. Common Shared: Parallel assign IP:
b. Host-only: Parallel assign IP:
In fact, during the setup and find core process, Parallel never been on. Do you think that will be the main cause?

Is Roon running in a VM? If it is…
Your configuration is not supported. What you’ve built is:
network1 - VirtualRouter - network2

Your Remotes are on network1 and your Core is on network2. Not a supported configuration.

If you want to run virtual you must assign the Core a bridged network interface and that interface needs to be bridged to a hardware network interface on the Mac mini which is connected to the same network as your remotes.

This bridged interface will then obtain a DHCP address from the same network as your remotes. Remove any firewalls and things should work.

If Roon is not running in a VM ignore the above. How did you install your core on the mac? What steps did you take? Is your Mac mini wired to router? Or is it wifi? What is the IP address of your remote, core, and endpoints? If possible please verify subnet mask as well.

1 Like

Please post some screen shots of the network and advanced network settings on you M1 Mini.

perhaps there are some issues with subnet mask or other entries like DNS / gateway etc that we might spot.

perhaps something like ‎LanScan on the Mac App Store would help see whats actually out on the network or something FING for the mobiles to see what they see too.

It looks like a good proposal, and I download the LanScan, the scan result as below:

My Network setting Screenshots:

Then below is my Roon Setup page:

Thanks a lot for all of your efforts!

Fing can be on the desktop too.

  1. Find Roon OS is ONLY used to locate Nucleus or ROCK servers on the network. It is not use for RoonServers running on Windows, MacOS, or Linux. So, as far as I understand, ignore that it is not used in your setup as you are running it on MacOS.

As an aside, even if you were using one of the other ones, it really only redirects the user to opening the webpage that those servers run.

  1. Linn Streaming is only used if you are using Linn equipment. I didn’t see that you were, so, ignore it.

If you are having trouble with your mobile connecting to the core, on your mobile, when it says it can’t find the Core, click the blue Help button which allows you to enter a server IP and enter

Your final image suggests that your are connected to your core - DaviddeMac-mini. From what device did you grab this screen shot? Also, if you click the hamburger (top-left) and go to the ‘home’ page, what does it show?

1 Like

In settings under general it should list the core name

So that means my Roon installation is normal and works as it should be. On my mobile app, I click the blue help button, not it also looks ok. Thanks All!

Below is my Home page, does it looks normal?

Below is the general in Setting page, it indicates my Roon Core “This Mac”, does this is normal?

Looks normal to me.

1 Like

It sounds great, I have no more questions. Thanks!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.