I'm Stumped About This Import

Roon Core Machine

Nucleus/iMac Pro remote

Networking Gear & Setup Details

Eoos/direct ethernet to nucleus

Connected Audio Devices

fiio dac/kef

Number of Tracks in Library

71000

Description of Issue

Ok so added a collection of 37 discs. Tagged them all in MP3 tag. Files are Flacs. Everything went into Roon under one album with 36 discs. Huh? Disc 27 would not go into collection. I merged and it disappeared. So i deleted, cleaned library, checked skipped files, re-tagged, re-imported only this time same thing but with only two songs of the 17 on Disc 27. Well did everything again and again and again and finally got the 17 tracks but that one disc is still separate from the collection. Oh and I’ve restarted Nucleus and Roon many times. I cannot figure this out? Can you help? Thanks

Did you use the mp3tag auto-numbering wizard in tools?

I did. I really cannot figure this out. Bugging me so bad have spent hours lol.

Ok. That is weird. I assume then you did all the normal things like using the same album title for all CD’s and subdirectories named CD01, CD02 . . . CD37?

Can you post a screenshot of the album? Maybe someone will think of something.

If you believe there is nothing amiss with the file metadata (you may already have tried similar but if not) perhaps try:

  • move the folders and files with the collection of discs outside your watched folders (or into a hidden folder within your watched folders)
  • clean your library again
  • stop Roon Server
  • move the folders and files with the collection of discs back into your watched folders
  • start Roon Server

and see if it makes any difference.

On occasion when importing a lot of files in one go, with Roon running, I have had similar issues. It perhaps tries to identify to soon (before complete sets of track for an album are available), but whatever the reason, weird things ensued - tracks incorrectly separated over multiple albums and/or incorrectly combined with existing tracks from elsewhere in the folder structure. I have noted this particularly with compilations / various artists albums and box sets.

Hope you get it sorted without to much further hassle!

Use mp3tag to check extended tags so you see all tags. Load up all files from an album, right click, select extended tags. Then you can tell whether there is a tag field that differs but should not. Sometimes one disk or a subset of tracks might have total disks or total tracks filled in while others do not. Subtle differences in tags can cause roon to think these are different albums.

Yup. Did the normal things. I looked at them in roon, on mac info, and at the files themselves to make sure there were no inconsistencies. It’s gotta be something stupid but I can’t see it aaargh. I can post shots

To be clear, mp3tag often shows me inconsistencies I do not see elsewhere. So if you haven’t, do the step I outlined.

Thanks I will try all that again. And yeah it may because I did them all too fast. But that was last night, and I’ve been dealing with it all morning today. Still can’t get it. You’d think deleting it , and restarting the nucleus and reimporting would fix it

Not if there is a stray tag you haven’t removed or changed.

Yep, did that already. And the discs were like that which is why I did all 37 discs in MP3 Tag before importing to roon.

ok will try that again

What is the album in question? Did you check and see if it was treating Disk 27 as a duplicate of another disk, maybe via versions. Turning on Show Hidden is a great way to troubleshoot import problems.

It’s disc 27 of 37. No versions listed. Good idea about the Hidden Albums I just tried that no go.
Appreciate all the help and ideas keep ‘em comin’ !!

Hey @James_Cortez,

Did you ever get things sorted out with disc 27?

If possible, could you upload the files in question here, and we can take a closer look. I’ll be on standby for your reply :+1: