I'm unable to connect Roon to my NAS Drive [Solved]

HI I’m new to Roon and I’ve just downloaded my trial.

Downloaded all ok and Tidal is working fine. But I cannot connect to my NAS library.

In “Add Network Share” I’ve inserted the pathway: smb://

User Name “admi”

There is no password.

I get the messagE “Could not connect to share: Unauthorized”

Can anyone help?



Roon v. 1.3 (build 248) 64 Bit.

iMac (late 2015) 3.2 Ghz i5 8 Gb Ram
OSX10.12.6 (Sierra)

Wired network

Synology DS214 Play Nas ( 2x 4Tb)

You should try those options, I’m sure one of them will fix the issue:

  1. Try to add this folder without username
  2. Add guest user to that folder and after that add this folder without username and pwd
  3. Add password to the folder and try to add it with pwd
  4. Try to use Synology admin account

Thanks for the help. Tried nos. 1to 3 no success.

Not sure how to do no. 4

In regards to #4: there should be an admin account for your NAS (most likely you use it when you login web UI).

Can you mount this folder in Finder ?

Thanks for the help. I need to get back to this later - need to go to a meeting.

Thanks for help Vova. I’ve sorted it. Synology was default setting user = admin and no password i went into synology gave it a password then put this into Roon and it connected to NAS.

Just one other question. Ive set my iphone as a remote and set roon to receive remotes. When my imac is asleep the iphone will not connect to roon!



Hi Gareth,

All the processing in Roon is done by the Core. The Remote versions just control the Core. So when your iMac is asleep your Core is asleep and your iPhone has nothing to control.