iMac pro catalina 10.15.3 and upgrade 1.7 difficulties

Core Machine (Operating system/System info/Roon build number)
iMac pro catalina 10.15.3 (8 core intel processor, 32 GB ram, large SSD) Roon 1.6 build 475

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
iMac pro connected directly via supra cat 8 cable to a linear solution reference audiophile switch. The switch is also fed via a netgear nighthawk cable-modem router receiving 1 gb service via local provider. Switch and router also connected via supra cat 8 cable. Switch feeds multiple endpoints via fiberoptic cable to optical rends and optical signature rendu.
The rendu then send signal via USB to various DACs.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
System has been performing wonderfully with Roon 1.6. I decided to upgrade to 1.7 two months ago. I first downloaded the remote app to my iPads and then proceeded to upgrade the core. The red triangle with exclamation point keeps reminding me of available upgrade. I click on upgrade: it says downloading, installing, stable. then click to relaunch, roon program disappears and never relaunches. I reopen roon and it is the old 1.6. My iPads no longer work with 1.6, I have read numerous threads about various problems with catalina including that the appears in the accessibility list, setup screen, mac os media key support etc. I can’t seem to get my mac to accept 1.7
I have been using 1.6 with no remotes for a few months now.
thanks for your help in advance.


On your iMac, go to System Preferences > Security and Privacy > Privacy tab. Then click Files and Folders On the left.

Are you able to see Roon showing Removable Volumes with a check mark?

If not, try and add a check mark. You may click and unlock at the bottom left of the window.

no I see Roon there with a subtitle of “full disk access” without a subtitle of “removable volumes” I tried to add a check mark to “full disc access” without success.

You need to check the Full Disk Access folder settings above in the left side of your screen shot

Hi @Carlos_Rodriguez,

I would suggest to create a Backup of your current Roon Database and then download the latest version of Roon again from our download page and install it on top:

Hello, I had tried to download the new version previously without success, it had asked me if i wanted to replace the version already on the hard drive with the new version and at the time I said yes… This time at the same prompt I had it install in addition to the old version “installl it on top”? : and yes it was successful. Thanks so much!! Looking forward to valence

1 Like

Hi @Carlos_Rodriguez,

Glad to hear that the upgrade was a success!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.