iMac27 can't connect to Nucleus after Catalina upgrade

Core Machine (Operating system/System info/Roon build number)

iMac27 running Catalina
Nucleus OS 1.0 (Build 175)
Roon Server SW 1.6 (build 416)
Roon Labs SW 1.0 (build 11)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Nucleus attached via ethernet to Netgear EX7000 wireless extender
EX7000 attached to Netgear R7000P via wifi
iMac attached to R7000P via wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

dcs Bartok attached to EX7000 via ethernet

Description Of Issue

Just upgraded to Catalina on the iMac. Now the iMac can no longer “connect” to (mount) the Nucleus - I keep getting an error message from Finder: “The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.” Oddly, music will play from the Nucleus via Roon on the iMac; my problem is that without being able to connect to the drive inside the Nucleus I won’t be able to back up using my cloud backup service. Anyone else run into this problem or have thoughts about how to solve?


There are multiple threads here telling you not to update to Catalina.

Thanks, James. I’m not sure that that helps me a lot with this particular issue. The machine I upgraded has very little to do with my Roon usage other than as a conduit for backing up (and some rare playback).

Interesting. I can still access the internal drives of my sonicTransporter i5 over the network with my iMac running Catalina…

Hi @Michael_Turner,

The Catalina issues we are aware of is Roon being unable to access any external drives from within Roon when Catalina is hosting the Core, in your case you seem to be accessing the Nucleus hard drive from outside of Roon?

Have you tried connecting both via IP address and via Hostname and the behavior is the same? Can you share a few screenshots of the error messages you are presented with in Finder?

“The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.”

Can you access the Nucleus web administration interface from the iMac?

Thanks, Winders. I’ve just read that Apple has dropped support for SMB connections (which is how I’d been connecting to the Nucleus). Turns out that all I had to do was go into Finder, select Go, then Connect to Server and enter the IP address and all is well. There may be other solutions but this one was pretty easy. The only annoyance is that the Nucleus now shows up simply as an IP address in the Finder list. I haven’t found an easy way to rename it, but I can live with that as a pretty minor inconvenience.

Thanks, Noris, I’ve just tried connecting via IP address - rather than SMB - and it has worked fine.



1 Like

Yes. And I can even play music from the iMac. Just couldn’t access the internal drive, but now that’s solved as I needed to connect via IP address rather than SMB.

1 Like

Hi @Michael_Turner,

Glad to hear that connecting via IP address is working as expected! Just a quick note, I would suggest creating a Reserved IP Address in your router configuration to ensure that the Nucleus’ IP Address doesn’t change when the IP Address lease expires and that you can keep accessing it at the same IP.

You’re still connecting via SMB. Something called NetBIOS is disabled in Catalina. That’s why you couldn’t reconnect to the share.

This can be enabled but requires some command line changes.

Done! Thanks Noris

1 Like

Martin, you wouldn’t happen to know how to rename the Nucleus in my Finder Locations List, would you? Right now it’s listed as an IP address.

You have a couple of options. Please note that I’m away from home so can’t test these. However, both can be reversed. You need to be comfortable with the terminal to do this. Try option 2 first.

1. Enable NetBIOS

sudo cp /etc/nsmb.conf /etc/nsmb.conf.bak
sudo echo "[default]" | sudo tee -a /etc/nsmb.conf
sudo echo "port445=both" | sudo tee -a /etc/nsmb.conf

2. Use hosts file

sudo cp /etc/hosts /etc/hosts.bak
sudo nano /etc/hosts

Add a line to the file as follows; you need to provide the IP address and host name. This is an example:       nucleus        # Roon core

Press ctrl-x then return to save the file. Finally type

sudo killall -HUP mDNSResponder

If this works you should be able to open the admin interface using http://nucleus.

Thank you Martin. That would be pushing the boundaries a bit for me so I think I’ll just stick with the IP address.

1 Like

This topic was automatically closed 35 hours after the last reply. New replies are no longer allowed.