Images gone. Only black squares

Core Machine (Operating system/System info/Roon build number)

Win 10 Home x64
Roon 1.7 build 521 x64

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router provided by ISP - Netiaspot. Wired connection for server. WiFi for Ropieee.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon at the same machine as server- wired connection.
2x Ropieee - WiFi

Description Of Issue


Today images disappeared from my Roon view at Win10 PC. This PC runs both Roon and Roon Server. I see black and grey squares instead of some zones images and Ropieee images. It also affects album an artist arts. It works ok when I access Roon via Remote form smartphone. I have tried reinstalling both Roon and Roon Server, including clean one with DB drop. Issue still persists.

Hi @Adam_Arczynski,

Just to clarify how you reinstalled here, can you please confirm you used these instructions to set the old database aside?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

Actually I did not expect that uninstalling ROON (not Server) would drop DB with my Library, so… :wink: I really mean it was dropped. :smiley: As I lost everything, nothing was keeping me from full reinstall then. Not a big loss as I have well tagged CR RIPs and my setup was not complete as I am still testing free trial. So to sum up:

  • uninstalled ROON from WIN10 machine with all checkboxes selected
  • uninstalled ROON Server from the same machine with all checkboxes selected
  • restarted PC
  • installed ROON Server and logged back to my free trial account
  • installed ROON
  • restarted PC

Side question: Was my library dropped during ROON (not server) uninstallation because server was on the same machine? Would’t it happen, if I had server on separate machine? Or is Library connected to ROON, not ROON Server? It kinda suprised me as I though that Library DB is connected to Server which I did not uninstall first. I believed that DB mentioned during ROON uninstallation contains some settings, etc. But looks like I was wrong. Apparently it was Server DB.

Hi @Adam_Arczynski,

The database for Roon Server should live in the Database Location/RoonServer path. Uninstalling the Roon app when in client mode shouldn’t have impacted your Roon database, it’s strange that you’re saying it did.

I suggest that you re-install both RoonServer and Roon to start fresh and see if this problem continues. Can you please use my above instructions to set both Roon and RoonServer’s database aside?

Can you give that a try and let me know if it helps with this issue? Thanks!

Hi, thanks for response.

I did reinstall of Server again and restored from backup. It fixed the issue. However, after restarting PC it happened again. I did one more reinstall and it was fixed again. I wonder If happens again, when I come back from work today.

I will also double check if uninstalling just ROON drops my DB and let you know.

Ok, so update from me:

Firstly, regarding my former re-installation and dropped DB. Looks like I miss-clicked then and actually uninstalled Roon Server. I have retried twice and all works as you described. Reinstalling Roon does not affect Server DB.

Going back to main issue with disappearing album, artist, zones, devices images. I am able to reproduce it 100% times. It happens when I restart my PC. To fix it, I need to either reinstall Roon or restore from backup. Kinda strange as images always work fine on mobile app. This would indicate a Roon issue, but reinstalling it does not help. I need to reinstall Server or restore from backup to fix Roon.

To sum up:

  • I install Roon and Roon Server on Win10 Home x64 - all is fine
  • Restart PC - images in Roon are missing. Roon mobile works ok
  • Restore from backup or reinstall Roon Server - all is ok
  • Restart PC - images are gone again in Roon. Mobile still works

It is exactly the same when I do advised re-installation with folders rename to Roon_old and RoonServer_old. It works after installation and stops after restart.

Restore from backup fixes issue even when backup was done when images were missing:

  • images ok
  • restart PC (images gone)
  • create backup
  • restore from backup (images ok)

Actually just restart of Roon Server triggers this issue as well. No need to restart whole PC.

Restarting Server when Roon is running also fixes this issue:

  • images missing
  • stop Roon Server (Roon Says Lost Connection!)
  • start Roon Server (Roon reconnects and images are back)

This can be used as fast and easy workaround but it would be great to have it properly working. Starting Server first and Roon second (which sound logical order to me) leads to missing images. Starting Roon first to let it complain about missing Core and starting Server second works ok.

Hi @Adam_Arczynski,

Thanks for the update here!

These symptoms sound particularly strange so I would like to review the diagnostics from your machine immediately after this behavior occurs.

Can I please ask that you reproduce this behavior, note the exact local time + date it occur and then use these instructions to send me a copy of your logs (for both Roon and RoonServer)?

The database location referenced in the above document list Logs for both the Roon and RoonServer folder location, they are located in %localappdata%/Roon/Logs and %localappdata%/RoonServer/Logs.

Can you please create a .zip archive of these two log folders and upload them to Dropbox / Google Drive and send me a link? If you don’t have Dropbox / Google Drive I can also provide alternate upload instructions.

Thank you!

Hi @noris,

I have reproduced the issue as requested:

  1. Started my PC on 09 Mar 00:00:00
  2. Started Roon Server at 00:02:30
  3. Started Roon at 00:03:00 (images missing)
  4. Restarted Roon at at 00:04:00 (images missing)
  5. Stopped Roon Server at 00:05:00 (Roon said Connection Lost!)
  6. Started Roon Server at 00:06:00 (Roon successfully refreshed images)

here are screenshots from steps 3, 5 and 6:

Here are zipped logs:

1 Like

Hi @Adam_Arczynski,

Thank you for the timestamps and the logs. I have created an internal ticket for you with our QA team and I have submitted the logs and timestamps for them to review.

It may take a bit of time to hear back from QA, but as soon as I have next steps, I will be sure to reach out once more.

P.S. Please check your private messages regarding your account status (if you haven’t seen the message yet). It it the green “1” notification on this website.

Hi @Adam_Arczynski,

I appreciate your patience until I had a chance to discuss your case with QA. I have spoken to them and we believe these are the next troubleshooting steps:

  1. Is there any change in behavior if you reset the TCP/IP stack on your Core? You can use these instructions to perform the reset.

  2. We need to ascertain if it’s just this specific Core that exhibits these symptoms. Would you by any chance have another PC around the house which you could use to host the RoonServer Core? If so, can you please install RoonServer on the other PC and keep the Roon UI on the current PC?

The steps for this are:

  • Install RoonServer on another PC
  • On the current Roon Core, go to Roon Settings -> General -> Disconnect
  • From the “Choose your Core” screen, select the other PC as the Roon Core
  • Verify if the same behavior occurs when starting RoonServer first and then the Roon UI on the other PC


Hi again @noris,

I did as advised:

  • Reset TCP/IP stack with provided commands via CMD started as admin
  • It asked for firewall settings for Roon, Roon Server and RAAT - I allowed all connections
  • Restarted Win10 PC
  • Additionally, Roon Server did auto-update to newest (528) build.

I see no changes. After restarting PC (or Roon Server and Roon), images are missing, I need to restart Server while running Roon to make it work again. Starting Roon first and Roon Server second also works. It also leads to displaying message about missing Core and refreshes images when Core is up.

I have also migrated my Roon Server to my Mac Book Pro with Mojave. I restored Core from backup and set new music directory (btw, cool it’s so easy to migrate core to another OS). I observed no issues at all. Roon on my Win PC worked fine no matter how many times I restarted Core on OSX or Roon on Win PC. Also, Roon worked fine on OSX.

I did additional test and used Roon on Mac with Roon Server running on my WinPC. Worked fine as well. Android Roon worked well with Server running on both Mac and WinPC. Looks like the only combination that leads to issues is running both Roon and Roon Server on my WinPC.

If you wish to investigate it further, I am happy to help. However, I am ok with current workaround. I restart my PC once a week and it is not a big pain for me. I still find Roon an awesome software, far superior to DLNA solutions. Additionally I am going to migrate Core to NUC, when 10th gen is available in country.

1 Like

Hi @Adam_Arczynski,

Thank you for running those tests!

Since this issue only occurs when the PC is hosting the Roon Server, it seems like some kind of firewall issue blocking RoonServer from retrieving the images, do you by any chance have any additional antivirus or firewall software installed on this PC which could be causing this action?

Have you by any chance tried running the full version of Roon on the PC (without RoonServer)? The “All-in-one” version of Roon also has the ability to act as the Core if you want to give that a shot.

If you are happy with the current resolution though, further troubleshooting is not needed, I just want to make sure that we reach a mutually acceptable outcome here.

Hi @noris,

I have no additional firewall installed and I have tried disabling Windows one. It did not help with missing images.

I have tried all-in-one installation that you have advised. It works like a charm. I am happy with it. Thank you for your assistance!

1 Like

Hi @Adam_Arczynski,

That’s great news and you’re quite welcome! Thank you again for providing concise and relevant information in your responses, it was a pleasure troubleshooting this issue with you. If you have any further difficulties feel free to let us know and we can take a look. Until next time, take care!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.