Impossible to change track titles

I have imported a 3 disc album of which some tracks are showed with a track title that is not from my file, not from Roon and can not be changed.
The track title shown is:
No. 3, Dank, König, dir
The track title on the edit page as Roon’s title:
Lohengrin: Act 1: Dank, Königm die, dass du zu richten kamst!
The track title on the edit page as my file’s title:
Lohengrin, opera, WWV 75: Act 1: Dank, Königm die dass du zu richten kamst!
My manual change is:
Lohengrin: Act 1: Dank, König, dir, dass du zu richten kamst!
The shown track title can not be changed!

Pieter dVR

Have you set the track’s metadata Preference to prefer file data?

I have tried to do that too, but it doesn’t hold this choice after Save.

In fact thera are two questions: @support

  1. Where does this shown track title come from?
  2. Why can’t I change the track title?

Screen shots please.

I have a suspicion.

Title of the file:
03 John Van Halteren - Lohengrin, opera, WWV 75; Act 1; Dank, König, dir, daß du zu richten kamst!
Screen shot player window:

Screen shot edit window:


Screen shot files:

  1. It comes as a consequence of Roon IDing an album. To revert to file data only, un-ID the album, I.e., click “nothing seems right”.
  2. You can change the title of a track, but leave the album unIDed. As I understand it.

Also, I suspect having `two semicolons or colons in the tracktitle may be mucking things up. Try changing the second one to a period.

Note that,Roon only has one indenting.

All tracks have the same format of titles. It doesn’t explain why some titles are right and others are wrong.

Hope you get it figured out.

If this is a Tidal album, pass along the title and conductor. I may take a crack at it.

It is a 3 cd set of Lohengrin by Royal Concertgebouw Orchestra directed by Mark Elder.

To be sure, something funny is going on here, but I don’t think this is a reason. I have never had problems changing the title of a track on an ID’d album

I have no problems with tracks of other CD’s either.

The three CD’s have in their directories a somewhat different format.
The second CD’s format is:

The third CD’s format is:

Perhaps that ccould be a reason for this behavior?


I dont know how, but could the permissions of the folders have been set up differently? Could CD3 be read only for Roon user?

The difference between the formats of the three discs came from dBpoweramp. I did the rip of the three CD’s and they resulted in these three sets of files. I copied the files to my NAS.

That was a rubbish suggestion from me anyway; Roon never alters the original file, only the database.

That comes from Roon’s metadata of the composition. If you edit,goto composition that’s what is shown.
You should still be able to override this however

Ok, I give up. I’ve just imported Kempe’s Lohengrin from Tidal, and I get exactly the same problem as @pieterdvr

Unless I disable multi-part composition grouping, I cannot rename a track. (And by the way, I get track 3 as
Lohengrin: Act 1. Scene 1. Danke, König, dir, daß du zu richten kamst! )

Roon knows best?