Incessant stutter. Playing thru Bluesound Node - So why is this happening?

Thank you. I will see if I can make hay with any of that. I HAVE moved the AP around a bit, only putting it close to the Node in my most recent experiment.

Just for a data point, until yesterday the google was atop a 6’ high shelf, and the node is at about waist level on a shelf about 2’ away. But I will play with that and see what happens. Thanks again.

I had the same problem - with Google Mesh.

Router hardwired to one main dumb switch and several other switches & devices connected to that.
Router hardwired to Google (Nest) WiFi Router.

The result was that I had a new WiFi (mesh) network which was much stronger, but that it creates another subnet - so my Roon Core (on a NUC) wouldn’t communicate reliably with my Google mesh-based remotes.

Ditched the Google stuff, bought a more up-to-date Router (AVM FritzBox 7590) and have had no problems since.

1 Like

If @ipeverywhere’s suggestion doesn’t help, I think the next step might be to try the Bluesound direct wired into the switch again, and see what works. If that works - Bluesound app and Roon - I think we’ve confirmed flaky WiFi on the Bluesound. And at that point, a TPLink RE450 as suggested earlier is probably the best (because it’s cheaper than an additional mesh point with an RJ45) alternative to going out in the snow.

** can anyone confirm a TPLink RE450 plays nicely with Google mesh?

Edit - as to what changed to break something that was working before, it wouldn’t surprise me if the Google kit updated itself without telling you. I’m guessing, obviously…

1 Like

I have a FRITZ!box as Router an two Fritzrepeater 1200 (with RJ45-Ports connected to a Pulse flex, no problems since then! Player are found in the BluOS-App and in Roon)

Easy, not to expensive. But in general: try to avoid to access your player (clients) via WLAN…

Hope you find a solution!

1 Like

You’re not the first person to be frustrated, to the point of giving up, about Roon with Bluesound

One has to be careful not to paint with such a broad brush. The product line of Bluesound and NAD is extremely broad. What has caused so many problems in these products is Bluesound/NAD taking advantage of Roon’s previous looser policy to claim certification when in fact many things were not working properly. And then they took years to fix issues and only really started to clean things up when Roon took the hard stance that you’re not certified if everything isn’t working and you’ll lose it it you don’t. This was the right answer IMHO… but NAD/Bluesound should be blamed for taking so long to prioritize fixing issues.

Having said all this you still have to do proper diligence to make sure you’ll not have an issue (which is good practice for any device you buy if you’re using Roon)…

I have 10 NAD CI720s with bluesound and 2 Nodes that work flawlessly in a wired fashion.

Many users have reported that the current Bluesound products are working much much better with wifi after a recent firmware release: BlueOS 3.10 released 18/8/2020. Of course that doesn’t help the OP with wifi problems with his Node.

And I’m not aware of users have problems with most Bluesound devices if they wire them.

The issues with the Gen1 NAD CI580 have never been addressed and it doesn’t work wired or wireless.

I could go on… but my point is there are some great products from NAD and Bluesound and if you’re careful in what you chose, do proper diligence and set them up properly you’ll likely never have issues (like me), but you can get burned if you’re not careful. But I would not rule out using everything from Bluesound/NAD…

1 Like

For me, with a Roon Nucleus and 2 x NAD CI580’s wired together in a rack with a UniFi Gigabit switch, it was absolutely unusable to the point where we ripped out the Roon and just went with BluSound because it at least works for the client.

I ordered a Rpi. We’ll see how it goes before I return the Node.

1 Like

I noted the specific problem with the CI580s in my post.

So the tech over at Bluesound just suggested I try using the BluOS app to play through the Cambridge CXA61. Which I will do as part of a trouble shooting diagnostic. Interesting thought which raises a question—assuming there’s any difference discovered.

IF that makes a difference, could I set up the BluOS as a Roon zone so that I could then access the 750gb local library that’s on a SSD attached to the NUC thru BlueOS? So that instead of seeing Node as a Roon zone, the zone would be “BluOS.” And if it can be done, would that matter? It would seem to me that the Node’s wifi circuits are still in play. But if it can be done, and if it works, then that would let the Node’s wifi off the hook and point to Roon software as the culprit? Maybe?

I think this may be part of a Bluesound buck-passing effort, as he wants to blame Roon, while Roon wants to blame Bluesound. (Both of which seem to let Google wifi off the hook, but since the Node playing Roon is the ONLY place in the house with a problem, I think Google gets a pass here.)

Bluesound has passed the buck for years. It took them over 1.5 years to fix their sync problem and until it was fixed with a firmware update on their side they continually blamed Roon. While my NAD CI720s and Bluesound Nodes work great for me in a wired state, I would never buy a product with BlueOS in them on a promise of future functionality or a promise to fix a current bug. I don’t believe anything that comes from them about the future and I don’t believe them when they pass the buck.

1 Like

Follow up. So I just went to play thru BluOS and lo I notice that “Roon” is (I guess) a source option in the sidebar.

So now I’m completely flummoxed. So I go to Roon. Choose an album in the local library. (Allman Bros Fillmore East, just to keep a constant reference.) Play. Leave zone wherever it already was. Go to BlueOS. Choose Roon in the sidebar. Allman Bros coming out of Cambridge CXA61 with NO STUTTER.

WTH? What is playing what? I have no local shares set up on BluOS, so it has to be coming from the NUC over wifi.

Talk about friggin’ ghosts in the machine.

Can anyone explain this? My mother always told me that “you don’t have to invent the telephone to use it,” which was her way of saying “if it does what you need it to do you don’t have to understand it.” But after almost a week of dealing with this, to stumble onto an apparent “solution” as a result of blind luck, but which I don’t understand even a little bit is a sharp kick in the head.

Screen shot of signal path attached.

1 Like

I guess that begs the question ‘how were you doing it before?’…

Great question.

On one of three iPads that I have. Which is the only iPad that has BluOS installed at the moment because that was the one I used to set up BluOS when I bought the Node.

Here’s the sequence that I WAS doing before. In Roon on iPad. Choose album. Tell it–in Roon–what zone to play to. I.e., Node. Stutter. I’m pretty sure that is how Roon is supposed to operate…except for the stutter part.

Or, on a MacBook Pro Roon app, choose album, send to Node while in Roon. Stutter. That MBP doesn’t have BluOS installed yet.

Now…

In Roon. Choose album. Switch to BluOS app. Choose Roon as the source. No stutter.

What I guess that means is that in order to avoid the stutter, I need to start music using BOTH apps. I guess I have to now download a BlueOS app to two other iPads, two iPhones, an iMac and a MacBook. It also means that no one in my family will ever use the system because no one has the patience to go thru this Rube Goldberg process just to get a decent signal.

Does that make any sense at all? Why would the direction/sequence of the two apps working together matter? Especially when the issue seems to be the wifi signal?

When you configure BlueOS device within Roon it will appear as a source in the BluOS app. There is some interoperability. When there was a sync issue with BluOS devices within Roon you could group them in BluOS and then Roon would only see one device and this was a sync workaround. You can also start and stop something your originally started playing in Roon from the BluOS App. I believe this is just a side effect of the integration with Roon and it really not intended to be in any way a normal use model. You should be doing everything in Roon except kicking off firmware upgrades of your BluOS devices from the app.

In regards to why you’re seeing no stutter when you’re kicking off play in the BluOS App on an album you’ve selected in Roon… I’m guessing you’ve also got your music loaded in the BluOS app (meaning you configured where your music library is from within setup in the BluOS App). If yes, I’m guessing that BluOS is likely playing the album itself…versus via Roon and thus no stutter, but this is just a guess and again is likely just a weird side effect of the integration but not an intended design flow. I can’t test as I don’t have any my BluOS app configured with any music by itself…

And I gotta say, I can’t accept that as a solution. Just a workaround. And a completely illogical one at that. Like figuring out how to arrange a bunch of random levers and buttons in a video game that makes the door to the dungeon open. Accidentally discovered, with no explanation. And I’d bet not replicable in another system.

I get the sense that a lot of the folks on this forum are pro audio folks who may work with clients to set up systems. Would any of YOU accept that as a solution? (And I’m not sure that a hardwired connection between Roon and Node would fix it given how wonky this workaround turns out to be.)

As of now, the Node is STILL getting the same wifi signal. It’s just that it’s not stuttering if you push the levers and buttons in the right sequence.

Re local library loaded in BluOS. No. I’ve never set that up as it seemed to me to be redundant.

I used the BluOS for the sole purpose of getting the Node onto the network and then never used it again. Once it was on the network, Roon automatically detected it and I had no further use for BluOS. Until the other day when I needed to factory reset it, and then this morning when Tony from Bluesound suggested that I try it the other way around.

Here’s another one… Roon always dropping out after about 30 minutes or so. Now all Qobuz albums have disappeared

The simple fact here is that you use BluOS devices wirelessly at your own risk. They are flakey or just don’t work. I still think the only fix as I’ve said earlier is just to get it wired. You’ve tried everything but actually running a long wire temporarily to your Node 2 and see if that fixes it. If it does (and I will bet it does), then doing that permanently is the only way to fix. And while the Node2 wireless is especially flakey, it is still a fact if you want to setup a trouble free Roon system - no matter what the manufacturer – wire your devices. I know you don’t want this to be so, but it just is. You should stop beating your head on this.

1 Like

I get it. It’s not so much a matter of beating my head. It’s just not logistically possible until snow melts and I can safely use ladders. And I don’t know about your world, but my wife isn’t about to stand by while I start drilling holes in floors and walls. Frankly, climbing a 30 foot ladder in 6 feet of snow would be infinitely safer. :wink:

I take it she couldn’t stand a temporary cable being run?