Incorrect computer name

@support How do I fix the incorrect name roon has assigned one of the computers I have running rune? Under settings -> audio all of the computers running Rune have the correct name except one MacBook Pro! It seems it should be pulling the network name but it is not. Is there a way to manually change this name it is showing?

Roon ver 1.5 (build 354) 64 bit

If the Pro is running core then Settings->General->Core.

In Settings->Audio Roon is getting the name from what ever you called the Pro in the Pro’s settings.

The core is not running on the macbook pro that is being displayed incorrecy. The core is running from a mac pro desktop server. I actually have 1 other macbook pro and 2 dell desktops also runnning roon and those names are displaying correctly. Just 1 of my macbook pro shows the incorrect name under the audio settings!

Hmm, the name that is in System Preferences->Sharing->Computer Name should be the name that Roon uses, but I guess that’s what you’re complaining about.

You’re sure about the name that you used there?

Sorry, that’s all I got.

The name of the macbookin network sharing is not the name roon is giving the macbook. I want to know how to manually change this name that roon is showing using a terminal command. I need one of the actual programmers to tell me how to fix this!

Hi Tim,

Can you upload screenshots of Settings/Audio and of a view of your network showing device names ?

You dont need a programmer :smile: I am sure we can help you figure out the issue.
Once you go to sharing and you make the computer name change make sure you click edit and edit it there.
Once thats done reboot your laptop. Give it a try and report back :smiley:
I am tagging @support for you :slight_smile:
Good luck!

The problem is something in roon not getting the correct netbios name from mac OSX (if that is indeed how it gets that name). There needs to be a way to manually override this setting anyways! You can choose your own name for all the audio shares but not the computers thrmselves. But just to reiterate my problem, i have 5 (FIVE) differnt computers running roon (and 1 additional running bridge) and only ONE of these is not displaying the correct name assigned to that computer (a macbook pro) in the roon audio settings. That macbook pro’s name displays correctly in every other situation (in file manager, drop box, etc). Only thing I can think of is to completly reinstall OSX on that mac and than reinstall roon. (I only use it for roon by the way). The weird thing id roonis calling the computer “picklgreen”. The computer name is Macbook Pro A. I dont even know where it would have gotten the name picklgreen from!! Thats not even my login name for rune or that mac.

Didnt work. I have already tried this anyways but I did it again anyways. I unistalled roon. I changed name of mac. Rebooted. Reinstalled roon. Reconnected to core, setup audio device, etc. Roon is still calling the computer Picklgreen!! Where is it getting this name from?

Try rebooting the router and any switches - maybe its cached incorrectly somewhere

Step 1: In the Menu bar, go to  > System Preferences…
Step 2: Click on Sharing.

Step 3: In the Computer Name box, type in the name you want to use for your computer.


Step 4: Check On “Ethernet”.
Step 5: Close the window.
Step 6: Restart the Mac.
Step 7: Close and then re-open Roon.


Does not have any effect at all. I have tried changing the name, rebooting, reinstalling roon, everything. I need someone who actually works for Roon to tell me where it is taking this name from! It not getting it from the OSX system properties that is for sure! Something tells me it has something to do with the DNS name associated with the computers IP address.

Ok - Well lets tag @support


Hey @Tim_Hayes,

@MikeD’s suggestion above was correct — We pull this information from System Preferences > Sharing > Computer Name. Since that’s not matching what’s in there currently for you, it sounds like something else may be going on.

Was this Mac at any point ever named Picklgreen? Was this a recent change? Have you tried rebooting your Core machine?


No the computer has never been named Picklgreen. I have rebooted the core several times. I will try completely wiping the macbook and doing a fresh install of OSX and see if that fixes it.

What is the provenance of this Macbook?

Goggle Picklgreen to see if that rings any bells.

Is the IP for that machine that Roon displays correct?

@dylan is as close to a Roon programmer as you’re probably going to get, so when he (and others) tells you were Roon gets its macOS computer name from, that’s probably it.

Unless someone put a hack (whether gag or nefarious) on your machine, rebuilding the OS seems rather drastic.

curios as to if you have shutdown and restarted everything else on the network, like router modem and switches as I suggested some posts back too.

Ok i fixed it. It required deleting the Hostname key from Library/Preferences/SystemConfiguration/preferences.plist and than renaming the computer under the sharing setting. I also figured out what was the cause to begin with.


So, you must be the Picklgreen that shows up in Google?

BTW - After a brief search -

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.