Indexing - I want to switch it off - How?

Hey, Roon, how can You explain these numbers? And the number of files scanned is still growing? The number of tracks imported remains the same. Photo shows the numbers after 6 hours Roon indexing. We’ll see, what it shows in the morning. Have You installed in Roon the permanent loop of indexing of the same tracks? Why? Why is it not possible to stop the indexing work in Roon or to set it for example once a year. It serms to be a very hard work for Roon program. Can I switch this anoying indexing off? I have to mention, that listening to the music while Roon is indexing millions of files from under 150000 Tracks imported - it’s a crap. Help me please, I want to switch the indexing off and I Want only to listen to my music…image

1 Like

Me too.


I’ve moved your topic to the support section of the forum.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Sounds like Roon is choking on something in that directory. This can happen when it gets into iterative loops. A common cause for this is a backup being located in the same directory Roon is watching. Until Roon Support guys get their eyes on this it might be worth checking for that.

1 Like

Hi @Gustaw_Zaleski,

Can you please share a screenshot of your Roon Settings -> Storage tab and a screenshot of the contents of the Multimedia folder? Also, what does the rest of your setup look like? Please use this thread as a guide to provide more info so we can better help:

Hi, Thanks for trying to help me. After the night Roon communicated, that download is complete. It would be the best option for me now, if I could switch the whole indexing off and eventually run it manually in future if needed (for example after ripping of few new CD’s).

Yes, my NAS (Qnap TS-453BT3) is 20 TB (4 pocket) and I have on it not only Music for Roon, but also Music bought 10 years ago from iTunes, Music bought recently from HDTracks, movies downloaded from Apple TV and manuals for HQ Player (this in Multimedia folder). I use also my NAS for back-ups (but the back-ups are in separate folder, not in Multimedia). But I’m sure, that I don’t have one milion files on my NAS.

I run also on my MacMini (i7, 3,2 GHz, 32 GB RAM DDR4, 250 GB SSD, from 2018) Kaspersky Internet Security, Kaspersky Password Manager, Kaspersky Secure Connection and Clean My Mac app, but I don’t think, that any of these should cause any problems for Roon Core. These problems (with chocking on indexing) appear since few months, after one of Roon updates. What I only need, is a „switch off” button in Roon for all indexing (I would prefer to run the indexing manually - when I need and want to - for example over the night - and not when I want to listen to my music). Can You please add such „switch off” option for indexing to the next Roon update?

What are those @Recently-Snapshot & @Recycle folders in your Multimedia folder for? Since you have told Roon to watch the Multimedia folder, it will be watching those as well. If they are not for holding your music files in your Roon Library, these may be confusing Roon…

These are Qnap system folders for back-ups (like TimeMachine on Apple). I have switched the back-up in Qnap off and these folders are really empty (0 KB).

Qnap is connected via CAT5 ethernet home network using Apple AirPorts and Edimax switches. Neither Qnap, nor MacMini (with RoonCore) are connected straight to the modem. It’s impossible in my location - I have a modem in one room, MacMini in another and noisy Qnap in another. I have checked the speeds and connections on my ethernet network with profesional IT-guys and they have said, that everything is running very well and fast enough for music files and movies files. The only thing, I really need, is a „switch off” option for Roon indexing, so I can run the indexing manually, when I need and want to - I would prefer to make decisions on myself, when and if I start the indexing work on Roon.

And - Yes - it happens every time, I start Roon from my iPad and select the path (Zone) and the Music to listen to…

Hi @Gustaw_Zaleski,

Thanks for the screenshots.

Are you certain that they’re empty? I’ve activated diagnostics mode for your Core and what this action does is automatically upload a log-set to our servers. I’m seeing Roon try to scan your @Recently-Snapshot folder and it doesn’t look empty according to the logs:

06/10 21:51:58 Warn: [storage] While reading playlist /Users/gustawzaleski/Library/RoonMounts/RoonStorage_b63db8d7d557050e01f13cf8ca8ee0cb4b00c1c4/@Recently-Snapshot/GMT+01_2020-05-31_0300/iTunes/iTunes Media/Movies/Polowanie Na Czerwony Pazdziernik/01 Polowanie Na Czerwony Pazdziernik.movpkg/2-GQ5EVXCVDKJ6ZFOBAAW7A6E7TBIGKGTI-0/2-GQ5EVXCVDKJ6ZFOBAAW7A6E7TBIGKGTI-0.m3u8: System.ArgumentException: Illegal characters in path.
  at System.IO.Path.IsPathRooted (System.String path) [0x0001b] in <ba70b91736bd40cb990a357097dba9c3>:0 
  at Sooloos.Storage.StorageUtils._MakePlaylistTrackPathAbsolute (System.String dir, System.String trackpath, System.Boolean skip_absolute_paths) [0x00050] in <b81db56bde3648e6bc033ef6233a519a>:0 
  at Sooloos.Storage.StorageUtils.GetPlaylistInfo (System.String path, System.IO.Stream stream, System.Boolean skip_absolute_paths) [0x0012c] in <b81db56bde3648e6bc033ef6233a519a>:0 

Also, it looks like you have Roon scanning your movies under /iTunes/iTunes/Media/Movies folder, and the .m3u8 in your movies folder looks like it’s confusing Roon:

06/11 20:32:47 Warn: [storage] While reading playlist /Users/gustawzaleski/Library/RoonMounts/RoonStorage_b63db8d7d557050e01f13cf8ca8ee0cb4b00c1c4/iTunes/iTunes Media/Movies/The Town (2010)/The Town (2010) 2.movpkg/2-5UFB432ZNSO4WZ2WFUQDMA5OZVYYMYKS-0/2-5UFB432ZNSO4WZ2WFUQDMA5OZVYYMYKS-0.m3u8: System.ArgumentException: Illegal characters in path.
  at System.IO.Path.IsPathRooted (System.String path) [0x0001b] in <ba70b91736bd40cb990a357097dba9c3>:0 
  at Sooloos.Storage.StorageUtils._MakePlaylistTrackPathAbsolute (System.String dir, System.String trackpath, System.Boolean skip_absolute_paths) [0x00050] in <b81db56bde3648e6bc033ef6233a519a>:0 
  at Sooloos.Storage.StorageUtils.GetPlaylistInfo (System.String path, System.IO.Stream stream, System.Boolean skip_absolute_paths) [0x0012c] in <b81db56bde3648e6bc033ef6233a519a>:0 

This is a pretty common occurrence with many folders under the /iTunes/iTunes/Media/Movies, I’m seeing Roon try to scan the playlist files under these folders and this is very likely why you saw the “runoff scanning” taking place.

I’ll check with the technical team to see if this is possible or if this is a feature request, but the best solution here would be to only have watched folders added that contain music files. You can manually specify the different folders under Roon Settings -> Storage for the share, and I would omit the folders with non-music content.

Wow. Thanks very much. I have changed the preferences in Roon storage and have chosen 3 folders only with Music files. Now I’m waiting for Roon to accomodate to these settings - it will take a moment. I will let You know, if this has helped - I hope, this could be the solution. Will it be possible, that You run Your check once again - after I will let You know, when Roon finishes adding Music to library and scanning files after I have changed the preferences?. It will be helpfull to know, that I have made everything correct - according to Your helpfull guidance. You were right - Qnap after last system upgrade has switched on the automatic security updates and snapshots and the snapshot-folder had two recent snapshots. Qnap itself reported also one corrupt file (perhaps it’s the same movie file, You have mentioned - The Hunt For Red October from Apple TV - I will allow Qnap to run it’s diagnostic in the night.image

1 Like

Hi @Gustaw_Zaleski.

Happy to help!

Sure, I can take another look at diagnostics once the system has settled down for a bit, it’s good to give it a few hours to settle down after making the storage changes. Do let me know how it’s going and if the changes have cured the initial issue!

Thanks once again. The previous problem is solved. The indexing runs fast and smoothly. No problems at all - the Numbers of Tracks imported and scanned are the same. Now I have a small new one. It seems, that Roon has imported all files from both folders „Music” and „HD Tracks”, but has not imported any Music track from folder „Apple Music”. I have also tried a trick - I have copied one album from folder „Apple Music” and put it to the folder „Music” and forced rescan of folder „Music”, but it hasn’t helped. I have also forced rescan of the folder „Apple Music”, but it hasn’t helped. I have restarted Roon on MacMini and Qnap NAS and have made all these steps and tricks once again - with no success. Roon recognizes the folder „Apple Music”, is connected, and - in storage settings - is watching for New files in Real time, but hasn’t imported any single Music track from it. In „Apple Music” I have the files (they are all m4p), that I downloaded from Apple Music (where I have a subscription), but I haven’t bought these Tracks on iTunes. Perhaps these Tracks have security add-on and this is the reason, why Roon can not import them into Roon’s library. Can You look at it please? Perhaps You know also the solution for this problem…

And please run after few hours the diagnostics on my Roon Core - to check, if now, after changing the settings in storage preferences, everything is ok.image image image image image image

You can tell Roon to exclude sub folders for scanning which is best policy if using a QNAP as it will read the @recycle and other folders . Set what you want it to miss out in ignored paths.

1 Like

This is in the “Ignored Paths” list … just visible in the screenshot you post, so Roon will correctly ignore “deleted” files that the QNAP has moved over.

Thanks for advice. I have solved the indexing problem with specifying folders only containing the Music files in the storage settings. Now I have only the problem, why Roon does not import to the library my m4p files from one folder.

1 Like

Yes, I would suspect the security might be part of the issue, can you upload a couple of them to Dropbox / Google Drive / and private message me a link (click my name -> message) so I can check if they work my end?

Yes that was what I was saying, although reading back my post apparently not.

1 Like

Funny I no longer use my nas so thats a left over from when I did.