Inexplicable warning

Core Machine (Operating system/System info/Roon build number)

Mac OS 10.13.6/Roon Version 1.7 Build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity Gateway Router w/ Zyxel power line adapters

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio DS DAC w/Network Bridge, ethernet connection using Zyxel equipment above

Description Of Issue

My Roon account is set up for automatic updates and I have the latest version. So what in the world is this warning I’ve just received (see attached screen shot):

Hi @Geoff_Mirelowitz,

If you reboot your Core machine does this error go away?

Now that I’ve tried that, yes.

What was the cause of this?

My guess is that the service that runs the metadata update had stalled.

Thanks very much.

@Geoff_Mirelowitz – I get the metadata improver halted message when I switch cores (using a single license). Goes away on restarting Roon on the switched-to core.

I’ve assumed it is an authentication issue, which then causes the metadata service to balk at providing info to the new core. If that assumption is correct, then an authentication issue might be what’s causing it for you. But I suppose there could be multiple reasons for the metadata service to stall.

Not sure if that’s at all useful …

[See Switching daily between Roon core on work vs home computer? for a long-ish thread that mentions this issue, if you’re interested, although it won’t provide any solutions].

Thanks. I have only one core.

I should have thought about rebooting the iMac (where the core resides). I frequently have another problem – which appeared at the same time in this case – where Roon shows that logging in to my Tidal account is stalled. Yet when I open my Tidal account separately it is clear I am logged in to Tidal.

A reboot of the Mac often fixes this, but it is an annoying problem that comes up too frequently.

Thanks for the details, @Geoff_Mirelowitz. Our team is looking into this and we’ll be sure to include your report as we continue our investigation.


Thank you.

When I get the message, simply restarting Roon suffices to get rid of the warning – I haven’t needed to reboot the computer (which I would consider far more troublesome). I assume you’ve tried just restarting Roon, and in your case that doesn’t work…?

Yes. I have tried just restarting Roon and that has not worked.

I switch my cores frequently. That message comes up with every switch. Stopping the core and a restart always cures it.

What is the purpose of switching cores?
How is that done?

I like to experiment with different setups of my equipment. Normally I run the core on my Antipodes EX server. When it is being used for another setup ex: running MPD/DLNA then I run my core on my MBPro server. To change cores I goto setup and disconnect the core. It then shows me all cores running on my network. I select the one I want. I am then prompted to unauthorize the current core. Voila… I am connected to the new core. Unfortunately I then get the warning described above. A restart of the new core always fixes it.

Thanks. As far as I understand all of this, my iMac is the only potential core for my system.

The thread I referenced earlier (Switching daily between Roon core on work vs home computer?) explains how to switch cores.

The purpose (for me) was to use Roon both at work and at home. Another scenario in which I might switch cores is if I experience internet issues when at home. In that case I can move my local music (which is on an external portable disk) from my Roon-dedicated computer downstairs to the computer upstairs that I’m working on, and switch to the core on the upstairs computer. Then I can still play at least my local music.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.