Infinite loop of "There was an issue loading your database" even after restore

Roon Core Machine

Windows Server 2012R2, Intel i7-3770K, 32GB

Networking Gear & Setup Details

DrayTek Vigor2860L + VigorAP 910C

Connected Audio Devices

2 x PC
2 x iPhone
1 x iPad
2 x RoPieee
1 x Oppo UDP-203

Number of Tracks in Library

450,000 tracks

Description of Issue

My Roon instance appears to have corrupt my database.
I have reinstalled Roon and have attempted to restore the database

It is now is in an infinite:

  1. I run roon, it say it’s corrupt please restore
  2. I restore the DB from my backup
  3. Restart roon
  4. goto 1

Any idea what I can do. Are there logs with more info?

Unfortunately it sounds like the backup you are trying to restore is also corrupted.
Can you try to restore an older backup?

What build is the Core on?
B884 is the latest.
If not on that version I would advise an update to that first.

hi @AceRimmer , thanks for the tips.
Software is the latest, i just installed the latest.

I have tried going backward through the backups.
The 5th one worked for about 3 minutes, a now I am back to the “there was an issue loading…” screen
Also, I now have no Audio devices showing up at all.

Reinstalling the app seems to still have left my system in a bad state (backups not working, no audio devices)
Is there a way to do a proper clean?

You could try a complete uninstall of Roon and then start again fresh.
It does sound like your database may be corrupted though as has happened to a few members on this latest build series which is now actively checking for db corruption and will not proceed if it detects it.
You might have to start fresh and not load an old db backup.

I had a second slightly older backup set, and restoring that seems to have worked
Thanks for your help :slight_smile:

1 Like

Great to hear!
Glad you had a good selection of backups to work with.

A good example of just how important keeping backups is.

Enjoy your music.

Different hardware (headless Mac Mini running Roon Server), but I’m having a similar / same issue since ‘upgrading’ to 1.8. I have multiple back-ups that I’ve restored from prior to 1.8 without issue. I’ve tried a clean install and restoring the database and it works for a short period of time, but I keep getting the dreaded corrupt database dialog forcing me to restore from a back-up. Rinse and repeat over and over and over. I’ll try a clean install next and start from scratch rather than going through the slow and tedious process of restoring from backup yet again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.