Initial install - when to give up!

Just put together a rpi3 with allo boss dac. Flashed a micro sd with latest ropieee and turned on. Did not do any other software installation. It says in the documentation install will take about 4 mins. It’s been flashing away for about half an hour now. Is this normal? When do I give up? What do I do if I give up?Flashing is fast and irregular, not the steady 1 hz flash. Haven’t connected an Ethernet lead yet, does this need to be done prior to installation? Did I need to install a driver for the dac first? If so, do I need to install some other OS software to enable this?
Many thanks…!

So although still fast flashing, I decided to plug in the Ethernet. And ropieee showed up on the network browser. Selected the allo boss dac and rebooted. Nothing showing up in Roon. Also rebooted my ROCK core, switch and router, still nothing. Tried the Ethernet cable from my sotm which I know works - still nothing. DHCP is enabled but there is no IP address or gateway showing up on the network page…is this normal? Any help to get this up and running would be greatly appreciated.

If I remember right, you need the ethernet connected when you boot because it goes to get updates right away. It slso reboots a few times during the install to configure itself and apply the updates. Mine also took about 25 minutes or so for the full install. Mine has a touch screen also so that might be why it took so long.

You also need to remember to enable the extension in roon.

Thanks Bear. I cannot see an extension showing up in Roon. Under settings>extensions right? Is the extension just for touchscreen or for Ropieee in general? I am (trying to) run without a screen.

I believe you need the extension for it to work with or without a screen.
Should look something like this in roon settings\extensions


Can you get to the webpage for managing ropieee?
Fromt eh Getting started page on the www.ropieee.org site:
“You can also visit the web page of the RoPieee to configure some items if necessary.
For that you need to either know what the IP address is of your RoPieee or you can visit http://ropieee.local

Yep. Can get to Web page. Have configured Allo boss and rebooted. Is it normal for no IP address to be showing up in the network section of the Web page? I sure don’t have any options in Roon on the extensions settings. Nothing discovered. At least I’m getting the steady flashing now…!

Mine is set to DHCP and all the entries say unknown.

Might try rebooting everything ropieee and ROON server and see if that helps.

What does you information page look like?
here’s mine.

Thanks so much for your help. I have switched everything off. And will turn it all back on in the morning and hope for the best. Optimism…it’s going to work…!
I will check out the information page. I’m not sure it’s got a much on it as yours.
My current theory is that I did not install a driver for the rpi to communicate with the dac. But maybe ropieee does that when configured…dunno, it’s all new to me!

If it does not work you might try re-flashing and hooking up the Ethernet cable when you start it the first time. I am sure spockfish (the creator) will be a long if you still have issues tomorrow. There are also a few others that know a lot more about it than I do hanging around that will chime in to help I am sure.

Extension is only if you use the lcd.

If your flash card is smaller than 4gb might be an issue, or if it’s not a spec 10card will be very slow

You must have the Ethernet installed when first booting…and it will take some time to update the first boot…give it 20 mins at least or more if your internet is slow

You will not see anything in roon unless you have a hat setup or usb dac turned on in the settings. Dac needs to be connected and on to show up in roon

The web interface will show if ropieee is running

Hope some of that helps

New dawn, new day. Followed your advice and reflashed sd card and reinstalled with the ethernet connected. Ah the joy of seeing Boss Dac listed in the Roon audio devices! Working a treat and sounds lovely. Running into a Valhalla 2 for headphone listening, going to add some small active speakers to the Valhalla pre out for a complete bedroom set up.
Thanks all for your help.

1 Like

Hi Max,

Nice that you got on board. I’ll need to put some more effort in the documentation I guess :wink:

Enjoy!

It was all fine except not realising had to be connected to the network for the install. Lovely bit of software, made for someone like me who wants to add affordable zones around the house without too much tinkering! Anticipating the wifi update for rooms that aren’t on the network. Thanks for all your hard work!

1 Like

Do you have a monitor hooked up to the HDMI port? You really need one, to figure out what’s going on.

No you don’t. RoPieee does not even use the HDMI port and disables it.