Innuous Zen Mini as Roon Core - any good?

Ok , have you tried any of the below to ensure the folder on the pc is shared across your network?

This sound more like a network sharing issue rather than a Roon issue.

I presume you don’t have a NAS?

1 Like

My gut feeling is the backup will relate to when the files were stored on your windows based Mac.

If they have been moved to the new server you may just have to create a new Roon instance pointing to the files in the new location.

You could do that while you wait for the support team to come online to confirm.

Hi, Thanks for all your suggestions. I have tried everything apart from using a USB thumb drive to manually copy the backup, which I will have to buy. I have tried to contact support again. I don’t think Roon are really interested in customers who want to use this product as a Roon core for some reason. I have looked into an Intel Nuc, which Roon recommend. It’s not the cost, they are pretty affordable, but I just don’t want another 2 devices (NUC+external drive for media) to plug in and find a home for etc. when the Innuous Zen can apparently work just fine (without DSP which I don’t need)

1 Like

Why would Roon want to officially support something that doesn’t meet their minimum specification?

And again it is not a Roon issue. Whether Roon can see your Windows PC shares is a problem between the OS the Roonserver is running on and the Windows OS the share exists on.

If the Zen uses Linux, then there are things you need to do to the Windows PC hosting the shares, before those shares can even be added to Roon.

Unhelpful, thanks. This has nothing to do with that anyway because there are plenty of users who say it works. So do Roon. They just don’t support Innuos as a fully fledged Roon Core because it doesn’t cope with heavy DSP processing/multi room DSP. Everyone else who is actually using it (IE not you) says it works just fine. The problem here is to do with the way Roon handles networking (or not) and access to Roon Database Backups. It should be easier to use than this or the error messages should be clearer. This is nota user friendly product when it comes to set-up and maintenance.

Blimey, sounds like it is time to give in. I have no interest in becoming a Windows/Unix networking expert.

Although, what you just said there sounds like it could be the reason Roon server doesn’t work as designed when sitting on a non Windows/Mac machine. Perhaps there should be a warning message saying not to expect browsing the network to work if the core is installed on a Unix or some-such device not configured properly for Roon. Crikey, who knows?! I’m losing the will.

Don’t get me wrong, I love Roon (once it’s setup and running ok). It’s bl**dy incredible and does stuff no other music system I know of does. I wouldn’t be persevering with this nightmare otherwise. I just wanted to restore a Roon backup onto a very good piece of audio equipment, which happens to also store my music library, instead of using a low powered PC, so I can get shot of that. I really don’t want to have to purchase, setup, maintain an Intel NUC/PC which isn’t useful for anything else, takes up space, is noisy, etc. etc.

OK, Ill have a try to help @Robert_Borley.
I have a Zenith, recently sent it away to have some work done on it, so when it came back I needed to restore my Roon Back Up.
So in Settings\BackUps\FindBackUps you need to set up Roon to find the device and the Shared Folder where your Back Ups are kept on your network. Mine are on my NAS.

This is what it looks like:-

Im also not massively an IT expert and was concerned I would not manage it, but it did work OK.
I think as others have said, there may be a firewall stopping Roon from seeing your PC, or maybe the file path you are typing in is not in the format it needs to be to find your PC.
I typed in the wrong path myself and had a panic, but once I got it straight, it was like ‘Open Sesame’!

The other point that has been made a couple of times is that the Innuos is not up to the job of Roon - it definitely is, Ive had mine for a year and no performance issues that Ive experienced. By the way, I do a bit of DSP in Roon, not a massive amount.

Good luck , hope you can get it sorted.

1 Like

Thanks. The only thing I haven’t tried is using the PC’s IP address instead of the name. I will give that a go and see what occurs. Mind you, I dont even now how to find out what the PC IP address is. I remember something about an “IPCONFIG” command from back in the MSDOS days. Sigh!

Thanks for trying to help me and most of all, being someone who enjoys running Roon on Innuos devices. I am jealous of your Zenith, but I have an LPSU on the way from Father Christmas hopefully to give my Zen Mini a boost! Loving it!

1 Like

Try Fing app, that will confirm the IP address for all devices on your network.

There’s a free program called Fing that runs on many platforms that will find everything’s up address.

Sorry @ged_hickman1, looks like we posted at the same time!

Other thing to say @Robert_Borley, don’t forget the back slashes (ie. \) when you type your path. I’m no expert but I think you will need 2 of these before your IP address and then one after, in front of the shared folder on your PC.
Sorry if I’m stating the obvious…

Thanks (and @ged_hickman1) for that Fing app, its pretty useful, the way it can identify what all the devices are. Great tip! There are so many devices these days, I never believe the list on my router and could never figure out what they all were! Now I know!

Having said that I found my “media-server” PC IP address with the old IPGONFIG at the command prompt. About the extent of my networking skills I’m afraid.

That’s OK, don’t be. I only just figured that part out last weekend. Here’s what is being returned by Roon…

I’ve tried all manor of things, IP address followed by device name, network share, no device name etc. etc.

This is what it looks like from my MacBook… Looks fine to me. :face_with_symbols_over_mouth:

I’ve just cleared out some space in my old “free” Dropbox account because thats all the Zen Mini can see. Weird because everything else on the network can see the Zen Mini. It’s taking forever to upload the backup to Dropbox and I suspect forever to restore it from there (if it works). :crossed_fingers:

I just saw this in the KB about restoring from Dropbox:-

Seems Dropbox causes some issues due to its API…

But looking at your screen shots, might be a dumb suggestion but would your path not be
In my case the shared folder is Multimedia.
Just a thought…

Thanks! I’ll can the Dropbox idea! Thanks for letting me know that!

It keeps failing. But as it was the only thing I could get Roon to navigate to, I kind of thought it would work. Silly me! Might have to give up on the Innuous as a Roon Core for the time being. I looked at the Roon Nucleus, WAY overpriced! May as well get a new Mac Mini M1 for a lot less, at least it would have other uses and is a lot more powerful than the Intel nucs Roon suggests.

I tried that.

Ive tried…


All manor of things. I’m completely lost.

I think maybe @Rugby may have a point, in that the ZenMini runs on some sort of Linux/Unix thing and is probably not configured in a way that Roon likes. Although you seem to me fine navigating to your NAS. This is what I hate about networking. It’s never as straightforward as it should be (in fairness, as it is with MacOS and Windows).

Sorry, I haven’t been following this entire thread, but have you tried backing up from your PC to a USB drive, then restoring from the USB drive to your Innuous?

My point is that to point Roon to a share on your Mac or Windows PC, you have to setup the share correctly ON the Mac or PC. Did you review the appropriate Roon FAQ pages?

Yes @Rugby, I’m sure that is the issue Robert needs to sort out.

In my case my ‘Multimedia’ file is a Shared folder on my NAS.
If there is no designated Shared folder set up in the PC or MAC then Roon cannot see anything to connect to.

Either that or as I think someone said earlier there may be a firewall.
But my guess would be on your suggestion.

No I haven’t. I was hoping to avoid that, but am wishing I had just bitten the bullet and gone down that road in the first place. I currently have a USB stick in the back of the PC copying across the latest backup folder. Saying it will take over an hour as I initially feared. Then I have no idea how to get Roon to see the USB when it’s stuck in the back of the Innuous Zen Mini. Which will then take forever to restore it.

Also, this all seems pointless as the Roon server on the PC is regularly backing up to the ZenMini, so there is a copy on there already!

Is it just me or is this all a bit too painful? Rhetorical, no need to answer that!