Instability, crashes and no album covers on android devices

Core Machine (Operating system/System info/Roon build number)

Ubuntu desktop 20.04.1 LTS, Roon 1.8 (build 764)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

From 1.8 all my android remotes are in this situation (Samsung S9plus, LG G5, Samsung Tab S3).
Almost impossible to listen to music from them or browse my library using the device as a remote control

Another problem that often happens is that i have to close and restart the android client several times as it remains frozen in the startup screen with the word Roon

I haven’t seen any improvements with the various builds released after 1.8.

1.7 and earlier worked fine on all 3 devices.

Hi @Daniele_Piancastelli

Do you have any non-Android remotes? Do they exhibit the same issue?

Can you describe your current networking setup so we can better understand how your remotes are connected to the Core?

I also use 2 pc win10 that don’t have these problems (they had problems loading album covers before 763, now solved).
They are all connected via wifi to the core with the fritzbox 7530 router (ftth technology)

@dylan some news? Currently my 3 android remotes are unusable to browse my library

@dylan @noris @john

I’m very frustrated with this situation. Any help figuring out what’s going on? My experience with 1.8 is truly disappointing. Even with all the bugs (still present) at least with 1.7 android remotes i was able to use them without problems…

I’m in a similar situation. Bought a Nucleus and have discovered that it is basically unusable on Android, so is largely useless for me.

Hi @Daniele_Piancastelli ,

Apologies for the delay in getting back to you here. Can you please confirm if you are using any Plex / Emby apps on your network? We have seen Plex / Emby cause issues with covers loading properly on remote devices.

What does your network setup look like, can you please provide some more details?

No Emby or Plex.
These days i did a test by changing the server from ubuntu to windows 10. Now the stability has improved, crashes are minor (only happen on android).

The strange thing is that the crashes don’t only concern roon, but also affect other apps that running (zerotier, apps that force the fullscreen, etc …) and also, for example, the bluetooth connection with headphones or smartwatch. The only sure thing is that the crash comes from Roon.
The covers are loaded immediately and remain in memory on the machine where the server is running.

In my notebook (with windows 10) the covers load slowly. The loading stops when all the covers visible on the screen have been loaded, so i’ve to scroll until the entire library is completely loaded.
After that, even if i restart the notebook, the loading of the covers is almost automatic.

On android remotes no. Here the loading is very slow (even here i’ve to scroll to “help” the loading) and after 10-15 minutes that i remain on the album screen to load the covers, the system crashes. If i close and reopen the app, the upload must start from the beginning.
I didn’t have this cover loading problem with 1.7

My network consists of an FTTH connection managed by a Fritzbox router. The core is connected to the router via ethernet cable, the other remotes (and the notebook) are connected via wifi

Hello @Daniele_Piancastelli ,

Earlier this week we released a new build of Roon, can you please confirm if you’re still seeing this issue in our last release even if you reinstall the App?

If you still see it on the new release after reinstalling the app, can you please share a few screenshots of the issue and provide a timestamp of the date/time of the issue?


Hi @noris ,
after the latest update (778) android is much more stable. Only two or three crashes in the last few days.

There is still the problem of loading images as explained in the previous post. Now android no longer crashes, but the images have a hard time loading and at some point they stop and no more are loaded.
I made another video to better explain the problem. This is a samsung S3 tablet, but the situation is the same for all my other android remotes which are a samsung s9 +, an LG G5 and an ibasso dx200

Hello @Daniele_Piancastelli ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Thank you for sharing the video, this helps us understand the issue better. Unfortunately, your video does not contain the exact local time + date of the issue’s occurrence, which we would need to cross-reference in your Android logs.

Can you please let us know the exact local time + date + remote used when you next get into this state? Also, how are you DNS servers configured, can you confirm you are using non-ISP DNS servers, like Cloudflare DNS, Quad9 or Google DNS?


I found the problem. These are the scanned album images in very large files (they are in tif format). I thought Roon generated much lighter thumbnails than the original file. Instead it doesn’t seem so unfortunately. I solved it by generating a lighter copy in jpeg format but I hope that in the future there is an optimization on the use of images

1 Like

Hi @Daniele_Piancastelli ,

Thanks for letting us know that you were able to resolve this issue by using JPEGs instead of the TIFs.
Do you by any chance still have the TIF files? Could you send them to us and we’ll forward to QA? Thanks!

yes. Where can I upload them? (I only send some because they are very large)

If you use Dropbox, OneDrive, Google Drive or iCloud, you can send a link to the uploaded files in one of these services via a Private Message to Noris.

To start a private message with him, you have to click on his avatar icon, and press “Message”.

1 Like

Hi @Daniele_Piancastelli ,

I’ve also sent you a private message with an alternate upload location if you wish to use that instead, thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.