Instability in new Nuc setup [Potentially Resolved - failing SSD]

Having a problem with a new Nuc713iBNH setup. Bought from Amazon over weekend, together with 4Gb Crucial DDR4 RAM, 128Gb TCSUNBOW M.2 Drive, and a Seagate 2Tb internal hard drive. Installation and setup worked perfectly, and was soon up and running. Nuc connected to dCS Vivaldi Upsampler by USB, and really impressed with the sound improvement compared with running Roon from a Windows PC over a network. The situation stayed the same for 24 hours before the system started crashing. Started with a halt mid way through playing which could be restarted, but soon degenerated to point it was impossible to restart successfully and had to do a complete re-install. Lasted about an hour before same happened again, this time the ROCK server failing to start. Since then I’ve tried changing ethernet leads, connecting directly to Virgin Router rather than switch, removing the Seagate drive and using USB sticks, all without success. Beginning to suspect hardware failure now, but not sure where, Nuc, memory or M2 drive? Any advice as to what to do next? Really don’t want to give up on this, the sound when it works is so good!

Is your library still importing? Or is it still analyzing? What are your library settings (screen shot please) and also are you using any DSP functions like upsampling etc?

I’m assuming this is a new setup as you only joined here 5 hours ago,

@support is always a good idea as is following the recommended information to help with diagnosis. See the knowledge base here

Hi Mr Fix It. The library is not still importing, nor analysing, it had been running for over 24 hours without a problem. Library settings are default, I can’t get a screen shot because I can’t connect at the moment, despite a web page access to the core saying everything was running. DSP is turned off. If I listed all the things that had failed over the last two days, and the remedies I’d tried, it would be pages long. Most times, the only thing that fixes the problem is a fresh reload of everything, and that last for between 30 and 60 minutes on average before the sound output drops out, and the App disconnects. I said that this is a new ROCK setup on a NUC, bought because getting hold of a Nucleus in the UK is very difficult at the moment, a sign of Roon’s success I guess! However, I have been using Roon on a PC core for nearly two years now, so I do know how it should work.

@Stephen_Dilworth let’s see what support will offer up. I am assuming you have a NUC that is spec’d over and above what your library size is…but for arguments sake let’s determine what that is…how many albums / tracks do you have imported?

Hi @Stephen_Dilworth ---- Thank you for the report and the feedback. The insight is very appreciated and sorry to hear of the troubles.

Moving forward, it is a touch unclear to me what the issue is you are currently experiencing at the moment :innocent: In your initial report you had mentioned that ROCK had started crashing but in your follow it sounds like you are losing communication between the NUC and your remote devices, as well as having stoppages in playback. Am I understanding the current state of things correctly? If I am indeed, may I kindly ask you to please provide the following information for me:

  • The make and model of the remote devices that you are experiencing these disconnects with.

  • Just to re-confirm when you notice these issues (playback stoppage and remote disconnect), you are still able to access ROCK’s web UI, correct?

  • Do you notice any patterns in behavior when the errors occur? I know you had mentioned that after a re-install things stay stable for about 30-60mins, are there any actions being repeated during that time frame that you can think of just before the problem shows itself?


Hi Eric,
Thanks for getting back to me, and I’m sorry I am being unclear! Perhaps I can describe the last day and a half, and we can take it from there. I did a clean install about 36 hours ago, going back to the BIOS to check the settings, then reloading the software. All went well, so I then inserted a USB memory stick with about 100 albums on it that had played on other equipment, and this loaded successfully though I did turn off the two analysis settings based on the above question, as I don’t use DSP. All was well, the Nuc ran for most of the day playing tracks at the beginning and end. This was a distinct advance in the time of stability, so I left it on overnight. In the morning, I tried it again and it was okay, so I unloaded the USB Stick and added a 500Gb USB drive with most of my 750 disk library on. Again, this scanned well, and I played one album through without problem. Later I connected again, tried to play an album and it just skipped through each track without playing it. Another album did the same. I connected to the Web UI which told me everything was fine, but when I went back to the App, it disconnected and wouldn’t log back on. Back to Web UI and this time it reported the ROCK server was stopped. Restarted that, and back to the App, but couldn’t reconnect. A reboot made no difference, so I eventually I had to reset the database and settings, and rebooted again. Now had access and the library was scanned again. Played fine for a couple of albums. A few hours later, tried again and the App blanked and displayed Lost connection, and again couldn’t reconnect. Tried trying to connect to different core, and it just kept scanning and couldn’t find any. Went to the Web UI, and found the Roon Server was again not running, I tried to start it, and it failed. Tried rebooting, and the Web UI said success but soon became unresponsive and web page then failed to connect. Tried a hard reboot, and now it doesn’t connect to the internet at all, there are no connections listed on the router status page, and can’t find any sign it is connected at all. Will try tomorrow connecting back up to screen, checking the BIOS and doing another clean install. The App software is running on an Apple iPad Pro (first model), an Android Samsung Note Pro (PM-900 I believe), a Samsung S8+ phone, and a Windows 10 PC. Not all at the same time of course, and it doesn’t seem to make any difference which one is being used at the time, nor are then any obvious similarities as to when the problems happen. My suspicion is still a hardware fault, either in memory, or the M2 SSD, but I’m not seeing any other signs of failure so not sure. Sorry for the rambling, it been a long hard day! Any advice?


@Stephen_Dilworth When you do a reinstall of the ROCK its going to have the Audio Analysis setup as default to run. It might (the roon guys can answer this better) find your internal 2TB drive and scan that too…if its got music on it still/yet.

I’m wondering if this could be temperature related as the i3 is not the fastest of the NUC’s available and its possible I guess its being throttled down if its getting very warm. Do you hear any fan running if you put your ear down near the NUC? Is the case warm or hot to the touch? You could reboot to the bios when its seemingly in this unconnected state and see what the temps are like…you would need a monitor and keyboard attached at the time of course too.

Hi @Stephen_Dilworth ---- Thank you for the follow up and the clarification, the insight is appreciated!

Continuing forward, I would like to have you gather a set of your RoonSever logs from NUC so we can have a closer look into this behavior to see if there is anything obvious in the log traces. If this is indeed a hardware issue I have my concerns that the issue will not present itself in the logs, but we can certainly take a look to verify that something else isn’t going on here.

The most important part of this troubleshooting exercise is to gather the logs AFTER the issue has occurred because when a fresh DB is put into place the previously recorded logs are going to be wiped. The next time the issue occurs please use the instructions found here to send me over a set of your RoonServer logs in a PM addressed to me.


Hi Eric (and Mr Fix It) Fingers crossed, problem solved! When I came back to reload everything, it was impossible to access the M2 SSD, the Rock install programme just kept giving ERROR messages that it could not partition the disk, or access it. So, returned it to Amazon and bought a Kingston M2 SSD at twice the price. Loading was now easy and faster, and so far, has run fault free for 16 hours. Still using external USB drives as they are much quieter than the internal, so in a week or so, I may buy an SSD!
Thanks again for all your help. Lesson learnt, don’t buy the cheapest model available!

@Stephen_Dilworth Glad to hear the problem is seemingly fixed…Thats a pretty fast turn around on the SSD card…perhaps it was flakey or overheating or just going bad…unlike spinning HDD’s when an SSD goes bad its usually pretty much instantaneous.

Looks like Eric might have been barking up the right tree.

Thanks for the follow up @Stephen_Dilworth, the feedback is very appreciated! I am pleased to heat that the new SSD has been holding up well over the last 16 hours :+1::clap:

The thread has been marked as “resolved” and is set to close in two days. If you continue to have the same issue, please feel free to send me a PM and I will be happy to try and lend a hand.

Happy listening!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.