Install issue with Rpi 3B+

(Lars Holmberg) #1

I wanted to try the new Rpi 3B+ with dietpi because of improved wifi, but ran into issues that seem to be what is described here:


What I don’t understand is if there is a workaround or some version available that would work, or do we have to be patient and wait for v6.5? Expected timeframe?

(Rene Bouwmeester) #2

If you want to run DietPi, you’ll have to wait it out for a bit, I’m afraid. While an updated 6.4 image supporting the 3B+ was released yesterday, there are bound to be some teething issue.

If you can’t wait – the new WiFi is running just fine with Raspbian Lite.

(Lars Holmberg) #3

Thanks for the info. I use this as a roon endpoint with kali and piano dac 2.1. Never tried Raspbian Lite. Will I be able to get
Roonbridge and dac support working?

(Tony Reimann) #4

Just install Roonbridge on top of Raspian Lite and away you go.

(Rene Bouwmeester) #5
  1. Flash Raspian Lite to SD card

  2. In the ‘boot’ section of the SD card, put an empty file called ‘ssh’ and a text file called ‘wpa_supplicant.conf’, the latter containing the following:

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    network={
    ssid=“Your_SSID_Here”
    psk=“Your_Password_Here”
    key_mgmt=WPA-PSK
    }

  3. Insert SD-card and network cable in Pi and boot

  4. Log in via ssh (ssh root@raspberrypi; password: raspberry), run ‘sudo raspi-config’ and set WiFi-country in Localisation settings

  5. Edit config.txt (sudo nano /boot/config.txt) and add at the end:

    dtoverlay=allo-piano-dac-plus-pcm512x-audio

  6. Shutdown Pi, remove network cable and boot Pi. You should now have WiFi up and running

  7. Install Roon Bridge for armv7hf:

    wget http://download.roonlabs.com/builds/roonbridge-installer-linuxarmv7hf.sh
    chmod +x roonbridge-installer-linuxarmv7hf.sh
    sudo ./roonbridge-installer-linuxarmv7hf.sh

  8. Sit back and enjoy the music

2 Likes
(Lars Holmberg) #6

Brilliant! Thank you.