Install With Digi+ Pro And No Touchscreen Not Talking To Core

I got a Pi 3 B+ and a HiFiBerry Digi+ Pro yesterday and have been trying to get them setup with no luck. No touchscreen so no video from the Pi. I first installed using the 0423 image and then tried the 0521 image with the same result.

Both installs complete installing version 110 and I can access the Pi from a browser. From the General tab I updated the Hostname, selected the Digi+ Pro HAT, unchecked Audio USB and set the timezone. After saving the Pi restarts and comes back up. I can now see it on the Audio Tab in Settings in Roon and set the Zone to Bedroom.


I can’t set the Roon Control Zone on the Pi because it’s set on the Display tab and I don’t have one since I don’t have a touchscreen. I have another Pi with a touchscreen which is how I know the Roon Control Zone is on the Display tab.

The other Pi lists 11 packages on the Information tab, several of them related to the touchscreen. The new Pi only lists these 5 packages.

The other Pi has a package named “ropieee-remote”, not sure if that package should be on the new Pi. I’m thinking it might since the new Pi does not show up on the Extensions tab in Settings in Roon.


I saw the thread titled “HiFiBerry Digi+Pro no show” from May 20th and have read it and it appears that there were some Internet issues with his install. As far as I know my new Pi has Internet access, it has a wired connection to an Orbi satellite and shows up in the device list of my Orbi router just like the old Pi which is connected to another Orbi Satellite in my living room.

Any thoughts on what I need to do to get my new Pi and Roon talking?

Thanks … Tim

Sorry to ask a dumb question, but it looks like Roon sees two devices, including your “RoPieeeDigiPro”. Are you saying that when you select that end point that Roon can’t find the device?

The extension is only for the display, if you are using. And, the display tab only shows up if the display is installed.

I have a similar set-up, I see six packages on my non touchscreen the only one missing on yours is one called qt5-declaritive-ropieee. Not sure if it is needed or not?? @spockfish may be able to answer that question.

The zone control in ropieee web ui display tab is only for selecting which touchscreen to control playback from. No screen means no need to select it to control from. and display tab will not show as that package is not installed.

Have you tried selecting the zone in roon and playing to it? It appears that it is active…
It looks like both ropieee endpoints are showing in roon. Or do you have more than two?


Thanks for saving this IDIOT from himself :upside_down_face:

Why would I bother to try it … I just KNEW it could not work since I could not enter the Zone on the Pi!

Of course it does work … would have responded sooner but I got sidetracked listening.




Thanks for the reply. I saw Nathan’s post first and got sidetracked listening to my new toy.



This is the best outcome: enjoy!

1 Like