Installation Failed!


Many of my customers are reporting seeing the screen below. Even though the device continues to function as an endpoint the web interface is not accessible. Is there a workaround without having to reflash the card?


CC: @spockfish


There is no workaround, as this indicates an error during installation.
Which version are they using?


The image that you gave me that automatically configures the DAC.

That’s already pretty outdated.

During installation RoPieee updates automatically to the latest version.
That could mean that it takes a long time (depending on internet speed etc.), so that might cause the issue if people pull the plug.

Can you please give me an updated one?

I instruct my customer to wait 30 to 45 minutes. I will update instructions to say 45 minutes to 1 hour.

Thanks but I have a custom image which Harry would need to update.


TL;DR: Downloading the image takes longer than expected or documented. Just let it cook.

I’ve been struggling with this issue today as well. I moved my DAC and had to unplug is. As a result when it rebooted it attempted an update, from there it just ‘hung’. I could ping it, find it on my network, but navigating to the device in the browser always failed, in that no page loaded.

I presumed something on the image went wonky, so I attempted to reflash with the version of the OS I had locally, 20191117. Same result…

I now hooked up a small display to the device so I could see what was happening during installation.

Everything looks good then it gets to the step installing Ropieee Specific kernel and just sits. After 30 mins I unplugged it and rebooted and got the error message on this thread.

So now I attempted to download from Ropieee directly. My download was estimated at 2 days… ??? Its only 2.5GB and I have a fiber connection (~700mb/s upload and download). I cancelled the download and attempted again and this time it took about 15 minutes.

So it seems that it potentially takes some time to download the image from Ropieee. I am going to let this cook for a while, like over night, and see what happens. Even though I am working on the latest image downloaded tonight.

Side note. I just attempted to download the image again. Estimated time was 26 hrs. Cancelled. and got a download time estimation of about an hour. I then repeated several other times and got the consistent 45 min download estimation.

The file download inconsistencies are interesting to me.

Second side note: as I was typing this and getting distracted the installation finally completed. Took well over an hour (I was very distracted).

So it seems that it is just taking way longer than expected. My previous updates/installations took less than 5 mins, and I’ve been using this on my Katana for well over a year.

Hi Matthew,

Sorry to hear that. I’ve restarted my VPS, maybe that fixes the bandwidth issue.
Can you try again?


I tried several times tonight. downloads consistently at 10 mins.

Thanks for resetting.

1 Like

I have quite a few customers who ran into these issues, will the device recover if they reboot or there is no way to recover without reimaging?

In all cases the device functions, but the web interface is not accessible.

There is no way to recover from a bad install.
That RAAT is available is great, but the installation is not complete.