Installing Roon 1.8 on MacOS 10.13.6

Core Machine (Operating system/System info/Roon build number)

MAcMini Mid 2010 MacOS 10.13.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Linksys EA7300

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Auralic Aries Streatmer with an RME ADI2 FS dac

Description Of Issue

Roon 1.7 has been running fine but the 1.8 upgrade keeps attempting to install but never succeeds on my Mac mini core and further more my control devices, an iPhone 6s and an iPad have upgraded to 1.8 and now are giving error messages saying they can’t connect with the 1.7 core because it needs to be upgraded to 1.8. Please don’t tell me you have obsoleted my Mac mini with this upgrade! This Mac mini cannot get any operating system more current than 10.13.6 because Apple has stopped supporting it. I hope your version 1.8 is backward compatible.

Bruce Barbour

PS if you can’t get this sorted out will you please issue me a credit on my monthly subscription until you do?

Hello @Bruce_Barbour, and my apologies for the trouble. You can view our minimum system requirements here which recommends macOS 10.14 but will work with above 10.9. Since you’re on 10.13, have you tried creating a backup and reinstalling over the old instance with this link? Please let us know if that works!

Thank you for your reply Nuwriy.
If I understand what you are saying correctly there is no need to restore my Roon Core to 1.7 because it never has been able to complete the upgrade to 1.8. It downloads the update and shuts down to install it but it never reopens itself from that shut down. I have to open Roon ands when I do I find that version 1.7 is still present and the software is asking me if I want to download the update. I have run through this cycle about 10 times, making no progress. So 1.7 is on the Mac mini core (and it keeps requesting permission to update) but the new problem is that my iPhone and iPad seem to have successfully upgraded to 1.8 and now they will no longer connect with the core. I get a screen saying I need to update the core to 1.8. So now I am effectively blocked from using Roon at all and I don’t know how to revert the iPad and iPhone to 1.7, which might temporarily solve the problem…but maybe not.

Bruce Barbour

I have followed your directions and used the link which I see I should have done in the first place. It successfully downloaded and installed ver 1.8. I misunderstood , my apologies. The only question that remains is that when I ran the installation I was offered the choice of keeping the old copy of Roon, which I did. I now have two versions of Roon installed on the Mac. I assume I can just delete the older one? I will await your confirmation and thanks for your help and good luck with the rest of the upgrade work!

B. Barbour

One more note to confirm things are up and running again. Thank you so very much for your prompt and professional assistance.

If I may I do have another problem, not upgrade related. I just bought an RME ADI2 FS Dac and I’m having trouble getting DSD256 files to play on it. I’m thinking this could be an incompatibility issue since the RME dac is not Roon ready as far as I know. It will play DSD 64 and 128 files. Previously I had a Topping D50s dac in its place and that had no problems with the DSD 256.

I’m sure you are all busy with the upgrade and all right now but when you have a chance could you let me know if there are any known issues between Roon and the RME ADI2 FS Dac?

B. Barbour

Hey @Bruce_Barbour, glad things are working! And you’re correct, it looks like we have no certified RME devices currently, which may lead to issues when using the RME ADI2 FS Dac.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.