Intel NUC Dead Again

I have contacted Intel, and I am pretty sure my only several month old ROCK NUC7i7BNH is dead. I came home last night to it completely off, and it would not turn on.

If I unplug it, and then plug it back in, the power button glows red (or more like Orange), but as soon as I push the button the light goes off and the NUC does nothing. A couple months ago it seemed to be dead, although the symptoms were quite different, then all of a sudden it started working again for no obvious reason.

Anyway, this time I have reseated the ssd and memory, tried a different power supply, and even pulled out the ssd and memory and plugged in, but the behavior is the same. :frowning_face:

I can’t help but wonder if ROCK is somehow pushing the CPU, race condition or something, for my install, and killing my NUC, just conjecture of course. As far as usage, ROCK has been perfect in terms of music flowing with no issues. It would be nice to be able to see the resource usage on the ROCK web page just in case something like that is happening.

I just thought I would post out here in case someone has experienced something like this, and of there is any other solution other than the obvious - warranty repair/replace.

ROCK is really lightweight and doing very little. If you installed any normal operating system on it, you’d push that system much harder. ROCK runs RoonServer and almost nothing else. It has a minimal SMB server so you can view the storage from your Mac/PC, a tiny service that delivers the web ui, and some minor scripts that get triggered by the Linux kernel with network status changes or ports get something plugged in/out.

This term does not mean what you think it means. This term is generally used to mean an out of order exception that occurs because two things are working in parallel and the programmer made assumptions of what would finish first.

This is counter to the spirit of ROCK. Even if we gave it to you, you’d have no ability to do anything to fix the erroneous condition. If we gave you the ability to fix stuff, we’d just be going down a road of creating a larger more bloated operating system. If you need this, run Linux Ubuntu or Debian or Arch, and not ROCK.

Sounds like you have bad hardware… do the warranty repair/replace. Make sure you keep your ram/ssd for the replacement.

Thanks Danny. I didn’t mean to accuse Roon of anything, I was really just thinking out loud. It’s just frustrating that brand new, expensive hardware dies in just a few months, but I know it happens. I was grasping at straws to explain what might have caused it.

Your point about offering information as far as the NUCs operation with no way to fix it does make sense

Thanks for the clarification on some of the erroneous stuff in my post. In case anyone’s interested I’ll post back here when Intel responds.

1 Like

I wonder if the power supply is defective.

Count yourself lucky! My NUC lasted all of 4 hours before dying completely. No signs of life whatsoever. PSU measured OK and I tried it without memory or SSD, to no effect. The supplier exchanged it after I got an RMA number from Intel support.

I agree that ROCK is pretty lightweight on the hardware by the simple fact that the NUC runs barely warm to the touch.

Open it up and try a bios reset by removing the battery and going through any reset process.

Battery disconnected an hour ago, gonna reassemble soon.

Well, I reassembled my NUC after disconnecting the battery and leaving it disconnected for a couple hours. No Luck, now when I plug it in I don’t get any light showing on the power button. Pressing the power button does nothing, no response from the NUC. No way to reset the unit or the bios since it does NOTHING. I am sure it is dead. I have a ticket open with Intel, so now I wait for them…

So for those who might be interested, my NUC was sent back to Intel for warranty service/replacement. It arrived at Intel today. Hopefully it will be back in my hands soon.

The reason I got the NUC was because I was having frequent skips in the middle of songs when the core was on Windows 10. With the NUC/ROCK that probIem was gone…but interestingly, I swithced back to my Windows 10 PC as my CORE while my NUC is gone, and I have not had a song skip or any other problems.

If that continues, then what do I need to the NUC/ROCK for…? Maybe I will sell it or repurpose it, or bring it back as a rock anyway. Who knows. Just funny that, of course. PC CORE is working perfectly. :thinking:

Turning your ROCK, into a brick twice… not funny at all :frowning: . (Sorry, this should have had a corny-joke warning…:disappointed_relieved: ).

Yes, please keep us posted, if you ever find out what’s actually broken (or even better : what’s causing that to break). This does not give us NUC users much confidence.

The company I’m working for is selling the cheaper Celeron based NUCs as an embedded solution, for a couple of years already. Until now (knocking wood…), they have proven to be very reliable.
Same for my own NUC6i5 on ROCK : running 24/7 for 11 months now. And I do hope it’ll continue doing that, for at least the next 5 years or so…

OP Here. Well, after a supremely annoying process by which I sent intel my NUC, they received it, then THE SAME DAY THEY RECEIVED IT, they sent me an email that the ticket was cancelled because I did not send the NUC in within 60 Days of the issuing of the RMA, then they opened a new ticket asking me to SEND IT IN (even though they already had it)…well…after all that, I received a brand new shrink wrapped NUC replacement. Let’s hope this one lasts longer than 5 months!

I have installed my SSD and memory, and I am back to it streaming music. Whew. Thanks for all the encouragement :slight_smile: