Intel NUC + NuPrime DAC-10H DSD 256 playback issue

Core Machine (Operating system/System info/Roon build number)

Intel NUC8i5BEH running Windows

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Intel NUC connected to DAC via USB

Description Of Issue

Hello everybody,

I’m still in the trial period so basically I’m still a noob in all things Roon.
I find it to be a very comprehensive software piece, which is the reason i’ve fallen in love with all it’s functionalities.

But unfortunately there is one issue that is bugging me and I tried getting over it but to no avail.

I am running Roon off of my Intel NUC8I3BEH via an USB cable to my trusty NuPrime DAC-10H. Theoretically, the NuPrime should be able to playback DSD files at 256 natively, but somehow there is no option to select “native” in the “DSD playback strategy” setting option.
I can only select "DSD over PCM v1.0 DoP) and that only allows me to play DSD at 128.

As I said, I am new to Roon and still trying to figure out how can I optimally set it up, but I’ve gone though every setting and every community topic I could find, and still couldn’t fix my issue. I changed USB cables, connected the NUC through Ethenet, Wi-fi, etc, tried unplugging and plugging back while restarting the DAC, but nothing seemed to work.

Can someone please tell what am i missing here?

Best regards,

Hi @Alexandru_Covaciu,

Welcome to the Community and for giving Roon a trial! Judging from your name I take it you might be Romanian? If that’s the case then - bine ai venit! :slight_smile:

I took a look at the DAC 10-H Manual and I do see DSD256 rates listed via USB, so it’s a bit strange you are not presented with this option. Have you made sure to install the NuPrime USB Driver on your Core first?

What does the driver look like on your end in Roon Settings -> Audio? Are you using the WASAPI driver or the ASIO driver for the DAC? Can you perhaps share a screenshot of your Roon Settings -> Audio and the Device Setup tab to help clarify?

– Noris

Hi Noris,

Thanks a lot for your support.
I didn’t know about that software I had to install in my core from the NuPrime website. I did install it now and it appears that I can activate my DAC-10H as an Asio end-point, whereas before I could only enable it as an Wasapi endpoint.

By enabling the ASIO endpoint and going into setting I can finally see “native” as an option.

I wish this would have been the end of it, but now DSD files will not play in any manner. There’s only a static noise that I will hear anytime I try to play a DSD file. I changed the settings from “native” to “DSD over PCM v1.0 (DoP)” but the same thing happens. The only way I can play DSD files while enabling the ASIO end-point, is to select the “convert to PCM” option.

If I enable the Wasapi endpoint then I’ll go back to square one.

  1. ASIO driver end-point setting, but cannot play DSD files at all as all I hear is static.

  2. Wasapi endpoint setting, but then I don’t get the native option.

I would suggest you restart the Core PC and the DAC too and see if this helps and go back to the ASIO driver and give the endpoint an appropriate name too

I tried all that and it didn’t work.
I got it ti work, finally. I don’t know what the issue was, but I uninstalled the NuPrime driver and installed it again, and that seemed to do the trick.

Thanks to both of you for the support!

Best regards,


Hi @Alexandru_Covaciu,

Glad to hear that the issue is resolved after re-installing the NuPrime driver.
If you have any further issues, don’t hesitate to reach out!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.