Intermittent disconnection

I am new to Ropieee as have only discovered it.
Great piece of software and very easy to setup.
However I having an issue where it keeps diconnecting/disappearing from network.
Its very annoying as it interrupts playback for extended time periods.
I have uploaded feedback ticket f00b16265be55f57.

Did a search but it came out with no real solution. I can see it was discussed in past but with no real outcome.
My HW is perfectly fine as I was using it with MoodeAudio for all the time with no problems.
I have the RaspDAC Mini kit and its fed by very stable ULPS. So I can’t see how this could be a power or HW issue.

Any ideas?

Hi Richard,

Looked at the logs, nothing special to see there.

Can you elaborate a bit more? What do you mean with ‘for extended time periods’?
Is there a special reason why you use a static IP address?

Furthermore I’m getting the impression that the logs I’ve received are from quickly after a reboot.
It would be better to have a log when the unit is running and has already shown some of this interruptions.


Thanks for quick response on this.
I mean when it disconnects it can takes good 30secods to come back and it happening very often.
I like to have all network devices set to static IP so when I test things, reboot router, devices, etc it will not be assigned with different IP.
I will try to leave it on for a while, so it appears in the log.
Will do this maybe tonight when I am back from work

Thank you

You should set the dhcp reservations in your router and let them use dhcp for address…much easier to manage.

If it’s restarting then could be heat related. Check in the last GUI tab for temps.

Power needs to be 2.5A but if you are also using non powered DAC or HATs and a display these need more power and you might be running out. ULPS can be limited to low currents

I can assure you there us no power limitation as my LPSU can easily power three such devices simultaneously.
And it is not rebooting or overheating. Its just going off network and is not accessible, not even over SSH

When it happens and it’s in this state are the less on the lan port flashing?

I was trying to read logs last night and now I am suspicious that the device may actually keep restarting in loop.
I can not actually see RPi as it is inside of housing. First I going to re-flash on another SD card. If the behaviour going to be same I will try to take it apart to actually see LED’s

So it’s not possible to send me feedback?
Does that mean that it actually does not return when it disconnects?

It does reconnects after about 30-60 seconds.
But now I have re-flashed it about 4 times. At the moment is running and not rebooting so far.
Will have to test it for a while and see if is going to be stable this time.

Could it be it was a doggy flash? I do not use any specific software, I flash this on my Linux Mint machine

OK, So about 15 mins later and 3-4 songs played this behaviour happening again.
I have uploaded feedback 4f0430973a593e24 just after it recovered from ?reboot?
Not sure if you going to see anything in it.
It is happening so often that sometimes even one track can not be played in full.

And here is one more ticket just straight after next stop/reboot 6ac68edd63014854. This one happened just when I tried played next song after first reboot.

Rebooting does not help, because then the logs are gone.

Still not clear to me: is it coming back after some time or do you need to restart it?

as i said, its going in loop. Off, back on. Plays for 30s maybe 1 minute and again

Ok. Can you send feedback without rebooting it? After one of those interruptions?

I am afraid that is all I have. Its not me manually rebooting it. its reboots in the loop itself endlessly.
I play track which stops. When is back I go to web and create that ticket before it happened again.
So if you can not see anything in the logs then there is nothing we can do here I am afraid.
I have tried various SD cards so the problem is not there.
Same device with same cards works flawlessly with other systems. I using Moode with no problem at all.
No idea what else I should try or where to look to troubleshoot this

Well, up until your last message I was under the impression that we were talking about disconnections.
Now it’s clear that we’re talking about reboots.

Anyways, the logs show nothing special, except a few ‘under powered’ messages.

Thinking out loud here… have you checked the temperature? You can find on the ‘info’ tab.

Nothing suspicious. Temp is only under or around 50°C

It seems I have to apologies to everyone, especially to @spockfish.
It turns out it was a big coincidence that 5V regulator failed in my LPSU and it was dropping voltage below 4.8V which was causing reboots of the device.
All fixed now and working smoothly.

Thank you everyone

PS: Mods please close and mark this thread as re-solved

1 Like

Hi Richard,

No need to apologize, just glad you found it!



Thank you once again
Happy days

1 Like