Intermittent dropouts when using Roon with Netgear Orbi

Roon Core Machine

Acer Aspire A515-52G
Inter Core i5-8265U @1.60Ghz
Windows 10 Home

Networking Gear & Setup Details

Netgear Orbi RBR50
TP-LINK TL-SG105 network switch between Orbi satellite and Roon Core.
Roon core connected via ethernet connection

Connected Audio Devices

Naim Uniti Atom HE connect via ethernet. One connected to the TP-LINK TL-SG105 network switch on the same satellite the Roon Core is connected to and the other via ethernet to a different Netgear Orbi satellite.

Number of Tracks in Library

Around 10000 tracks

Description of Issue

At random moments listening to Roon causes the network on my Netgear Orbi to shut down temporarily. This only happens when using Roon and no other forms of streaming or network access. It seems to have gotten progressively worst with Roon updates.

When this occurs all devices connected to the network (especially those connected with ethernet cables) temporarily loses connection to my home network.

This causes playback on the Uniti Atom HE to stop immediately and user interaction is required to restart the playback once the network has been re-established.

When this occurs the Roon core also loses all internet connection as well.

I have tried everything I can think of to solve this. Moving the satellites, trying wifi connection on the Unit Atom instead and also installed a network switch between the Orbi and the Roon Core as suggested in a post I found on this forum. IGMP proxying is also enabled.

It appears since the installation of the network switch and attaching one Uniti Atom HE to the switch as well, the dropouts on THAT Atom has stopped.

The other Atom, connected to a different satellite, is suffering more and more dropouts as Roon is updated. At the moment it is sometimes unusable, dropping out multiple times in one track or album.

What is strange is that sometimes days can pass with no dropouts and then suddenly it is unusable for a few hours.

Native streaming on the Uniti Atom HE does not suffer from the same problem and is perfectly stable.

I have therefore concluded that this seems to be related to Roon communication on the Netgear Orbi specifically.

I cannot see anything in the admin logs of the Netgear Orbi that would suggest the cause of this issue.

Can you perhaps help me find the root cause of this issue? I am at the point of cancelling my Roon subscription due to being unable to use it as intended.

Sounds like a broadcast storm is happening if it’s taking out your network as it’s not handling things well. From Roons Network best practices.

Netgear Orbi Routers

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

But you have that setup all ready.

@Michael_Harris I remember you had an orbi

Check all this here to ensure you have not caused a network loop some how as this has the symptoms of that.

Yes been running the Orbi’s with Roon since 2019 (the original Wifi 5 versions) and turned off the IGMP proxying as part of my setup. Never had any issues with Roon, and the only real issues I have ever had have been with Sonos when they were plugged in to Ethernet (as they were taking over the routing to use their own protocol) and that broke Roon as the Sonos Mesh could not be disabled so I had to unplug them and use WiFi.

I was also mostly using the TP-Link switches as you as well until recently.
I even run the Roon Core off the back of an Orbi and with the almost 800Mb traffic throughput I really never have an issue.

Can you try to unplug other devices and see what might be causing the issues as once you have changed the IGMP PROXY setting this is almost the perfect device for Roon.

It’s early in the morning here, but don’t these two statements contradict one another?

Hmmm thanks for the info. But I don’t have any of those situations. In any case not anything I can see. Even checked my Orbi console and no devices are connected via Ethernet and Wifi at the same time.

I also have the Wifi 5 Orbi. But you say you turned it OFF? The best practices for Orbi says to leave it on? If you really have it turned off I would be happy to try it. Thing is they use a double negative interface for it. A checkbox that if you set it ON you turn it OFF :joy:


I had a very similar scenario. I was using ubiquiti amplifi hd devices but throughput was not good enough for us and 2 teenage boys’s simultaneous use so I got a set of Orbi devices. The speed through the mesh network was way better and everything was fine except I got a few sporadic dropouts when using Roon. The network remained stable.

When i applied the last firmware update ( a bit of an adventure in itself) everything got screwy and sporadically the network would go down. No external connectivity and no internal streaming. I would have to reboot the broadband and then the Orbi network to regain function.

I read the notes on the forum and swapped my Roon core from directly into the Orbi to via a switch attached to it. I have a muso gen 1 and an NDX2, both of which are wired into satellites and have had no further issues.

I know that doesn’t really help you but hey, a problem shared eh?

The hardware is great but the software and the tech support for what are supposedly premium products from Netgear are pretty pathetic.

Oh forgot to mention this. The issue is dat the problem is intermittent. Sometimes a week wil go past with no dropouts and then suddenly it starts and then I will have many. Then it may be quiet again. So I cannot reproduce the issue which means that if I unplug things I would have to leave them unplugged for weeks to make sure it was the problem. And I cannot do that, of course. If I unplug something and it works for an hour or two I will still have no idea if it solved it and if it has just gone into a lul again.

Oh I so agree. The fact that you get three months support and then you have to pay.

Really glad I left Netgear products behind years ago, that’s very poor.

As it’s intermittent hard one to tie down. Are all the access points using hardwire backhaul or wireless backhaul? Are they an extension of another router and uses in bridge mode or is the orbi you main router as well?

Sorry I am in work today, but I followed the instructions as part of the Network setup guide.
On some devices you enable and others you disable, my brain cannot remember which I did

1 Like

It is wireless backhaul. Wont be able to do a wired backhaul in my home setup. And the Orbi Router is the main router.

That was my confusion when typing the message out.
Disable Off becomes on and Enable On becomes Off :scream:

1 Like

After reading some confusing KB articles, my money was on you being right. :sunglasses:

1 Like

I will always take those penney’s, but yes it becomes confusing, and 50/50.

I am updating firmware on some serious enterprise kit at the moment so I better get back to concentrating :wink:

Can you try connecting you core to the main one that will be hardwired with your incoming internet and not use it on a satellite to see if this helps.

Yeah you don’t want network dropouts there as well!!! :joy:

I may be able to do that. That exact thought crossed my mind just last night but will need to do some fancy footwork to make it fit there. A project for next month somewhere with my current agenda.

But it is a good idea to try!

1 Like

Just your basically running core wireless which is really not recommended even on a mesh system although it can work. Putting it on base unit makes it fully wired, Roon is pretty heavy network wise and Wi-Fi not being duplex can struggle. The intermittent nature may point to wireless congestion. Are you in a built up area with lots of other Wi-Fi users? May be work getting a Wi-Fi checking app i you haven’t already and see if there are any obvious interference from neighbouring Wi-Fi as there’s changes channels it could start to interfere with yours. May be none of this but it’s always good to check.

1 Like

You are referring to “wireless” as being on the satellite? It is wired into the satellite but yes, that means wireless comms via backhaul. So definitely something to check, yes.

I’ve checked that many times with inSSIDer. Not too congested and my router is on a clean channel and blows everything closeby out of the water with signal strength. So that is defo not the issue here.

Well I was also updating the Firewall Firmware so I took the site offline for 20 minutes, but all back up now and off to update some additional switches

I consider my Core to be Wired as it is plugged directly into a Mesh AP.
Others might argue but I get almost 800Mb of real world traffic through it and my Synology Plex server.
One of the reasons I bought the Orbi was because my wife did not want the wires running through the walls and in testing it came close to Ethernet performance.

You should be able to make this work so it is a matter of trying to track down when the problems occur

My reasons for having an Orbi is very much similar to yours. Did not have issues for a long time and then suddenly it just started. The problem, though, is that I am unable to track down the problem, LOL.


Makes sense as for a change the reality met the marketing (in use case and speeds).

Trying to track down the item causing the issue could be a challenge, it could be a WiFi or Ethernet device. Early on I created separate networks for the different bands on main and guest so I had 4 networks, while working through some older WiFi devices. I have less now, but the fun (and challenge) is always in the finding the cause of a problem and then subsequently working out how you can work around the problem.

1 Like