Intermittent gaps in playback between tracks on Sonos zones (ref#BDU4D1)

What best describes your playback issue?

· Other

Is there a specific error message you see? If so, please select from the following options:

· Other

Please try to reboot your Roon Server and check to see if this helps.

· Rebooting my Server had no effect, the issue remains

Please try to reboot and unplug/replug in your affected audio device and check to see if this helps.

· Rebooting and unplugging/replugging my audio device, the issue remains

Please open your Roon Remote and select the "System Output" Zone and try to play to it. Do you encounter any playback errors with this Zone?

· I can play back music *without issue to System Output*, it is only the *other zone that has issues*

What method is the audio device connected with to the server (Roon Ready, HDMI, USB, AirPlay, Chromecast, etc.)?

· Sonos

Is the audio device on the latest firmware version, as per the manufacturer's app?

· Yes

Is there any change in behavior when using a different cable for the connection for the audio device?

· No, using a different cable didn't change anything

Have you reached out to the manufacturer of the audio device regarding this issue yet?

· No, I have not reached out

Does the issue happen with local library music, streaming service music, or both?

· Both local and streaming content are affected

Please try playing content of a lower sample rate (44.1kHz or 48kHz). Do you still have the same issue?

· No, lower sample rates are still affected

What is the model/manufacturer of the affected audio device(s) and the connection type?

· Sonos Amp, Arc, Play:5

Describe the issue

I am still getting gaps/pauses between tracks when playing to Sonos zones. Sometimes playback is gapless, but occasionally, there will be very short gap between tracks. This has been an on-going issue for a long time, however, it is less frequent for the past several months. It used to be that there were 5-10 second gaps. Now they are generally second or less. This happens with both local library files as well as Qobuz. I've tried Sonos in both wireless and wired modes, Same issue. Just updated to 2.0.37 this morning and had gaps between tracks 2-6 when playing Frank Zappa Absolutely Free.

Describe your network setup

Eight Sonos zones, using SonosNet in wireless mode. Nucleus core connected to ethernet. Wifi network is very solid and Sonos diagnostics show excellent coverage to all devices.

Hi @HeavyMetalDrummer ,

I enabled logging for your account, but I was unable to locate this playback attempt. Can you please let us know the time + date when you next reproduce?

I’m listening to Pink Floyd, The Wall [Experience Edition] right now. July 1, 4pm ET. There were gaps in between tracks 1-4 and 1-5, and also between 1-12 and 1-13. Starting on Disc 2 now, let’s see what happens.

1 Like

I made it through disc 2 of The Wall, and there was one gap - between 2-11 and 2-12. July 1st, 4:45 ET

1 Like

@HeavyMetalDrummer - Thanks for those timestamps, I can confirm that logs have come in. We are reviewing them and will get back to you once we have more information to share.

Hi @HeavyMetalDrummer,

Are you able to upload a copy of the local file of The Wall mentioned in your post above? Our QA team is hoping to reproduce with an identical file. Thanks! Here’s an uploader.