Intermittent iPad connection to Roon Core

–iMac Retina 4K, 21.5-inch, Late 2015; 3.1 GHz Intel Core i5 processor; memory 16 GB 1867 MHz DDR3; macOS High Sierra 10.13.6
–Roon Core: on iMac; Version 1.5.00354 (Build 354) stable (64 bit)
–iPad Air 2; IOS 12.0; 64 GB capacity (50 GB available)
–Roon Remote on iPad; newest version

Operating Roon from the iMac is without any issues or dropouts. The problem I have had for the last 4 weeks or so (I had no troubles for over a year) is controlling Roon from my iPad. Don’t know if it was a macOS or Roon update, but now when my iPad tries to connect to Roon Core, I get a “Lost Connection–Trying to reconnect” message. It may reconnect in a few seconds or a few minutes, but doesn’t stay connected for more than 10-20 seconds before the “Lost Connection” screen comes back.

Rebooting the iMac, uninstalling and re-installing Roon Remote, rebooting the iPad and closing/reopening Roon Remote had no effect on the “Lost Connection” problem.

Please help. A non-functioning Roon Remote totally defeats the purpose of making Roon easy to use and part of an enjoyable listening experience.

My iPads have been intermittently loosing their connection to the Roon cores for many months now. See

If I shutdown the iPads they come up and stay connected until the next time this intermittent fault occurs. Doesn’t happen to my Windows 10 remotes, just the iPad app.

Your problems seems a bit different however. Maybe @support can help.

Have you tried killing all the apps on the iPad? You can do this with 2 quick presses on the iPad and then swiping up each app to remove it from running.

Hey there @David_Hagerty!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this behavior occur with any other remote devices?

Do you have any antivirus or firewall on the Core machine? If so does disabling it yield any change?


Yes, I have tried that. With all other apps closed the problem is no better.


Router modem: Arris SURFboard SBG-6900-AC
“The SURFboard SBG6900-AC is 3 products in 1: a DOCSIS 3.0 cable modem, dual-band concurrent 802.11ac Wi-Fi access point and 4-port Gigabit Ethernet router. With high download speeds and high Wi-Fi speeds it’s an extremely powerful Wi-Fi modem in the SURFboard lineup. No more buffering while streaming HD video. No lag while gaming with friends.”

Music server/NAS connected to router via Ethernet
iMac connected wirelessly using 5G WiFi.
iPad connected wirelessly using 5G WiFi.
Nothing else in house connected to 5G.

I tested download speeds yesterday from iMac: download 139 Mbps; upload 10.6 Mbps. Jitter 3.7 ms.

Let me know if you need additional information.


I would also add that it makes no difference whether the iPad is connected to the “G” or “5G” WiFi.

Is your iMac set to never sleep? display sleep is OK but if the iMac sleeps then the core will go away. Or is music playing the whole tome this an issue?

Happens all the time, including when music is playing.


Hey, @David_Hagerty!

Do you have any other devices that you can use as a remote (Windows, Mac, iOS, or Android device) with Roon? Knowing if the same behavior occurs elsewhere would allow us to narrow down where this behavior may be occurring.


Let me clarify: for the last 4 weeks, EVERY time I have tried to use Roon Remote from my iPad, I had connection problems. HUNDREDS of attempts.

TODAY: it’s working flawlessly again. While I am thankful that it’s working again, the unpredictability frustrates me. Also makes me wonder when (not if) it will happen again.

In any case many thanks to those who tried to help! I appreciate it.

2 posts were split to a new topic: iPad Remote losing connection to Core

Follow up on this issue. Has recurred 3 times. In each case closing and restarting apps on iMac and iPad did not fix the problem. However, rebooting the iMac did fix the problem all 3 times.

Hope this helps someone!

I appreciate the update, @David_Hagerty,

The next time this behavior occurs I’m hoping you’d be able to do a couple things for me:

  1. Make a note of the time you notice this behavior so I can enable some diagnostics on your account and take a look.
  2. Using an app like Fing that scans your network, can you confirm if the iPad is able to see the Core machine on the network?
  3. Can you confirm if another remote device (Windows, Mac, iOS, or Android) is able to connect to your Core?


Hi Dylan. Still working flawlessly. One of life’s mysteries!

1 Like