Intermittently skips songs / Pauses playback / Out of sync interface / Possible Sonos issue?

Roon Core Machine

  • Ubuntu Server 22.04.1 LTS on an Intel NUC11TNHi3
  • The OS, applications and all my CD rips are stored on a Kingston NV2 PCIe 4.0 NVMe 2TB SSD
  • RAM memoy in use is 1x Kingston ValueRAM 8GB at 3200MHz

Networking Gear & Setup Details

  • Netgate 6100 pfSense router
  • 1x Ubiquiti UniFi 6 Pro Wi-Fi

Connected Audio Devices

  • 3x Sonos One SL

Number of Tracks in Library

  • 17883

Description of Issue

I basically only listen to albums and I play them start to finnish. For some reason Roon sometimes skips a song or only plays the first split second and then moves on to the next song. Sometimes it even skips two or the interface is out of sync with the actual playback.

It is really frustrating, also because it messes up the number of plays of a song.

The latest Roon version did not resolve the problem.


Hi Eric
Sorry that you have problems

Just out of curiosity as I was thinking of Sonos. All 3 of them over wifi? And if using something ethernet connected you also have the same skipping?

Great to see you posting but not so great that you have a problem. Hope the other guys with Sonos experience are going to help

1 Like

I just realized I think I’ve been seeing the issue with other audio devices as well I’m afraid.

A MacBook Pro with heaphones had the same issue if I recall correctly.

Everthing is wireless. The only LAN cable in my tiny appartment is the one from the router to the wireless access point. Can’t say I have wireless connectivity issues. The server also seems pretty much idle all the time.


It’s only been happening when listening via Sonos.

then no wifi problems, maybe if you are in a wifi super crowded area

I hate cables but still I’m afraid of wifi more than I hate cables :slight_smile:

1 Like

Yes. I think it is a server side issue.

1 Like

So, how do I get to speak to someone from Roon?

Hello @eric8bits,

Roon do not offer phone support but they will assist you right here on the Community website in the #support section.

Unfortunately due high demand and a small team it may take a little while till your report reaches the head of their queue.

Hang tight.


I have log files from the server application I can share. They might clear things up.

Still no sign of support?

Possible same issue reported by someone else:

The out of sync part is what I am seeing as well. Next to the skipping.

Another report:

This is the same issue or related. I notice everyone reporting this is using Sonos.

At first I suspected it to be something bigger but I only experienced the issue with Sonos.

It sometimes happens to me as well that I need to force start playing music again. It just halts.

Another older report, same issue:

This might be of interest:

Another possible related report:

Also related:

I have seen this error as well.

Also from this thread, this is the case for me as well as I have a stereo-pair in the group:

Hey @eric8bits,

Thank you for your continued patience while we work through each thread. :pray:

If at all possible, are you able to test hardwiring your core / sonos endpoints?

I’d be curious to see your network bandwidth options from your router. Are you able to select 2.4Ghz or 5Ghz? Can you assign specific devices to specific bandwidths? If yes, you may know where I’m heading with this. :slightly_smiling_face:

I would make sure your core and sonos endpoints are on the same bandwidth - ideally 5ghz, but it would be good to test both (again, if this is an option.)

Outside of this, could you please recreate the issue and share the specific date and time back here? That will help us pin down what might be going on. I’ll enable diagnostics on your account so we can take a closer look. :+1:

I’ll be on standby for your reply.


Ok, first issue right now (February 24, 10:02 CET):

The interface is not in sync with what is actually playing. The timer is frozen at 3 seconds.

This started when I forced Roon to play another album from the start while another album was playing.

Then around 10:05 CET it totally messes up. Skips a song. Messes up play count. Is out of sync.

I think this happened when the initial song with the frozen interface was finished playing.

I’ll need to purchase a switch and a networking cable for a hardwired configuration so would be a last resort.

The Sonos devices are on 5 GHz, WiFi 4 and the Roon server is on 5 GHz, WiFi 6 according to the UniFi Network software.

I also tested AirPlay instead of Sonos Streaming this morning and that worked fine with my first test.

The #1 suggestion that people facing this type of issue get is to wire their core. If it were me, I’d purchase a $20 dumb GB switch and be done with that.

There are a number of threads on this, but it’s a strong Roon suggestion to wire your core at a minimum. Id certainly wire one of your Sonos endpoints as well. I realize it’s not what you want to hear, but Roon is very very demanding network wise. Good luck.

1 Like

The strange thing is, I don’t seem to be having the issue when using Sonos’ AirPlay. The issues arise when I choose Sonos’ Sonos Streaming.

Performance of the Roon server has been excellent.