Internal circuitry noise on RPi3 -> USB DAC


I spent a weekend fighting a really nasty Raspberry Pi noise, with no luck. I’m out of ideas, please help me.

My setup:
Raspberry Pi 3 (or Raspberry Pi 1, both have the same issue)
With or without Touchscreen, with or without Ethernet cable, tried 3 different power supplies
Running RoPieee (or DietPi + RoonBridge, or anything really)
Connected to Aune S6 DAC via USB, Ferrite bead on USB cable
Aune outputting to Accuphase E360 via either RCA or XLR
All equipment powered from the same grounded extension cord.

When Raspberry Pi is powered, a few seconds into booting, as soon as USB gets initialised I start hearing internal Raspberry Pi circuitry hiss. It sounds similar to what hard drive sounds when head is busy. It also correlates with screen output (all the text outputted during boot, or even the seconds changing when RoPieee touchscreen is running). If I disable and unplug a touchscreen there’s no improvement, except for an additional high pitch noise that gets most intense when screen brightness is adjusted to medium (less noise when it’s set to full brightness). Ferrite beads hooked on any cables have no impact.

Noise level does not depend on amp volume.

If I plug in e.g. a Macbook to USB output, the noise level drops significantly, but does not completely disappear.

Any thoughts would be welcome.


How close is your RPi to your DAC? This sounds more like EMF than noise on the USB.

If they’re already separated by some distance, then I guess the next thing to try would be going to SPDIF between the RPi and DAC (with something like a HiFiBerry Digi+ board).


1 Like

Other RPi users have reported occasional issues with noise correlated to the HDMI output of the RPi. DietPi can configure this to be off by setting the Screen Resolution to “headless” in the configuration menu, or by enabling “low noise” mode in the audio setup menu. I think RoPieee disables the HDMI port by default, so the HDMI suggestion may be a red herring. (@spockfish is this still the case? RoPieee is evolving so quickly, it’s hard to keep up.)

One solution to be rid of the USB headache entirely is a S/PDIF digital output HAT for the RPi (as suggested by @Jeff_Young above). However, this would limit content to 24/192 and preclude the use of DSD (unless your DAC accepts DoP over non-USB inputs, but most don’t).

There are many options in this category: (has AES/EBU)

1 Like

Yes. HDMI is disabled by default in RoPieee and can’t be turned on.

1 Like

Is that a challenge? :wink:

1 Like

Thanks guys for all the ideas.

Jeff, no the distance between Pi and DAC does not influence the amount of hiss. Optical connection is of course an option but defeats the purpose of my new purchase of a DSD capable DAC, my previous one was already fine.

Jim, as per Harry’s comment the HDMI should be disabled so should not be a reason.

In the meantime a few other observations:

  • Disabling power of DAC does not remove hiss; however unplugging power cable of a DAC removes hiss. Plugging to different outlets (nearby) causes same amount of hiss.
  • plugging the Pi onboard audio directly to Amp RCA (USB cable unplugged) does not cause hiss.

Based on this sounds like a ground loop but what am I plugging wrong? And why doesn’t ferrite bead help?

Thanks again.

If it is a ground loop i‘d start to unplug everything from your stereo except power and speakers and reconnect everything while checking for the noise.
In the past I had several situations with noise when hdmi, Ethernet or the cabled antenna (via cable company) was connected.

1 Like

If your DAC doesn’t require power from the vbus, you could get tweaky and cover the power pin of the USB cable or or snip the power wire as a test.

1 Like

That’s a very interesting idea. I’ll try it in a day or two and report back.

Thanks Chris.

Meh, it was a promising idea, but my DAC didn’t like it. With USB +5V cable cut, Pi doesn’t see the DAC, but also no noise.

I also double checked HDMI and it’s turned off (turning it on doesn’t change the noise pattern).

Next on my list is to swap the DAC with a different one (will bring it from work today).

Otherwise all I have to connect to hear noise is:
Pi: power via microUSB, USB to DAC
DAC: power, XLR to Amp
Amp: power, Speakers

all power from the same grounded outlet

I also hear a low noise during the bootup phase of my Pi 2b. However it quiets as soon as ALSA is started and takes control of the DAC. (While thinking of it, it only affects one of my older DACs when using a Hifiberry Digi+ Pro and attaching to the DAC over SPDIF)

A couple of other suggestions, if this issue is caused by interference:

  1. Check powerline phase for each of the attached units.
  2. Attach them using a NON grounded extender

Of course, as suggested, keep Pi and DAC well away from switched PSUs, powerlines etc.

I wish I could reproduce this. It’s a great opportunity to test many USB devices that claim to clean up the signal.

If available:
Have you tried to use a different USB power supply for the Raspberry Pi?

Yes I have tried three different power supplies, it makes absolutely no difference on the pattern of the noise. I even tried a battery pack (which was a bit underpowered so Pi would reboot after several seconds, but the noise would start before it reboots).

Never had an issue with noise on any RPi system susing USB or HAT and I’ve got 3 of them using HiFiBerry for 2 and native USB for one of them. Had touchscreen on 2 of them and it made no difference to the SQ with or without.

What happens if you disconnect your Aune S6 DAC from your Amp and connect headphones to it? Can you still hear the noise?

There is no noise in the headphones – only when the speakers are connected.

I connected my tried and true Aune T1 Mk2 instead of S6 and there’s no noise! It seems S6 is poor at filtering it out.

I have sent an email to Aune for a comment.

@Darius_Matuliauskas, it’s not necessarily poor filtering. It might be that the S6 has a component or trace on the PCB that happens to be the right length and in the right orientation to be acting as an antennae for picking up whatever noise your RPi is emitting. (You could try turning the S6 90º and see if the level of the noise changes. That might or might not indicate antennae behaviour.)

As per recommendations from Aune, I have tried disconnecting ground from S6 and the noise disappeared.

Is this normal mode of operation or does it indicate poor design / manufacturing of the device?


When you say disconnecting ground, I hope you dont mean the mains safety ground!!!

So this confirms its is a ground loop/noise issue. I have used a RPI3 with multiple different DACs and not had an issue, however it is always a potential if a single ended (RCA not balanced) system has multiple connection points to ground, or via certain SMPS.

However you really shouldnt see this if the DAC has a galvanically isolated USB input, which is pretty much par for the course these days. Balanced connection should also minimise the issue.

So, unfortuantely to my mind, yes it does sound like bad design from Aune.

One other solution is to use a USB isloator such as the Intona.

1 Like