Internal Server Error when I try to connect to the Ropieee Pi

I had a RopieeeXL endpoint working fine for 6 months. Following the upgrade to 1.8 I experienced connectivity issues much like the rest of the Ropieee community.

However I had decided to reinstall the software (for, it turns out, no good reason) I have now tried several reflashes but I can still not reach the management page at the ip address the endpoint is reporting.

Currently I get an error message:- Internal Server Error.

I’m reasonably computer and network literate but this problem is way down my list of priorities. I have a few hours to try and fix it this weekend, maybe the next opportunity will be in a weeks time.

If SSH is suggested I will need some helpful OSX related instructions.

Are you sure you are using the correct IP address? Have you done another port scan?

Would you post the error you are seeing?

To uses ssh follow these instructions. You’ll need to know the IP address of the Raspberry Pi. Are you getting the Internal Server Error message when attempting to load the Ropieee web interface? I agree with @Nathan_Wilkes that your IP may have changed.

ssh root@<IP address>

Enter ropieee for the password and …

Welcome to RoPieee


Keep in mind that changing stuff is not recommended and not supported!

Have fun!

[root@<host-name> ~]#
1 Like

Terminal returned port 22 “connection refused”

I am using the ip address that the device is reporting on the Zone Not Found screen.

I have been able to play through it but the screen still reports “zone not found” and “is your dac connected”.

I am deducing (possibly incorrectly) that I could fix this if I could contact it as normal to set the zone properly.

This exact setup was working fine from the initial installation 6 months ago.

I do use static IP’s but even with them disabled this problem has persisted,.

If I try http://ropieee chrome delivers this error :- DNS_PROBE_FINISHED_NXDOMAIN

among others depending on browser etc.

A port scan of the ip that the ropieee is reporting looks like this :-1:

 Open TCP Port: 	80     		http
 Open TCP Port: 	8080   		http-alt
 Open TCP Port: 	35101
 Open TCP Port: 	44601
 Open TCP Port: 	44663
 Open TCP Port: 	44989

What is displayed on Roon Settings > About? Is the Ropieee listed? Is it the same IP address you’ve been using?

This is not the normal set of ports: I would expect 22, 80, and perhaps 8080 based on a set of nmap scans I just ran.

Run Fing on your phone or check your DHCP log on your router to confirm that you know the IP address of your new build. I’d suggest not using ropieee.local and instead using the IP address to connect to the web GUI.

1 Like

I would have expected 22 as well. I had already been checking DHCP logs and have now run Fing although it reports the same data as the port scan.

I would give more time to diagnosis but it was running and now it’s not, coinciding with 1.8 release. I have to disentangle the coincidences and try to diagnose it. I had nothing else change aside from the 1.8 update and reflashing.

Yes, same IP. There is a total correlation of ip address across the network.

I don’t understand how RoPieee is reporting an IP address to you. I am also suspicious of the other open ports — this is why I wondered whether your new build actually changed IP addresses, and so you were actually scanning a different device on your network by mistake.

A screenshot of the error message when using the IP address on port 80 would be helpful, as I mentioned before.

Also, for clarity, is the status LED on your Raspberry Pi flashing at 1/2Hz, showing that the install is finished? And, normal pings to the IP address are successful, correct?

It seems quite unusual to me too, are you sure you are scanning the right io address?
This is the scan of my RoPieee

The Ropieee has a 7" screen. When it is running it tells you where to find it (For configuring Ropieee point your browser to http://ropieee or is the exact wording). That correlates with the router and fing which report a device called ropieee at

When I point my browser to either address I get the message “Internal Server Error”.

The Ropieee can still operate the dac, it’s possible to enable the zone and the spockfish extension in Roon, Roon reports the same IP address. However the Ropieee screen has the error message :-

We’re still waiting for the zone to be controlled

  • Is your DAC turned on?
  • Is the Ropieee Remote Control extension enabled in Roon?
  • Is the correct zone configured in Ropieee?

Now in answer to those questions

Yes, my dac is turned on (in fact I can play music from Roon through it)
Yes, the remote control extension is enabled
No, I cannot configure anything in Ropieee because I can’t connect to it using SSH.

I have tried re-flashing with a normal pi operating system and currently the device has been re-flashed 5 times.

I have checked my static IP’s and there is no static ip for the ropieee address or conflict with the MAC address. I don’t know how to double check the MAC address of the ropieee but it’s being reported by the router.

In short the ropieee is not presenting port 22. This is not speculation it’s demonstrable. Any ideas why or how to fix that problem would be useful.

Just for clarity, yes, the Ropieee status light is flashing at 1/2hz.

Apologies for not posting a lot of pictures backing this information up but hopefully you can assume that I’m checking the obvious stuff and have been through the sub forum threads looking for answers already :slight_smile:

It seems you have not enabled ssh in the Advanced configuration tab

That is a helpful observation but I’ve had no opportunity to change the settings since this is a re-flashed pi and I can’t access it through SSH. Surely the default settings would apply.

This does introduce a possibility that there is a way to use another port to turn SSH back on if that is what’s causing the problem.

Have you tried clearing your DNS cache?

dscacheutil –flushcache
sudo killall –HUP mDNSResponder

Also, I’d be tempted to install standard Ropieee first and upgrade to XL once everything is working.

Thanks for the script. I am trying to connect with the ropieee through a few different devices so I’m guessing they can’t all have the same problem with the DNS cache.

I have installed normal ropieee and would then upgrade to XL as per the advice on the current ropieee distribution web page. When I first installed it last year I did go straight to xl.

I tried the script but no change unfortunately.

When I access port 8080 I get a screen saying “Upgrade Required”

This is expected behavior, because you have not configured your Roon Control Zone in the Display tab yet, right? (This is the first time I understood that you were using a display.)

Are you saying that the RoPieee GUI works for awhile, and then fails? Or it used to work, but doesn’t now? In other words, what do you see when you point your browser to the IP in question?

The reason I asked for a screen shot of the error is to see exactly what you are looking at, because there may be a clue as to what has failed in your situation. Is the error only on the display (meaning you have not configured it yet), or is it that the administrative GUI doesn’t work (the reported “Internal Server Error”?

(If the only error is the display, just configure the Display tab correctly and enable in Roon Settings. There are guides on the forum + web if you need these.)