Internal vs. NAS with ROCK and slow transfer speeds

Thoughts on which is better and why I am getting slower transfer speeds on the same hardware with ROCK than I was with Ubuntu?

I am having trouble gettIng to the internal drive in ROCK from other platforms (DietPi for example) and am thinking of just using my NAS for music storage given that and a degradation in file transfer speeds with ROCK.

What speeds are you seeing and what are you expecting and what is your setup?

what is the problem with \\ROCK\Data\Storage\InternalStorage ?

I have the same problem. I just set up my first NUC with ROCK. Fabulous instructions and install. Everything worked great. I have M2 memory and an internal SSD so I decided to transfer my Music folder from a network drive which Rock sees and uses to an the internal drive. The music folder is 100 Gb. When I drag it on my Mac desktop from the Network drive to the \InternalStorage it slowly starts transferring into the internal NUC drive. It estimates it will take about a day. I also tried attaching external drives directly to the NUC USB ports. I can see them through the ROCK network mount on my Mac desktop but file transfers fail. I was thinking about booting the NUC in Ubuntu from a flash drive and transferring the files to the internal drive but before messing around with command lines and possibly screwing everything up I thought I’d ask how to mount an external drive to the ROCK and/or how to xfer files from a networked drive to the ROCK. I just know I’m missing something obvious but what?

1 Like

Good question, I didn’t record the speed when using Ubuntu, but when I transferred my music as @Bruce_Chassy describes it took about twice as long, maybe longer, with ROCK than it did with Ubuntu, on the same machIne, same network connections. I was also transferring using a Mac.

Nothing. Turns out it is a problem with DietPi holding any samba mount in it’s prefs. I initially thought it was due to the guest login.

I am still poking along. The files are transferring but claim they will need another day to move the remaining 65Gb. The rate is slow but the files do seem to be being moved.

Why is this so slow?

are you transferring over wifi?

Yes because I could not mount a USB drive directly on the NUC. The Wi-Fi modem/router is a Netgear R9000 that is one of the newest and fastest and there is virtually no other traffic on the network. The NUC is wired to the Router using ethernet over power line which is >200mbps. I don’t expect a Wi-FI connection to be blazing fast but even at 10mbps this job would be long done with.

When I plug an external USB drive into the NUC I can see it on the desktop from my Mac. It gives me an error popup when I tried to move a file. The disk is formatted in exFat. I have disabled the Music library settings.

The good news is that it still claims it will be done in “about a day”

how much are you transferring?

Two folders. 48Gb and 104Gb. I just did the math. 48hrs would correspond to 53 mbytes/min or 767 kbps. (Check my math). 0.7mbps is pretty slow even for wi-fi.

Just for the fun of it I measured it for an hour. It’s going 1.7 Gb/hr. I think that works out to 3.8mbps. Not exactly fast but faster than my first guestimate.

My speeds were faster than that, but they were about twice as slow as when using Ubuntu.

I found this when doing some research on the subject, but it is a bit beyond me. Make any sense to either of you?

48hours * 60minutes * 53megabytes/min == 152640 megabytes (48gb + 104gb)
53megabytes/min / 60seconds == 0.883333333333megabytes/sec, or 904.5333kilobytes/sec
904kilobytes/sec == 7236kilobits/sec (or kbps), or a bit over 7megabits/sec (or mbps)

I just did a quick test on my ROCK install at home:

Over WiFi, from a Macbook Pro running Mac OS 10.12.6, to a slow ExFAT formatted USB2.0 5200rpm Western Digital Passport drive from 4 years ago, connected to ROCK running on a NUC6i5, I am getting 47megabits/sec. I’m also upstairs and bouncing through 2 Eero mesh WiFi routers before going ethernet to the NUC.

Something is wrong on your SMB sender, your network, or your drive is failing.

great find! I get it even though I am far from expert. I fear that it will possibly add some speed to use this fix and it’s really good to know about but I don’t think this is my main problem. I do think it was quite possibly your slowdown. I will give it a try after the files finish transferring tomorrow and report back.


Thanks for the benchmark. That’s more like it. I was expecting at least 50 and that’s where you are. I have measured the network speeds on both the wi-fi and powerline ethernet and they are way over what I am getting. I don’t think that’s a problem. The behavior is seen with various drives so that’s not it. I cannot rule out servers and hosts not playing nice with one another. I think that’s the problem and I am pretty sure it comes from the Apple side. I am using a late 2016 MacBook Pro with touchstrip. Frankly, it’s a dog. It’s a very responsive machine with an awful keyboard, a useless touchstrip, USB-C ports that are too close together, and major quirky behaviors. In fact right now the search function is globally dead. It won’t work in Spotlight or Mail. There have been other weird behaviors. All I can hope is that the forthcoming release of High Sierra will sort out some of these odd behaviors. I’m going to wait until after I have that installed to try to fix this. On the host end of this the i7 Nuc is brand new with new M.2 and SSD drives and the ROCK install from Roon which appears to me to be solid as, well, solid as a Rock. Great work by Roon labs. And I trust a Linux installation a lot more than Apple’s strange version of the software. In the interests if making it user friendly they do stuff that they ought to tell people about–like the SMB signing issue fritzg picked up on. It’s really too bad Apple doesn’t get it and open up their system.

FWIW, the transfer completed overnight and I now have about 150Gb of music files on my Internal Drive. It obviously speeded up a little overnight and managed to upload more than 40Gb in 12 hrs or less. There is really something strange going on with my network set-up but I think I’ll just move on since the needed file transfers are completed.

agreed, that is a strong symptom of network being the bottleneck, since the software didnt change in that time period, nor did the drive.

Enjoyed the thread on file transfer speed. I am a new user and had a Rock up and running for about a month. It works just great. However I have decided to update the library on the internal drive on the NUC and ran into the transfer speed problem. My typical speeds were 1-3 Mbytes/sec. For a terabyte of data it would take a long time. Poking around various posts I could not get any improvements. I quickly realized that the ROCK being a Linux Box formatted the internal drive in a ext4 format. This was not recognizable on my Windows 10 desktop. Probing around on the internet I did find a software from Paragon Software called ExtFS for windows. I removed the internal drive from the NUC after formatting it with the ROCK OS and attached it to the desktop through a USB 3.1 dock. I also attached the USB 3.1 drive with the library also through another USB 3.1 port. Initiated the ExtFS software and was able to see the ext4 formatted drive in windows explorer. A drag and drop copy for done to start the copy process. It was able to copy 1.4TB in about 3 hours. Wow! Thought I would pass this along. I realize all the frustration out there. Ideal solution would be for the Rock OS to be optimized for this copy operation without the need to use a third party solution. Good Luck. Hope this helps others.