Internet Radio - Some stations play only out of one channel on ROCK/Nucleus [Ticket In]

Core Machine (Operating system/System info/Roon build number)

Latest ROCK on NUC installed a few days ago.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Fios --> router --> NUC --> USB --> DAC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


One channel of internet radio is out (right) on many but not all stations. It mostly is contained to various streams of New York Public Radio (WNYC, WQXR, …). It is consistently out for those.

I played these stations directly from QT/I tunes. No problem.

finally, as a test i switched my Roon core from ROCK to my trusty, ancient Macbook Pro. Works fine.

Conclusion: something is wrong specifically with my NUC/ROCK. Note that it is connected to the same ethernet switch, same USB cable, to the same DAC. The ONLY change is the computer. Other stations (WFMU, radio paradise, BBC) have both channels.

Problem. Note I will be traveling on business for a few days.




Have you tried rebooting the server?

yes. didn’t help.
I have also tried disconnecting and re connecting the USB --? DAC. Appeared to work once but not another time. problem is, this is intermittent to begin with.

Can’t have to reboot the server every day in any event!

Thanks for the reply,


just one adder… since most of the problematic stations are associated with NYC public radio, it could be them…time will tell.

Well, its not NY Public Radio. Switching to a laptop from Roon and using the player to play the stream directly works just fine. So something is going on between the stream and Roon on the ingest side.

Hi @Just_Me,

What kind of DAC are you using as the endpoint here? Is the behavior the same for any other endpoints connected to the NUC?

I have used two different DACs, but cant say more. The primary DAC in question is a denafrips Ares II. remember though that switching to a differen troon core sixed it. It almost has to be the roon (ROCK) core or its interplay with the NUC.

ps: you did read all the way above where it says updated right? I re-wrote narly all of that after doing more testing.


Hi @Just_Me,

Can you share a link to some of the stations affected by this issue? I’d like to give the streams a try on my end.

Sure. See below. but note that they work with Roon on my MacBook Pro, and they work from the browser, but not with my new ROCK/NUC. That’s the mystery!
It’s affects all the variants of New York Public Radio - WNYC, WQXR, Operavore, …

New Jersey Public Radio (in the same stream family) is NOT affected and comes from a New Jersey, not New York, source.

Thanks for the help.


Hi @Just_Me,

I tried all of your links on my ROCK and they appear to be playing from both channels, so this is strange indeed. Does the same behavior occur when using both USB ports?

(Edited for typos, clarity etc.)
It doesn’t look like you have read through all my posts for the complete history. Let’s back up - most stations play two channel on my ROCK/NUC. The stations in question play fine on another roon core on a different (Mac, old) computer on the same ethernet hub. So you really want me to switch USB ports? If so, when i get home i will give it a try, but this seems like grasping at straws rather than asking what’s up with the code"? I just want me ROCK, which is a big investment over the free old macbok pro i was using to work.

I’m happy to help debug - sure. But why exactly would the USB port be at fault if BBC works fine, radio paradise works fine but 3 NPR stations do not? Moreover they continue to not work (play left channel only) consistently after reboots, deleting and re loading the stations, etc.

Just please confirm that you had all that in mind when you asked - its easy enough to do, but not from hundreds of miles away. And it seems to be a legitimate problem with very early code.

Update 9-11-19

I am back and have done as you asked, and tried the other USB ports on the NUC. Problem is unaffected. I also changed Ethernet ports (as if that could possibly be the issue) - unaffected.

I still have three of my primary radio stations playing only the left channel. WNYC, WQXR and operavore (WQXR)

Good news! But troubling still…

I have it working full stereo. Sorta. On a whim i decided to try the MP3 versions of those stations (WNYC-FM, WNYC-AM, WQXRFM), rather than the AAC versions.

They are playing. but this begs: “why?”. Clearly the AAC versions work natively on my old Macbook, and in Roon on that same MacBook, and according to Roon support, in their tests on ROCK (i presume they (you?) successfully tested it on ROCK since that’s where I was getting failures).

So i have a work around. but something is still wrong.


Just a thought, but have you gone through the step of adding Codecs to your ROCK/NUC installation? And does the ROCK Web UI administration page report that they have been added successfully (i.e. the “missing codecs” error message no longer displays)?

Yes, i added the codecs. Missing codecs message was gone.

And, note that a) one channel (Left) works and it works on many other internet radio streams.

Good thought though.

Hi @Just_Me,

First off : I haven’t tried yet in my own Rock, so I’m not sure how it behaves.
Will do that, later on.

But I do want to share a thought already:
I notice that all your streams are AAC + encoded (notice the plus!).
AAC+ files are not ‘true’ stereo, in the sense that they contain two channels.
They are mono (single channel), but contain a tiny additional sideband. This sideband can help approximating and restoring the original stereo spread. This is called Parametric Stereo.

But if the player does not understand this sideband, then it is expected to play just the mono track.
Which seems to happen in your case.
I might be mistaken, but I seem to remember that FFMPEG needs an external library to support AAC+.

I think it makes sense to think, that perhaps (your version of) FFMPEG does not support the Parametric Stereo of AAC+ ?

As said : will try to check on my own Rock next week. But perhaps this info can already help out a bit… :slight_smile: .


Top CODEC knowledge display!!

Very interesting. FFMPEG was added ( I did it). But that would explain the problem. I need to check whether any of the other stations, which have always worked, are also AAC. I did note above that I switched to the MP3 stream and it did fix the problem.

Surprised that the support staff missed this. They asked for the links and tested them (supposedly).



If support says they have tested, then they have. You may trust that :). Perhaps they just hadn’t gathered every relevant piece of info yet.

I’m home for a couple of minutes now. And ou know what ? I can reproduce this! At least, with the codecs linked in the Roon Knowledge Base (so, this one : )
Indeed I got only single (left) channel.

No time to test this through today, but it seems like the codec that I originally used has no trouble.
Playing both channels (not sure if it is really stereo…).

Have to leave the house now, but perhaps you can give it a spin. My files are labeled ffmpeg-3.3.1-64bit-static.tar.xz. If not possible to find with Google, I’ll be happy to upload for you.

Please report back; would be nice to know!