Internet radio station not working - problem only on rpi3 running dietpi

Installing Roon Bridge from the DietPi installer should lead to the same result as a manual install.

What happens if you turn upsampling off for now?

I see that you’re using the ‘384kHz kernel’ – if turning off upsampling helps, you could try to revert to the latest officially supported (Raspbian) kernel (4.4.50) and limit upsampling to 176.4/192. In my experience, the higher numbers do little else for these boards than display higher numbers anyway.

You hit the nail Rene! Thank you. Sorry - I didn’t think of that. I had the upsampling set to power of 2. When I turn off upsampling, or if I limit the upsampling to 176.4/ 192, there is no problem as you can see it has now been running for more that 10 minutes. I have tested both RPI3’s and this solves it.
I still don’t understand why Tidal and my own music works flawlessly, and the radio doesn’t. Well fine for me anyway.

1 Like