Internet Radio stopped working after roon update

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

This has been working just fine until yesterday. Now it plays for a few seconds then says ‐ unable to play this station…

I’m very unhappy about this.

Hi, you say the core is android? That probably isn’t right so can you check? Core should be on a PC, Mac or suitable NAS. Also this can be a networking issue so some detail there would be helpful.

The core is on my innuos zennith mk 3. Not networking issue. I can connect to the internet when internet radio is unavailable. This problem appeared yesterday immediately atfet roon update. Just tried again just not. It connects and plays then stops and displays the message I referred to in my original post.


  1. It would be helpful if you could tell us which Internet Radio Station was having an issue
  1. Did you try the Internet Radio station not the internet using a different machine? The point I want to make is that Internet Radio has many hops between where the stream originates until it gets to you. Any issue along that pathway can cause playback problems. Checking the Interent Radio Station with a different device/software will let you know if the issue is “out there” in the internet or with Innuos/Roon.

Hi @Peter_Duthie,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Please also verify the following:

  • Since experiencing this have you tried rebooting the Core machine?
  • Does this occur for all internet radio stations or just certain ones?
  • Does this occur for all endpoints?
  • Does other content in Roon play without issue?

I have a Wi-Fi connection to the router next door. The music server is connected to the Ethernet socket on the Wi-Fi receiver/transmitter

Reboot. Everything yes.
I have two stations. Both behave the same. I.e. disconnect after a few seconds.
There is on one endpoint.
No, present, issues with roon other than this.

I only listen to two radio stations. BBC Radio 3 BBC Radio 4.

OK, well it’s no consolation, I know, but both of these are playing quite happily on my Core (ROCK on an Intel NUC) following the update to Build 416. Because I’m outside the UK, I can’t use the hi-res audio streams, which are geofenced to the UK. So for example, the Radio 3 url is,aac

Does this work for you?

Thanjs for your attention. I have tried the url you gave me. It works for a few seconds then craps out unfortunately.

I listen to Radio 3 a lot and would love to get it up and running.



Thinking back. I was maybe trying to play the radio during the update install. I think I may have closed roon too early. Is it worth trying a reinstall of the update? If so please give me instructions.


That works for me in the US. Thanks for the url!

Hi @Peter_Duthie,

Are you playing this to System Output of your Android device?

If you play to System Output of a different remote does the same behavior occur?

I only use one output device. It’s all I have. :slight_smile:



HI @Peter_Duthie,

If you have a Windows or Mac machine available that you can temporarily use as a remote, knowing if the same behavior occurs there would definitely be a great data point.

Moving forward, I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

It is behaving much better tonight. I stared at about 18:00 UK time it carspped out around 18:33. But it has been playing fine since then - it is now 18: 38.

I can live with the odd crap-out but before tonight it only lasted a few seconds before failing. If you like I’m happy to shelve this and can get back to you if the problem recurs.

I don’t understand it but I am hopeful that, maybe, all is well. However, do feel free to turn on your diagnostics.

Still playing fine at 18:43.



Damn. Just crapped out again at 18:44. So, yes turn on the diagnostics. Please.



Thanks, @Peter_Duthie.

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Many thanks.


Hi @Peter_Duthie,

Thanks for your patience here while we’ve looked into this. I spoke with the team about this and they’re seeing some errors that appear to be related to networking issues.

Moving forward, I was hoping you could clarify the following:

  • Just to confirm, the only device you play to is System Output of the Android device? Can you share a screenshot of Settings | Audio?
  • If you run a network speedtest can you share your results here?


There is only one output and that is to my Anthem STR amp. I think you should take my word for that Dylan. Running a speed test is pointless - it’s around 25 Mb/s just now but can go to 40/50. There are two problems here.

  1. Use a a power line and that is subject to noise on the line sometimes. I will, in time, fix this but not so easy as I have a 3/4 ft wall between my router and the room where my HiFi is.
  2. Is strongly suspect that you have shortened the buffer, or equivalent, that accepts the internet radio data stream. I get much better results running the radio on Orange Squeeze.

If you could progress your investigation on the basis of 2 above I would appreciate it.