Interrupting import after some minutes

Core Machine (Operating system/System info/Roon build number)

Running Roon 1.6 build 416 on a MacMini Late 2014 2,6GHz i5 16GB 10.14.5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Library on a NetGear ReadyNas running latest Raidar.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
A mix of Squeezeboxes and 3 Marantz 7012

Description Of Issue
When I try to import the record collection the import always stops after some minutes. What is imported is possible to play without any problem. But I need help to find out what is stopping the import. Another of my Roon servers has imported the whole record collection without any problem.
Thanks in advance

If you go to Settings / Library / Skipped files is it showing any problem files there?

Thank you so much.


Well actually that did not solve the problem. Removed 6 corrupted files but that did not solve the issue. Roon still stuck after only a 10th of the collection.


Hi @Bengt_Andersson,

Can you please share a screenshot of the “Activity Spinner” progress when this issue occurs? The Activity Spinner is located in the top right-hand corner and looks like this:

You can upload screenshots to this site but following these instructions.

– Noris

Here comes 2 screenshots. Nothing strange happens, everything is looking alright. The only problem is that it ends happily way too early.

Hi @Bengt_Andersson,

Thank you for sharing that screenshot. A few follow-up questions:

  • How is the library stored on the other Roon Server that completes the import as expected, is it still using the ReadyNAS?

  • By “finishing early” do you mean to say that the import never completes identifying all the content on the i5 Mac Mini and some are missing? I believe this is the failure state here, but I just want to confirm.

  • Can you provide a few examples of tracks/albums that are not importing?

  • Do you notice any patterns in the type of content that is not being imported? E.g. all are DSD files or all have a specific audio format, contain special characters, ect.?

  • How large of a collection are you trying to import?

  • Have you tried rebooting the Roon Core yet? If not, can you give this a try?

– Noris

It is the same server. Does not show any odd behaviour accept that it stops at 2263 albums. In the NAS there should be approx 27.000 albums. To my knowledge there is no DSD at all among all the albums. I have tried to reboot. I have reinstalled. Nothing helps. It get stuck on the same number of albums. So if there is a problematic album, how can I tell which when Roon claims it not skip any files.

Hi @Bengt_Andersson,

You mentioned that you tried to reinstall Roon and the behavior is still the same, but have you also set the old database aside when performing the re-install? I think it would be worthwhile to give this a try and you can set the old database aside by using the following instructions:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location:
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Try the import process again

Do let me know if there is any change if using those instructions.

– Noris

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.