iOS apps not able to connect to iMac Big Sur (11.7) running Core 2.0

Roon Core Machine

iMac (Retina 5K, 27-inch, Mid 2015)
3,3 GHz Quad-Core Intel Core i5
Memory 32 GB 1600 MHz DDR3

Networking Gear & Setup Details

Asus RT-AX58U router/wifi
TP-Link SG3424 managed switch

Connected Audio Devices

Linn Klimax DS (network connected)
Linn Akurate DSM (network connected)
Linn Sekret DSI (network connected)
Moon 850D DAC (USB)
Naim Muso QB (wifi)
Sonos AMP (network connected)

Number of Tracks in Library

35.000 tracks

Description of Issue

All iOS are on version 2.0 (they were automatically updated). I installed the core on the iMac as RoonServer; I restored the database from the mac Mini used to run Roon 1.8 (mac Mini cannot run 2.0 as I can’t upgrade it to macOS 10.15).

The core runs, and I can connect to it with ARC (iPhone on cell). Also, on the iMac, when installing Roon, it can be reached (but in that case, you have two cores running on the network when also RoonServer is running); see the image below:

Looking at the IP addresses of the cores, it occurs to me that the first one listed has the (fixed) IP address of the iMac; the second seems to have the router’s IP address.

Stopping the RoonServer core leads to just one core on the network, with this result:

I defined a port forwarding on the router:

Where 10.174.0.2 is the fixed address of the iMac.

Roon ARC works, but I frequently get the message “Poor connection.” This is strange as the iMac is on a network with an 800Mb/800Mb fiber internet connection, and I have the same in the office. Wifi is capable of 1.5Gb max on both ends.

I do not get any further than this. I have installed the Legacy 1.8 version on the mac Mini and the Legacy version for the iOs apps, and at least everything works again. But Roon 2.0 does not yield favorable results thus far.

I would appreciate if someone took a look at these connectivity issues. It seems the focus is on Roon ARC, which is fine. But I can’t use Roon 2.0 on any of the equipment I have. Only on my iPhone and in the car - luckily, it’s a Volvo with a B&W system, but still.

I have tried several things. Reinstalled after cleaning the Library content of Roon as well. To no avail. Still the same connectivity problems. No control point other than on the iMac running the core can access.

Anybody? I have two Roon accounts; one connects my Roon 1.8 core, the other connects the Roon 2.0 core. Why is it I can connect to the Roon 1.8 core, but the Roon 2.0 does not allow any connection?

Does anybody at support bother to look at this? That’s the bare minimum you could do, right? I have a lifetime license, so paid 500 USD for the software. I just want to be able to run and enjoy it, just like every other customer.

I initiated the ticket on September 23rd. It’s October 2nd now, and nobody even bothered to respond.

Let’s flag Roon’s @support team for you here, as this thread appears to have escaped their view.

Hey @Arthur_Venis

I’m sorry to hear that you had some issues after the update. It looks like your problems were caused by incompatible builds. Your Core machine is on Roon Legacy 1.8 because your Mac OS is 10.13.6 which won’t work with Roon 2.0. (2.0 requires Mac OS 10.15 or later) Your remotes are on Roon Remote 2.0 but they can’t talk to your Core because it’s 1.8

In checking your system diagnostics, it appears that you were able to install Roon Legacy 1.8 on your remotes and have been enjoying music. Can you please update us on your current status? If you’re still having trouble and need help we’re happy to lend a hand! Thanks!

1 Like

Hi Jamie,

Thanks for the response.

Here is the summary of the current situation:

  • Yes, I am running 1.8 Legacy right now because it is the only to use Roon in the network.
  • Yes, I have a MacMini running the 1.8 Legacy version as it can’t upgrade to Roon 2.0
  • I installed another core on an iMac running 10.15.7, so it runs Roon 2.0
  • None of my iOS devices can connect to the Roon 2.0 core - see the screenshots I made
  • ARC is running and accessible, although its stability is only so-so. My server runs using a fiber internet connection with 800 Mb up- and download; bandwidth is enough, I think.
  • I have tested with the Legacy server switched off, the 2.0 server switched on, and both switched on. The only way to play music in the network is with the 1.8 Legacy core. Everything else is unusable inside the network.

In conclusion, it has nothing to do with incompatible builds. Even when all parts are running the same build (2.0), no iOS device can connect to the core. The only way I can connect is when I start Roon on the iMac that runs the core; in that case, I get two servers running 2.0 (one Roon Core and one from the Roon app).

So, the problem is not solved. I am not able to switch to the new version. I hope someone can shed some light on this, as it is unclear to me what causes the issue.

Regards, Arthur