iOS can't find Roon Core (but my desktop can)

Roon Core Machine

Mac OS latest version 13.2 (22D49)
3.2 GHz 8-Core Intel Xeon W
32 GB 2666 MHz DDR4
Hardware Overview:

Model Name: iMac Pro
Model Identifier: iMacPro1,1
Processor Name: 8-Core Intel Xeon W
Processor Speed: 3.2 GHz
Number of Processors: 1
Total Number of Cores: 8
L2 Cache (per Core): 1 MB
L3 Cache: 11 MB
Hyper-Threading Technology: Enabled
Memory: 32 GB
System Firmware Version: 1916. (iBridge: 20.16.2059.0.0,0)
OS Loader Version: 564.40.4~55
Serial Number (system): C02VV08CHX87
Hardware UUID: CEDE8153-7E01-577F-920B-02D208135429
Provisioning UDID: CEDE8153-7E01-577F-920B-02D208135429
Activation Lock Status: Enabled

Networking Gear & Setup Details

Mac OS latest version 13.2 (22D49)
eero mesh network (all wireless)
iPhone 14 (up to date os)
all on the same wireless network


Type: Ethernet
Hardware: Ethernet
BSD Device Name: en0
Configuration Method: DHCP
Configuration Method: Automatic
MAC Address: d0:81:7a:d6:dc:fc
Media Options:
Media Subtype: none
Exceptions List: *.local, 169.254/16
FTP Passive Mode: Yes
Service Order: 0

wi-fi Airport

firewall is off
Firewall Settings:

Mode: Allow all incoming connections
Firewall Logging: Yes
Stealth Mode: No

addional wifi details
Software Versions:
CoreWLAN: 16.0 (1657)
CoreWLANKit: 16.0 (1657)
Menu Extra: 17.0 (1728)
System Information: 15.0 (1502)
IO80211 Family: 12.0 (1200.13.0)
Diagnostics: 11.0 (1163)
AirPort Utility: 6.3.9 (639.19)
Card Type: Wi-Fi (0x14E4, 0x7BF)
Firmware Version: wl0: Sep 14 2022 18:10:05 version 9.30.489. FWID 01-31bf0e8d
MAC Address: 8c:85:90:96:9b:78
Locale: FCC
Country Code: US
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1 (2GHz), 2 (2GHz), 3 (2GHz), 4 (2GHz), 5 (2GHz), 6 (2GHz), 7 (2GHz), 8 (2GHz), 9 (2GHz), 10 (2GHz), 11 (2GHz), 12 (2GHz), 13 (2GHz), 36 (5GHz), 40 (5GHz), 44 (5GHz), 48 (5GHz), 52 (5GHz), 56 (5GHz), 60 (5GHz), 64 (5GHz), 100 (5GHz), 104 (5GHz), 108 (5GHz), 112 (5GHz), 116 (5GHz), 120 (5GHz), 124 (5GHz), 128 (5GHz), 132 (5GHz), 136 (5GHz), 140 (5GHz), 144 (5GHz), 149 (5GHz), 153 (5GHz), 157 (5GHz), 161 (5GHz), 165 (5GHz)
Wake On Wireless: Supported
AirDrop: Supported
AirDrop Channel: 149
Auto Unlock: Supported
Status: Connected
Current Network Information:
PHY Mode: 802.11ac
Channel: 64 (5GHz, 80MHz)
Country Code: US
Network Type: Infrastructure
Security: WPA2 Personal
Signal / Noise: -67 dBm / -92 dBm
Transmit Rate: 260
MCS Index: 3

Connected Audio Devices

2 Blue Node

Number of Tracks in Library

Description of Issue

I recently moved my roon core to a new server.
when I run the roon remote on my iphone (same network) It can’t find the core.
this was working fine with old server
I reinstalled roon remote app on the iphone
I can access the roon core on the new server from my laptop as expected.
I can I resolve this issue?

As an aside, what is the difference between Roon Core and Roon OS Device?
(The Choose your Roon Core screen has a link “Configure Roon OS Device on your network” but it is just documentation, and doesn’t actually allow any configuration to happen).

Thanks in advance

Roon OS device is for a core running on Roons own operating system such as the Nucleus or self build ROCK installs on intel NuCs.

@Spencer_Marks, can you share the IP addresses of your Mac Pro Roon Core and that of your iPhone? Do you have any other network equipment in your network? Is your firewall on your Mac Pro Core configured to allow exceptions for Roon and RAATServer?

Thanks, so I am running the Roon core on my iMac. Thank you for the clarification.

Fire wall is turned off
Other iOS devices (e.g. my iPad) can connect to the Core.
Just my phone is giving me issues.
requested IP addresses:
phone →
server →

What do you see on your iPhone while looking for your Core? Can you post a screenshot?
Do you see something like Select a Different Core? If so, click that.

What version of Roon Core are you using on your Mac, Version 2.0? Is that the same version as on your iPhone? If they are the same version, maybe delete the app from your iPhone and reinstall it?

Hi same versions and I did do the delete app routine

Are you sure your phone isn’t on a guest network?
Are you able to connect to your 2 audio devices from the iPhone using the audio devices app? Are they Bluesound?

1 Like

Hi, so I tried all of these things before posting (as my original post specified) but I want to thank everyone who contributed a possible solution.
The resolution was to make sure my telephone number was set to work with FaceTime. I have no idea why this would have affected Roon connectivity. But when I enable my telephone number in FaceTime settings and reinstalled the Roon remote app (for like the third time) it was able to connect to the roon server. Man, what I pain. Thanks again. (He’s a plug for having Roon provide support for paying customers)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.