iOS endpoint does not resume playing after being paused [Ticket in]

Roon Core Machine

iMac Late 2013
Quad-core Intel Core i5
32GB RAM
Ubuntu 21.04, ufw firewall disabled
Roon Server: 1.8 build 814
Roon Endpoint: ios app 1.8.00814

Networking Gear & Setup Details

Netgear Nighthawk router, unifi ac lite AP

Connected Audio Devices

iPhone 6s running roon connected via wifi and outputting through dock connector

Library Size

24,652 tracks

Description of Issue

iPhone 6S will launch roon app, show up as an endpoint, and play local media without issue.
After ~5 minutes, if the music is paused it will consistently fail to resume playing. I am able to reproduce the issue with some consistency, but shorter pause times seem to resume playing occasionally. Issue occurs identically on windows-based core, so suspecting the issue is on the endpoint side.

Workaround has been to exit the roon app on the ios endpoint, relaunch, and resume playing.

Looking for troubleshooting assistance to determine why it plays without issue on a fresh launch, but after being paused will fail to resume playback.

Thank you!
MM

Hi @Mark_Mitchell

When it is failing to start playback are you receiving any errors or anything? What does it look like in the Roon app during this time? Can you do a quick screen recording to show what you’re seeing? Thanks!

Thanks Dylan,

No errors are presented.

Screen recording from endpoint.

in this video:

  1. begin new track, plays without issue
  2. pause @ 15 seconds
  3. wait a moment
  4. press play, pause button shows action received, but playback does not resume

Screen recording from controller (running on a separate Mac)

in this video:

  1. restart roon app on ios endpoint
  2. play new song, plays without issue
  3. pause
  4. resumes successfully
  5. pause again, lossless icon goes away
  6. resume fails, no error displayed

Thanks for the video, @Mark_Mitchell! I’m going to enable diagnostics so we can take a look at what happened here. I’ll be in touch once I have an update on our investigation!

Hi @dylan

Any update on this support request?

Thanks!

Hi @Mark_Mitchell, we’ve tried reproducing this on our end but so far we haven’t been able to. You previously mentioned:

If you remove the dock from the equation is there any change?

Tested just now, no change in behavior between dock connector and headphones. I also tried disabling private wifi on ios, but that also produced the same behavior.

Testing steps:

  • Close roon app
  • Unplug from dock
  • Plug in headphones
  • launch roon app
  • play a song
  • pause for 5 seconds
  • play for 5 seconds (successful)
  • pause for 5 seconds
  • play for 5 seconds (failed)

I’m having exactly the same problem with an iPad Air 2 that I use to listen to music in the evening. If I use wired earphones with remote then a paused track will not resume if you press it 5 seconds or more after entering pause mode. I’ve just tested on my iPhone 8 Plus and get the same issue with wired headphones. Interestingly, if I use my Air Pod Pro’s then it will pause but never resume - even if less than 5 seconds. The same thing happens with my Fiio BTR5 earphone amplifier that connects to the iPad via Bluetooth.

Another issue that’s possibly connected to this is that if I set a timer to stop the music after 30 minutes I will almost always get the ‘Select an Audio Zone’ message the next time I enter Roon on the iPad. Closing the app down and restarting it will always fix the problem. I think it’s something to do with the app going into background mode (I’m sure I’ve had the same problem when pausing the iPad via the earphones after 15 minutes or so).

Thanks for confirming, @Mark_Mitchell. I passed a ticket along to our team for investigation and I’ll be sure to reach out as soon as I have their feedback.

Thanks @dylan! and Thanks @John_Williams for reporting the same! Always helpful to have a sample size more numerous than a single user!

One additional data point, I have been using this setup for about a year and this issue started occurring in the last ~4-6 weeks.

Hi everyone,

Our QA team has pinned down this longstanding bug and we have a ticket with development. We’ll post here as soon as a fix is imminent and prepared for release with a Roon build - stay tuned and we’re grateful for the deep well of patience you’ve all displayed.

1 Like

Very disappointed to see that this hasn’t been fixed in today’s new build.

This is 100% reproducible on my iPhone 8 Plus and iPad Pro using AirPods. Start a track playing and the pause / resume works fine while the screen is showing. If you let the device sleep for a while you can pause the playback but it won’t resume … you have to wake the screen up and then it works. The same applies to wired earphones.

I appreciate that not many people may use an iPad or iPhone as an endpoint but I like to listen to music at night and rely on the remote. I’ve moved over to using Plexamp as it’s 100% reliable and gives a much better alternative to Roon Radio with their sonic analysis (and new DJ mode features).

This problem has been present since I started my Roon subscription 2 years ago - I’m surprised it hasn’t been addressed yet.

Roon Core Machine

OS: Pop!_OS 22.04 LTS x86_64 
Host: Inspiron 7560 
Kernel: 5.19.16-76051916-generic 
CPU: Intel i7-7500U (4) @ 3.500GHz 
Memory: 2932MiB / 15899MiB
Roon build 1211 production build on Core and iPad (iPad OS 16.3)

Networking Gear & Setup Details

WiFi connection from core to all remotes/bridges

Connected Audio Devices

iPad → 3.5mm headphone jack

Number of Tracks in Library

2,206 tracks in library

Description of Issue

When using my iPad as a listening endpoint, the listening zone is consistently dropped after the music is paused.

Shortly after pausing (I haven’t timed it), when I open the Roon Remote on the iPad, it says “nothing playing”, then says to select an audio zone, then repopulates with the iPad as a zone. This cycle is usually, but not always handled automatically after manually reopening the app. However, it often doesn’t work and the Remote has to be force closed and restarted.

I don’t use low battery mode or low data mode. Both the iPad and Core are connected to the router via WiFi.

Is there a workaround to stabilize the iPad zone and have it be available without actually having to open the Roon Remote app? Or is this just expected behavior? I dug around on the forum but didn’t really see a recent answer on the topic.

Hi @soks,

Thank you for the report, and we’re sorry to hear you’re encountering these difficulties. The team is aware of the underlying issue and has a ticket in the pipeline for a fix.

I’ll merge your post into the main tracking thread momentarily, so you can more easily and readily see updates once we release a fix. Thank you.

1 Like