IOS remotes disconnect and can't find Core anymore after roughly 1 hour or so

Roon Core Machine

Imac 27, 2020, I7 3,8 Ghz, 64 Go Ram, Big Sur 11.7.2

Roon latest version installed on both OS and remotes

Networking Gear & Setup Details

Imac on ethernet, no vpn, fibre, Wifi provided by a “last gen” (quite old tech anyway) AirPort Extreme. I know the Airport may very well be the weak link here. Nonetheless, it works quite great for the rest of my wifi usages

Connected Audio Devices

KEF LS50WII via ethernet
UAD Apollo Twin on my Mac

Number of Tracks in Library

61,000 tracks in library

Description of Issue

I Use an iPhone (13 pro max, IOS 16.3) and an iPad Pro (4th generation, IpadOS 16.1.1) as Roon remotes. Every hour or so, my devices disconnect from Core and can’t find it anymore. (message “waiting for Roon core” pops up etc…). The only way I found is to quit/relaunch the Mac Roon app, and then it works again : remotes find the core, everything’s fine… for an hour or so.

– Checked my network settings on Mac : no firewall
– Prevented my Mac to go to sleep, and then installed Amphetamine for good mesure. My Mac is now fully awake 24/7 with no results

  • Uninstalled / reinstalled Roon apps on iPhone / Ipad : doesn’t change anything

My home network seems fully functional (Plex server used via wifi on my iPad, Infuse streaming on my Apple TV, , Roon streaming to the KEFs, Hue bridge and so on…) everything is ok except the Roon remotes. I don’t understand what’s going on and where the issue is.

Maybe I missed something ?

Any help greatly appreciated! Thanks in advance!

Any chance to rule out this as the problem? Maybe a more current router you could try for a day or two?

Edit: Everything re-started, routers and APs included?

Thanks for your reply !

Tried connect everything via the wifi provided with my Internet box (not the best wifi system there is but it works) . Therefore with the Airport out of the equation, I guess, with …no results : same “waiting for Core” error on the remotes :-/ (

that said, I intend to get a mesh wifi system,I realize the airport is reeeeeally obsolete by now)

I’ll do a full restart of everything involved and keep you posted.

Thanx again !

Hey @Olivier_Ravard,

Ben with the support team here, I wanted to check in on this thread to see if you were able to get things sorted out?

I’ll be on standby for your reply. :+1:

Hello Benjamin. Well, after a lot of fiddling I tried to assign a static IP to my iMac / Core running machine, and to the remotes.Not sure if assigning a static IP to the remotes is useful in anyway but I guess it can’t harm.

And tadaaa, it seems ok now !

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.