iOS worse than before

I started a thread about 6 months ago on this and received info stating they were working on it but when I replied to that same post again about 3 weeks ago asking for updates I’ve not gotten any news so here goes again.

Sorry for posting again.


When will iOS be usable?

Used to be able to get a track playing but now crashes during searches.

Thank you


Maybe look to your system

I suspect 50% plus Roon users use iPads or iPhones 125,000 users .

I use an old mini , 6 yrs old, and a modern 12.9 pro , so different iOS with no issues . I can’t see the iOS app being the issue without MAJOR dissent from the users

Maybe @support can help

Just saying :sunglasses:

1 Like

Perfectly usable here as well I’m afraid on 1 x old iPad mini running iOS 12.4, 2 x iPhone XS running current iOS and one Amazon kindle thing thats’ not iOS obviously but runs another remote.

I know you’ve probably done it before but it would help @support if you described you system in their template format

If you raise a thread under #support, it’s automatic. Also in this section of the forum, support are unlikely to see your thread, they monitor the #support section. I can’t move it

I’m going to move this to support as suggested by @Mike_O_Neill . I’d also back up his view that this is likely an individual issue and doesn’t affect all iOS devices.

It’d also be a good idea to follow his suggestion and add some more detail about your setup, particularly the iOS device.

1 Like

Thanks for all the support.

Yes I filled out the required support info, it was a while ago but just haven’t responded in a while.I was told it was being worked on so I was exited when they upped the Roon os but sadly still no luck. Using Roon with my computer as remote since then but it’s getting tiring not having it at my phone (11ProMax ). It works on older versions of iOS on an iPad Air.

Thanks again,



If you give us some information about your system, one of the Roon Gurus may suggest a way forward. I couldn’t find your older thread to see anything.

Thanks, I’m not sure where to start so here’s pretty much everything.

If I’ve forgotten to mention something important, please let me know. thanks again.

ROCK on Nuc 8i5 with 16Gb Ram, 256 nvme boot & connected usb3 music drive.
I have the Rock and 3 audio zones (Meridian) on a separate switch from my Main network. ( very easily reproducible audio clicks and ticks when connected to the main dLink switch)

Linksys EA9500 MAX STREAM router

Macbook and iMac via wifi are Solid as remote / sometimes the local playback zone disappears but traced back to audio setting changes in Macbook.

Kids iPad Air & Air 2 are Solid remotes
iMac used as Pc workstation via ethernet is Solid

iPhone 11 Pro Max
tried various steps found in the support community

wifi on/off

Tried airplane mode.

deleted the app, shut the phone, restarted and reinstalled the app.

Something just occurred to me that may signal a bigger issue, I hope it helps.

While the MacBook works fine to select music and doesn’t crash like the phone, it doesn’t update when songs change.
at the end of a song, when a new one starts ( in radio ) I have to quit the app to see what the next song is and the time doesn’t advance either.

If I quit the app and restart the timestamp of the song remains at where it was when I restarted.

No updates till I quit again.


Hi, something I’m sure is important.

I just noticed that my core even after rebooting, seems stuck at " checking for an update" and my current OS version is 1.0.8 v 753, a few versions late.
gonna try manually unplugging to jostle it a bit as software methods not working

Have you restarted all your network gear

HI, thanks for the suggestion and yes, over the past six months I’ve gone through my network reboot a few times but it hasn’t helped.

I’ve always accepted the updates so kinda stumped as to why it hasn’t updated.

I’m hoping it just starts working properly once I get everything on the same version of the Roon OS, not sure why my core isn’t updating while my remotes update just fine, even after a reboot.


unplugging the live system and restarting got it to ask for the update again and it took it.
I don’t want to get too excited but it may have resolved the iPhone crashes.

One thing I’m noticing although it may have always been this way is the song time progress display doesn’t always advance 1 second t a time, it sometimes advances 2 seconds at a time.

This is looking like an iPhone thing , not iOS per se , if your iPads are ok but not phones. I don’t have an iPhone to check but my 2 iPads on ios 12 & iOS 14 are behaving themselves and the same despite the iOS differences

Why assume Roon is the problem. If it was, there would be (tens of) thousands of complaints. I have 5 year old iPad Prom— problem free!

The see this type of behavior over two generations of iPhones, two core hardware bases, two (three?) versions of Roon. No, it’s unlikely the iPhone. The network is fast and rock solid. Roon remote is the only app to crash awkwardly after some time. Second to none. And the only that requires a restart of the mobile to solve it for this time. If you don’t it takes like 20 seconds and it vanishes again. Happy for everyone not affected but for quite a few of Roon customers it’s a nasty reality. Unsolved for a very long time.

I have to say that I too have posed the question about iOS - and the constant crashing. My iPad runs Roon fine - I guess the iPadOS somehow deals with things differently. However, the iOS app on my iPhone 11 Pro crashes within seconds of opening… almost every time. I’ve tried with every other iPhone app closed - no different. I’ve tried different network hardware - no difference. I have a brand new NUC and ROCK. I can see the only issue being the Roon app on iOS (as differentiated - again - from iPadOS.
I pray that Roon will sort it out. It’s exceptionally frustrating.

unlikely to be Roon and more likely to be whatever things you have running on phone. With iOS14 (especially above 14.2) Apple have introduced a load of “security updates” where they are slowly starting to break all the tracking that apps use behind the scenes. Wait for iOS 14.5 when it gets really hardcore.

Don’t forget in iOS 14 they introduced all the tracking monitors of all things on your local network. And sometimes they just don’t quite play nicely.

For example on one phone, (not 2 other phones or 1 iPad in my house) Roon stopped finding the Core, it also stopped controlling my Philips Hue lighting system and unable to see my Devolo Poweline network.

Just one phone out of 10 Apple products.

Complete rebuild / reset and restore worked for about a day then all failed again. I did this about 5 times.

it was only by resetting all and NOT doing a restore (which was very very frustrating as was building a phone from scratch) that it solved it (and is still solved). I still have no idea what caused it.

The more these things interplay and control each other, the more likely sometimes a couple of apps playing badly together kicks something off…

Hmm. I’m not sure this is an adequate excuse personally. All the other apps on my phone work. Why not Roon? As I’ve said in my post just above, Roon crashes almost immediately even when I have quit all the other running apps. I appreciate there will be other processes going on in the background but still. Moreover, if Apple are doing all the tracking monitors you mention, they are presumably doing that on iPadOS also but that does not crash.
The fundamental issue is that Roon on iOS does not work. This needs to be fixed. It’s quite simple.


Agreed. And quite the same problem here.

That’s great for you. But is there any help from this to those affected other than to delegitimise their claims? From the other side of the fence: It’s real :confused: