iPad 6gen and iPhone 8 Plus fail to connect after coming out of sleep mode

I am facing exactly the same problem on my iPad 6gen and also iPhone 8 Plus.
Roon server is running on Linux 64x.
Once iPad/iPhone gets to sleep mode and I wake it up an d re-open Roon app, it can’t connect. When I try to switch “to another server” I can see my server, but in ‘initializing’ state. I have to kill the app on iOS device and then it suddenly has no issue connecting.
I’ve had this issue on iOS 11 and also 12.

@support do you have any thoughts where the issue is coming from?

Hey @StefanK — Thanks for reaching out with your report!

So we can take a closer look at what you’re experiencing we have split your post into it’s own thread.

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

How often would you say this occurs? Does this happen every time the iOS device wakes?


Hi @dylan,

Thanks for the quick reply. My network setup is quite straight forward:

  • Netgear R7000 router with TomatoUSB firmware (iOS devices connecting to its wifi)
    <-wired-> Zyxel GS1920 switch (no special configs present)
    <-wired-> ReadyNAS running flavor of Debian 8 with Roon Server x64 on it

It does not happen after each wakeup of the iOS devices. I’ve now worked out yet the pattern how often it happens, but it does happen at least once a day. The only way to resolve the issue in that case is to kill the iOS Roon app and start it again. On the next start it connects immediately.

Upgraded server and iOS devices to the new build 354, but the issue remains.
I had to kill and restart roon app on my iPhone twice today. I have verified that when iPhone had the connection issue after wake up, there was no issue connecting from iPad.
It seems the issue is on the ios app not able to correctly retrieve server status. If it was server or network issue I would expect same issue on all devices at the same time.
Device having the issue keeps showing the server in “Initializing” status and it doesn’t change until I kill and restart the ios app. Other device at that moment has no issue connecting.

Thanks for the update, @StefanK!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Hi @dylan,
New issue happened today 27/09/2018 at 10:08am CEST on my iPhone.
I’ve checked with iPad which was also woken up from at least 30mins of no usage and it connected with no issue.
Let me know if any other info is needed or some other test to perform.

Thanks, @StefanK!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Hi @dylan, just checking if you have received the diagnostics. I’m using roon every day so I would expect it should have been sent already.
If not is there some way I can trigger it manually or should I zip some specific logfiles and send them to you?

Hey @StefanK,

The diagnostics report for the Core machine was received, but unfortunately I did not receive a report for the iPhone remote device. I have re-enabled these diagnostics and the next time it connects to the Core machine this should come through.


Hi @dylan ,
I’m using both iPad and iPhone clients daily, so I’m surprised it hasn’t gone through yet.
Do I need to record another instance of the issue?
Is there some way to push the diagnostics from iPhone?


Hey @StefanK,

The diagnostics report has successfully uploaded now and I am passing it along to the team for further review. I’ll be sure to update you as soon as I receive their feedback.


Hey @StefanK,

I had a chat with the team regarding your report and wanted to reach out with our findings. The technical team is currently working to reproduce this behavior in house, and we are hoping that you could perform a test for us that should give us some more information here about why you’re experiencing this.

The team has asked that you connect your Core machine directly to the router instead of the managed switch. When in this configuration do you still experience this behavior?


Hi @dylan,

Wow, you’re right. Avoiding my managed switch worked. I no longer see the connection issue.
I’ve done some more search on your forums regarding managed switches and found some suggestions to turn on ‘flow control’ on the port on which my router is connected. So I’ve done that and I’m going to see if it worked.
Let me know if you have some other suggestions in the mean time.

I’ll report back with my results.


Hi @dylan, I’m happy to report back that turning on ‘flow control’ on my managed switch has resolved the connectivity issues.

But contrary to the suggestions of some posters, it was actually necessary to be activated on the port where my NAS is connected (which holds the Roon server) and not on the router port.

So thanks for the help, this one can be closed now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.