Ipad and Roon server connection takes ages [Resolved - Deleted cache and rebooted]


For a few weeks now it takes ages to connect the iPad remote to the Roon server, sometimes about 5-10 minutes. Is there anything I can do to improve? The topics around this subject all describe solution directions that are not fitting my situation.

My situation:
Pink Faun streamer with headless Linux OS
LAN connected to router through a switch box of netgear (standard, nothing fancy)
SSD with all my music files direct in the streamer so no router in between.

6th generation
Software: 14.7.1

Streaming services:
Both incorporated into the software of Roon off course ;-).

Everything worked up to specification until about a month ago and now this issue rises.

Looking forward to your response.

Kind regards,

Moved to support.

Power off everything including your router. Close all apps on your Ipad and restart the Ipad. Clear cache in Roon.


Wil try the removing of the cache since al the other I already did several times but will include them again with the cache option include. Thanx for reply. Will post a message if this solved the issue.

That did do the trick, especially deleting the cache was the big step.

Thanx for your advice in this much appreciated.

Next step for Roon development to have a limit on the cache so this issue does not occur…