iPad app keeps freezing


(Sam King) #1

Hi. I keep finding the Roon app frozen when I go back to it. Today I launched it to try and play an album and found it stuck on the Now Playing screen saying Nothing Playing and I could not get out of this page. I tried swiping away the app a few times to force close but made no difference. Curiously the Now Playing screen did show the track I subsequently started playing from the iPhone app but I still couldn’t leave the Now Playing screen.

I have an iPad Pro 9.7 and the iOS version is the latest available. I run Roon Core on my 27 inch iMac 5k Retina and it connects to my router via Ethernet. I usually play to my Cambridge Audio Stream Magic 6 which connects to my iMac via USB audio cable. But to be honest it doesn’t matter whether my audio equipment is on or off, the iPad app has frozen a few times now. The only way I can rectify the situation is to uninstall the app and reinstall. Then everything is fine for a while.

I see others have reported this on your forums and the implication from the answers is that it is something to do with peoples setups, but it seems to me the app is not working well on iOS 12.1.4 I am new to Roon so I don’t how well the app worked with previous versions of iOS in the iPad.

I don’t seem to have any app problems at all on my iPhone XR running iOS 12.1.4 but I prefer the iPad app as you can use e.g. Focus which doesn’t seem to be available on the iPhone app.

I’m taking advantage at present of a free trial via Qobuz and thinking about subscribing. On the whole I am enjoying Roon but this problem is spoiling things quite a bit and now I’m not sure.

Cheers
Sam


(Noris) #3

Hello @Sam_King,

Thanks for contacting us regarding this issue. Can you please let me know if the iPad has enough free space to operate properly? I would like to confirm that it is not by any chance running out of space and causing it to lock up.

When the app is in this stuck state, do any of the buttons work at all? What exactly do you see on the page, does it say “Loading Album” or does it just contain the previous page you were on? Does rebooting the iPad get it out of this state?

Thanks,
Noris


(Sam King) #4

Hi Noris. Thanks for the reply. My iPad has about 60Gb of free storage.

I get both errors actually now you mention it. The “Loading Album” hang happens when I am playing an album and I tap to load the “Now Playing” screen to view art work and playing track. If I then go off browse my library while listening and come back to the “Now Playing” screen, to then view the album and all tracks playing I found out you tap on the album art and it usually takes you back to the full album playing. That’s when I keep getting the screen stuck on “Loading Album” message. I can sort this by going to my full library and searching for the Playing album again or just swiping away the Roon app and relaunching.

The more troublesome issue is the app freezing and I think it is usually when using the “Now Playing” screen but can’t remember fully where I have been in the app everytime it has happened. When the app is truly stuck no buttons work at all. The last time it happened it was showing me the “Now Playing” screen with the message “Nothing Playing” the bottom “Select Audio Output” and a blue bookmark symbol at the top right. Rebooting the iPad has no effect. I have to uninstall the app.


(Noris) #5

Hi @Sam_King,

Thanks for letting me know that you are able to reproduce the second issue as well. We have an open ticket regarding hanging on the Loading Album screen and the devs are aware of this, but as for the app completely freezing, I have not seen this behavior before.

Can I please ask you to note the next date and time that his issue occurs at, the time being the local one in your country (e.g. 9:16PM) when it occurs and let me know this info? I would like to enable diagnostics mode for your account and take a look to see if there are any errors occurring in the background.

Thanks,
Noris


(Sam King) #6

Thanks and will do. Fortunately it has only happened twice so far and I suppose it could be an iOS issue. But swiping away an app usually rectifies the issue for other apps and the odd thing with the Roon app is that made no difference. Only a reinstall worked. I have seen other posts in the Roon forum saying the similar things.
Cheers, Sam


(Noris) #7

Hi @Sam_King,

Thanks for providing that additional information. It would be useful to take a look at the logs when you are in this state. If this issue occurs again please let me know before re-installing the app so that I can check the logs and see if there are any errors present.

Thanks,
Noris