iPad connection issue

Core Machine (Operating system/System info/Roon build number)
Mac Mini 6,1 single core i5 MacOS 10.13.6, wifi

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
wifi, TP Link AX50

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
iPad Pro 2015 with Audioquest Dragonfly Red

Description Of Issue
As of iPadOS 14.2, Roon connects to iPad with Dragonfly but then says

“Roon lost control of the server”

… after play command. Have tried restarting server app and machine, restarting iPad, deleting and reinstalling app.

Hi @Vincent_Gizzi — When did this issue start occurring? Were there any changes around the time this started happening?

Do you see this issue with any other remotes?

Hi Dylan

I can’t say when this might have started because I haven’t used my iPad as a zone for quite a while. The remote app running on another desktop works fine with all my other zones, but the ipad only shows up as one intermittently, And when it does, and is selected, pressing play doesn’t do anything—no movement on the progress bar.

Hi @Vincent_Gizzi,

Can you please try uninstalling the Roon app on your iPad and then re-installing it from the iOS App Store? Let us know if that helps!

I did that but it didn’t affect the problem.

Hi @Vincent_Gizzi,

If you disconnect the Dragonfly and try to output to the iPad internal speakers, does that work as expected?

No. Problem remains.

Hi @Vincent_Gizzi,

Thanks for confirming the issue still occurs on the iPad internal speakers.
That is strange behavior to see, are you by any chance using a VPN on your iPad?
Can you please reproduce the issue and let me know the exact local time + date + track affected?

I am not on a VPN. Will note time and source next time problem occurs.

I recently had something similar happen when using my iPad as an endpoint.

These steps fixed it for me:

  1. Delete Roon App
  2. Do a “hard reset” on the iPad (hold down both the power and home button at the same time Continue holding both buttons down, the screen will eventually go blank The Apple logo will then appear, release all buttons)
  3. Reinstall the Roon app from the App Store.

The key seemed to be doing the “hard reset” on the iPad rather than a normal reboot (ie just power off then on just using the power button).

Hope this helps.

The problem just recurred. At 2:37 pm, Dec 22 EST, playing track on my ext USB HD, ALAC 16/44.1. Error message. “roon lost control. of the audio device” which is the ipad pro running the remote, Ipad IOS is 14.3 .Roon working fine on Macbook, iPhone. I had already uninstalled roon on the ipad pro,did hard reset, re-installed.

Hi @Vincent_Gizzi,

Apologies for the delay in getting back to you here, hope your holidays have been going well! I’ve just enabled diagnostics mode on your iPad - next time the Roon app is active it should upload a set of logs to our servers for review.

Can you please let me know when you use your iPad again and I’ll re-check for the logs? Also, can you please submit a log set from the Core you used to perform the test? You can use these instructions to access the logs.

Thank you and Happy Holidays!