iPad Interface goes blank or 0 Albums displayed

Roon Core Machine

iMac Corei7 4Ghz

Network Details

Apple Airport a/c

Audio Devices

Auralic Aries

Library Size

126,000 tracks between qobuz and alac files on Synology NAS

Description of Issue

Just received a new iPadPro 12.9”. Sometimes when switching between Roon and another app, coming back to Roon the interface is blank. Force quitting is required or starting over by searching. the playback controls remain and are active.

I’d add this appears to be an issue with the app losing the list of albums, not a display issue. When I tap to see albums, 0 are listed.

Hey @John_Hendron,

Thanks so much for letting us know of this. Sorry about the delay and for the trouble :sweat:

I was wondering if you could try:

  • deleting the Roon Remote app from your iPad
  • restart the iPad
  • reinstall the Roon Remote app

I hope it helps :pray:

thanks. i tried the formula you suggested; after a week of using the app the symptom returns; specifically going back to the app with a playing album, the entire interface is blank where we’d expect to see album art and information. the playhead was still moving and the buttons on the bottom and top left were active.

Hey @John_Hendron,

Thanks for reporting back on this. Sorry for the delay in replying :pensive: . Do you have any other remote than the iPad Pro 12.9"? Do you get the same behavior on any of those?

If this is a behavior that repeats itself 100%, could you please jot down the reproduction steps, including what state are you starting from and everything leading up to this display? It’d help our QA and technical teams tremendously :nerd_face:

Thanks in advance :pray:

Tonight my iPhone did the same thing. Switching from one app back to Roon is what I have to do to reproduce the behavior.


Hey @John_Hendron,

Thanks for following up :pray:

Could you please re-attach the photo, if relevant? It doesn’t seem to be displayed :nerd_face:

Tried again; not terribly relevant: just similar interface with missing elements.

Have turned on local logs if this helps. Am a user that sometimes has VPN on iOS devices turned on.

Hey @John_Hendron,

Thanks so much for following up and sharing all the bits of info that might help.

While VPN doesn’t always play nice with Roon, it looks like this is a bug we’re aware of… :pensive: . I just heard back from our QA team.

Please, bear with us while the ticket gets the attention it needs :pray:


I had exactly the same problem today while listening to an album. Going to browse the albums list showed 0 albums out of 279, but playback unaffected. Using Roon remote on my iPad. On closing the app and then reopening everything was back for a time, but after closing the app and switching to Safari then opening Roon again, the problem recurred - 0 albums, 0 tracks and 0 compositions. No problems using Roon remote on my iPhone or my MacBook. You said this was a known issue, so any fix you can advise?

Regards, Ian

Hi Rebeka,

Has this issue got a fix yet. Same thing happened to me today using iPad - see my post above?

Regards, Ian

Hey @Timberwolf,

Thanks so much for chiming in and sharing that you’re experiencing the exact same issue… I am sorry.

There is a ticket in with our QA team for investigation. We are collecting information, so it is very helpful you’ve mentioned this.

We’ll make sure to let everyone know once it’s been resolved :nerd_face: