iPad keeps disappearing

I have added an iPad (on wifi) to my Roon environment however it seems to come and go from Zones on my Core (on iMac) with no discernible pattern. This is even when the iPad is happily playing music.

It sometimes disappears from Zones on Roon Remote on my iPhone and even on the iPad itself. The latter seems to resolve itself if I close and re-open the app on the iPad.

Shutting down Roon on my iMac doesn’t restore it.

Is there something I should be looking at to resolve this please?

When you add it make sure to make it a NON private zone in device settings

It is selected as non-private. As understand it, it wouldn’t show up at all if it wasn’t.

As my note says it is intermittent.

I should also add that the iPad is set up to never go to sleep.

And as I say, it can be happily playing when it disappears from the Core Zones.

Ok flagging @support for then.

Hi @Mark_McLaughlan,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this occur with any other zones, or just the iPad?

High speed cable in cable modem and then a Telstra 6233 wifi/switch =
(which I think is a re-badged Netgear switch). Then this is connected =
via a LAN to a Netgear Extender. The iPad either hooks on to that wifi =
point or the wifi point of the 6233. Same name but the behaviour I’m discussing seems to be the same no matter which its in use.

If I haven’t used either my phone or the iPad for a while then
both/either will disappear from the core zone map. This isn’t a
surprise to me. A refresh of the Roon app and it reappears.

But the iPad dropping out of the Core Zone list whilst music is still
playing and/or dropping out when no music playing but the iPad hasn’t gone to sleep is a bit strange.

Thanks

Hi @Mark_McLaughlan,

As a test, can you try disabling the Netgear Extender and just use the primary router for WiFi and let us know if there is any change? In the past we have seen some issues stemming from these types of range extenders, so it would be good to know if the same behavior occurs without that in place.

Sorry for the delay. Unfortunately the wifi signal from the primary router is too weak so the test failed…

Hi @Mark_McLaughlan,

Is this because the router is too far away? Are you able to temporarily move closer for this test to see how things work without the extender in place?

Yes, that’s why we have the extender. Not easily.

Having said that it makes no sense to me that my iPad can show up on my Core (iMac), then disappear from the list on Core, yet still be happily playing via the iPad (which is listed on the Device list on the iPad along with every device that runs directly off my iMac)
).

Hi @Mark_McLaughlan,

Moving forward with troubleshooting, I’d like to enable some diagnostics on your account. First, I was hoping you could reproduce the issue and note the time that the iPad disappears from the zone list. Respond here with that time and your timezone and I’ll enable diagnostics so the technical team an take a look.

Thanks!

I just tried the same, I normally run via an extender for the same reasons

I have just installed a new router, Tp link ArcherC9

Connected to the router wireless 5g , I see my iPad as “device located on network “, switch to the extender it disappears , switched back to the router it still hasn’t shown,

5 mins later still no show

I have never seen my iPad on the core PC that I a recall

It’s back on the Network , very slow showing up though?,

Gone again , very intermittent?

I did some testing today at 10.43 AEST however it was not all that useful in regards reproducing the problem.

However I did work out that the “Private Zone” had switched back to being “on” on the iPad. It was definitely off previously. No idea why it reverted to on or when.

So I switched it off at 10.58 and since then it has been stable. I’ve stopped and started the music, closed the iPad, re-started etc and it’s still shows in Core Zones list.

Perhaps, just perhaps, this has been the problem throughout but I don’t believe so - my memory is reasonably clear that it had “disappeared” off the list and then returned when I first noticed the issue.

I did try my iPhone as well, which seemed fine except the app closed down/crashed at 11.15. Seemingly without reason.

Note: The volume control on Roon seems to have no control on the volume on the iPad (which is connected by USB to a separate hifi. This may be because the USB/Lightning output on the iPad/iphone is fixed???

I’ll let you know. Thanks

Just happened. 11.04am AEST

Was playing on iPad. Stopped the music on Core using Pause. Chose some other music but it now showed “Choose Zone” and iPad was no longer listed on Zones and no longer shown under Audio as seen on network.

Went to iPad, had to log in, and chose play. All fine. Went back to Core and iPad was listed.

My Autolock is set to 15 minutes and it was only a matter of seconds between above states.

So my takeout:
Roon on iPad is paused
iPad decides no apps are running so goes to sleep
This removes it from Roon Core’s view of what is on the network
“Open” iPad and hit play and Core sees it again.

A bit clunky for “Pause” to cause this, no?

Hi @Mark_McLaughlan,

Thanks for the update here! I’ve passed the steps you’ve shared with me along to our technical team for further investigation. I’ll be sure to update you when I’ve received their feedback here.

Thanks!

Hi @Mark_McLaughlan,

Thanks for your patience here while we have looked into this. I spoke with the team today regarding their investigation of your report, and I wanted to reach out with an update. The team has reproduced similar behavior and we are going to discuss with our development team at our next meeting. I’ll be sure to update you after we get more feedback from the dev team.

Thank you again for your patience here, Mark — It’s greatly appreciated!

Thanks Dylan. Unfortunately my trial has run out so I can’t do any more testing for you. Unfortunately I cant consider buying Roon with this sort of stability issue.

I would like to know of any progress though please.

Regards

Hi @Mark_McLaughlan,

I spoke with the team regarding their investigation and we were hoping to get a little more information.

Does the iOS device go to sleep during playback? Did you manually lock the device? Is it on the lockscreen when you pause and then it disappears?