iPad lose every one minute connection

Sorry about the delay in responding to you.

I have Roon 1.3 installed in a custom made NAS built to the specifications recommended by Roon. The NAS is a 64 bit system, powered by an Intel i7-4790K Quad-Core 4.0 GHz LGA 1150 88W Desktop Processor (16 GB Memory) mounted on a Asus H97M-E/CSM LGA 1150 motherboard. All music is stored on a single Seagate ST8000NE0001 hard drive. The NAS operating system is WHS 2011.

The NAS is connected directly to the router (Apple Time Machine) with a CAT 6 cable. I also have an Apple Airport Express to extend the range of the wifi. The router mode is set at DHCP and NAT and the two DACS (Merging NADAC 8 player and Logitech Transporter) and NAS have been given static DHCP connections.

I have Comcast as an ISP and typically have a 200 to 250 mbps wi-fi connection, even when the wireless remotes (iPhone 7 and iPad Pro) lost the Roon connection. When I am playing music, there are rarely any other devices accessing the wi-fi on the system (with the only exception of e-mailing or texting).

I have already provided a pretty detailed description of the connection drops I have experienced with my remotes. Sometimes they both experience it simultaneously; sometimes one connects when the other doesn’t (but the one that connects, in these instances, it inconsistent). Sometimes it appears that Roon “comes up” when I turn it on, for a flash of a moment, only to get the lost connection screen. Sometimes the lost connection screen persists for several minutes and then gets connected; other times, the iPhone/iPad goes back to sleep before connection is restored. Sometimes, exiting and re-entering Roon (via remote) seems to restore the connnection; others it doesn’t work.

There are two DACs that are connected to the NAS via a Netgear JGS516 ProSafe 16-Port Gigabit Ethernet Switch (JGS516NA). CAT 5E and CAT 6 cables are used as connectors.

There are about 30K tracks in this collection, although Roon claims there are 61K tracks (I think there are a lot of duplicates). The tracks are wav formatted – I used dBPoweramp to rip them from CDs.

After reading about the solution that thyname published, I have changed my 5Ghz band from Automatic to fixed channel (161). [My NAS had been directly connected to router already.] I will report on how this works in a few days.

Let me know if you want any more information about my set-up or the problems I am experiencing.

A couple of days ago, i implemented the “thyname” modification to my set-up. Since I had already connected my NAS to the router directly, the only thing left to do was to change my 5Ghz setting (in my router) from Automatic to Fixed Channel (not really knowing which one to chose, I selected the highest setting, 161).

Beginning immediately and continuing for the past two days, my two remotes are behaving very differently than before. Roon boots up quickly (the longest “lag” has been a couple of seconds … maybe) and refreshes even more instantly. This has been true for both my iPhone 7 and iPad Pro.

I still hear “my inner cynic” telling me that this is too good to be true. However, after 40-50 consistently successful “tests” (including re-boots of my NAS, iPhone, iPad, and Roon (alone), even he is not sounding very convinced.

I am considering my issue with this resolved for now and suggest that anyone else having the same problems with their remotes try this.

For me, the problems with the remotes losing connection has been very frustrating (and humiliating). I am grateful for the generous help and support provided by the Roon community.

Thyname, thanks for the suggestion.

1 Like

Awesome! You are welcome!

Since I posted my (hunch) solution, I have had zero problems.

On another note, I used a Windows tool called inSSider to find out the optimal channel for the 5 G band. This is helpful when there are neighbors around with signal interference.

OSX has a similar tool built right into the OS. Option key and press on your wireless status icon. Open Wireless Diagnostics. From the Window menu choose the Scan window.

It won’t tell you the best channel to choose but gives you the information needed to pick the right channel.

1 Like

Hello everybody,
Also good news from the Netherlands.
Today I had some time to test different things. Inspired by @thyname I checked the use of different channels on 5GHz WiFi.

My core-server and iPad are already connected to the same switch/access point. The core-server wired, the iPad wireless on 5GHz. I changed the 5GHz from automatic to fixed channel. Channel 138 give the best results and the connection is now stable. At the moment the system is now 8 hours running without any problem.

I’m so happy !
Have a nice weekend !


15 posts were split to a new topic: Remote connection issues with iPhone 7 and Gigabyte GB-BKi7-7500

Two weeks further, I’m not satisfied. The disconnections are back, not every minute, not every day but random on different times. The last week I have done a lot of testing, even bought a new router! And now I think I have found the problem which is reponsible for the disconnection on my iPad.
At the moment a workaroud is running. But, I’m running out of time, I must go now. Tomorrow you recieve more information.

I’ve also discovered this bug recently with my iPad Air (early 2014, 1st gen) and latest iOS. Dropouts with very short intervals, like every 1-2 minutes and then it reconnects immediately in 0-2 seconds. This is still superbly annoying and depending on where you browse the library, it might take you back to the beginning of album browse or something similarly annoying when reconnecting. This problem appeared after some of the last few updates to Roon.

Core platform: Win10 64bit with most recent updates

Core HW: AMD FX-6300, 16gb RAM, Gigabyte GA-78LMT-USB3 MB, Gigabyte, Geforce GTX 1050Ti, SSD Crucial MX100 128gb (Roon is installed here), Storage: Western Digital WDC Red 3tb.

Router/wireless: D-Link DIR868L connected with ethernet to my PC (Realtek GBE family controller with most recent drivers) which runs the core. Static ip on the PC which runs Roon core, otherwise DHCP. Audio runs runs through USB to my audio system.

The error is Lost connection which flashes for very short duration, usually under one second and then Roon remote reconnects immediately.

iPad connected through 5ghz wifi and auto channel scan. I tried the earlier fix by manually selecting the channel but it doesn’t help. I’ve rebooted the router, rebooted the iPad, rebooted the PC, installed Roon again on iPad but none of these helped.

Any update @mike ?

For a moment, I thought it was gone. Not a dropout in over five minutes, but then there it came again. I continued experimenting with different wifi channels. I only have four options with my D-Link router, 36, 40, 44 and 48. Now running 40 and it has the least dropouts I think. But it’s still happening frequently. Weird issue…

Anyway, it must have something to do with the recent updates to Roon since I’ve never had this problem before.


Happens with my iPhone 7 also.


I took a video of the dropout on my iPad. Happens after 25 seconds:

Here the screen only blinks for a second but sometimes it throws you to beginning of album view or somewhere else after reconnecting.

If your router has a WiFi region setting, set it to USA.

Assign different SSID for 2.4GHz and 5GHz in your router. Switch your iPad to 2.4GHz SSID. Try channel 1, 6, or 11. See if it behaves differently.

No region settings and all other settings have been on auto previously and everything’s been working good.

2,4 and 5GHZ connections have different SSID’s. I tried with 2,4GHz on channel 11 with immediate dropout then with channel 6 and with that I got almost 10 minutes before dropout but now it happened again while writing this. I didn’t try channel 1 yet, feels pointless to me since this doesn’t feel like a real fix to the problem, only temporary solution.

@mike … So we are 24 hours further, the system is stable; solid as a rock :wink:
The workaround seems to be the temporary solution.

Last week I have build a secondary small network totaly isolated from the core network. This network has a new router (ASUS RT-AC3200). The router was directly connected with the internet, the core and Synology NAS. The iPad Air2 is wirelles connected on 5GHz with this router. Man o man, this is really fast, bloody fast! The average speed between the router and iPad is 879 Mbit.

Unfortunately the problem stays; random disconnections on the iPad.
The router wireless signal is extremely strong. The distance between router and iPad is less than one meter.
Further I see the same thing as in my core network. The profile picture is blinking every minute, the picture disappears 1 second on all my systems. This are three Windows10 clients, two iPads air and four Android smartphones.

Yesterday I saw a post in this topic about problems with the iPhone. I don’t now the name, but this post is moved to a another or new topic. For me was interesting the discussion about the Windows firewall. This was for me the only thing I have not tested yet. So let’s rock and roll !

I decide to switch off the firewall on the Windows10 core-server. I reboot the server and restart the Roon remote app on my iPad. I could not believe; all problems disappeares. No blinking profile pictures on all machines; no reconnection issues on the iPad. Everything is now more than 24 hours fully stable. Now we are talking ! For the fun; I cascading three switches between core server en the router. No problems, the system stays fully stable !

Today all components are back in my core network; fully stable, no blinking profile pictures and no reconnections on the iPad. So, in my environment the Windows10 firewall generate all the problems I had. On the new router I don’t use fixed channels, I change the 5GHz transmission power to low, no problem everything stays stable. I go with the iPad to the garden (50 meters), everything stays stable.

When I switched the Windows10 firewall on; all problems are back.
Don’t forget to reboot the core server and to restart the Roon remote app on the iPad When you turn off the Windows10 firewall.

Next step; why gives the firewall the problems in my environment ?

1 Like

Thank you René, this might’ve been the solution. I disabled the Windows 10 firewall (I have one in the router anyway) and over 20 minutes without dropouts now. I’ll continue testing tomorrow. But still, only a temporary fix since everything worked fine in previous builds.

Try adding Roon to Windows Firewall exception list.

I am now having driving Roon from a Linux server, but on a Windows machine I noticed that it tells me that the firewall is not accepting all calls from Roon - so maybe it is a good general advice to ask people, who are using Windows to be aware of the firewall and add Roon to the exception list.

Well this makes it even more weird since roon.exe and RAATServer.exe were both on allowed list on Windows 10 firewall. I checked before I disabled the firewall.

This morning I did some more experimenting. I turned the firewall back on and tried to look for advanced settings which might’ve had something to do with the dropouts. What I first noticed was that there were total of eight Roon related allow rules under the Windows Firewall -> Advanced settings -> Inbound rules. Four for Roon.exe and four for RAATServer.exe. Most other applications only had two per process. So a duplicate rules for Roon processes. I deleted all the eight rules and re-opened Roon. Now Windows firewall asked during the startup if I want to allow Roon.exe and RAATServer.exe network traffic and I clicked allow. Now there’s only four Roon related rules on the list, just like all the other applications have.

After this process I haven’t had any dropouts at all even with Windows firewall turned on.


Today I did the same test as @patouskii with the same results :slight_smile:

Yesterday I saw also eight firewall rules for Roon for incoming and outgoing traffic.
I delete all rules and add them manual, no results.

Now I deleted all roon/raat rules in the Windows firewall and reboot the core server.
I started manually the roon core software and the firewall cames withe three pop-ups for raatserver.exe and roonappliance.exe.

I’ve checked the firewall rules. Only for inbound traffic are two rules for raatserver.exe and two rules for roonappliance.exe set. Both four rules are active.

So, at the moment the firewall is running with the new automatic rulessettings (4) for raatserver en roonappliance. Everything works good the last two hours :slight_smile:

1 Like

probably notices from the older version of Roon.

So, the problem is back today. More testing with the Windows firewall ahead. Now I only disabled the private network firewall and it seems to have done the job again, no dropouts for a while.

Would be nice to get some feedback from Roon team, thanks.