iPad Mystery Is Driving Me Nuts

I have an older iPad running iPadOS 12.4.6. After a month of working fine with my Nucleus+ it is now giving me grief.

When I try to use it the Roon logo comes up and then I get the “looking for your Roon core” message. It will not recognize my core even if I enter the correct IP of the Nucleus and hit scan.

Earlier I could get it to come up by unplugging the Nucleus but this no longer works, Hoping for a correction I even removed and reinstalled the Roon Remote app to no avail. YET my iPhone connects to the core flawlessly!

I don’t get it at all!

Is you iPad connected to the proper WIFI 2.4 or 5?

try entering 255.255.255.255 instead.

2.4 and router is less than 6 feet away

I did a search of all 15 of my IP’s. The Nucleus+ is 10.0.0.3 I tried 255.255.255.255 and iPad says it is still searching for the core.

Yet my iPhone finds it in the blink of an eyelash!

Usually, a reboot of EVERYTHING, including router, fixes most problems.

Expecially iPad!

Making progress – to the rear! Ip for Nucleus got changed from 10.0.0.3 to 10.0.0.11. Now my Iphone won’t connect to my core either. HOWEVWER both Ipad and Iphone are acting the same. Now they say “Chose your Roon Core” below that I have a picture of the Nucleus which has the words “connecting” and “connection failed” altrernating below it . So both Ipad and Iphone are trying to connect (I think). BUT beside the Nucleus logo there are words “Firmware 1.0 (build219)” Below that it says"stable/::ffff:.192.168.1.1 Version 1.7(build 571" . The line below thar says “stable”. I am using the program Wireless Network Watcher to give me the IP readings. It says the IP for the Netgear router is 10.0.0.1.
The 192.168 **** series of IP numbers is associated wuth my Viasat modem.
So how do I get things to look gor the correct IP and connect?

BTW, this is after I had rebooted everything - the modem, the router, the nucleus, and the Ipad.

Sounds like a network issue. Everything has to be on one IP range.

1 Like

I rechecked that the router function was turned off from the Viasat modem (otherwise I would have two networks trying to work). So after being reset how are the Ipad and Iphone still attempting to connect to a discontinued IP address? And more to the point how do I direct them to the proper one/

I have a similar problem using iPad as the control device for Roon on one of my systems, and as Paul has intimated, the problem has not always existed. My setup used to work flawlessly until around (at a guess) 6 months or so ago.

I have Roon Rock installed on an Intel NUC (8i5), and my ‘older’ iPad Air is currently running OS 12.4.6. My high(ish) speed broadband and WIFI is provided by Sky (UK), and delivered by a relatively new Sky Q router, and I also have a 2 Tb Sky Q TV box (PVR) which is also connected to the network. I have a Cisco 2960 switch attached to the router over ethernet, and the following components connected to the switch: Intel 8i5NUC; Panasonic 4k Blu-ray player; Panasonic 4k Smart TV and a sonore MicroRendu audio streamer/renderer.

My problem is similar, but not exactly the same as yours. Whenever my Sky Q TV box is connected to the router via ethernet, my iPad Air cannot find my Roon NUC. I get the same Roon Logo and message (“looking for your Roon core”) as described by Paul.

However, as soon as I disconnect the Sky Q TV box, my iPad instantly finds the Roon NUC and works perfectly. No other device on my network is affected in any way - just the iPad to Roon Rock connection.

My solution, although a bit inconvenient, is to leave the Sky Q TV box unconnected when I am listening to music and don’t need it, and to physically connect the Sky Q box when I do need it.

I use a Windows 10 PC as Roon control point for another hi-fi system elsewhere in my house, but connected to the same home network via ethernet (on a separate switch). The Roon control app on this PC has no issue finding Roon Rock on the Intel NUC irrespective of whether or not the Sky Q TV box is connected, so I guess my issue is purely wi-fi related.

I would prefer a more convenient solution!

Success Finally! The gentleman who commented this must be a network problem (although I could not see how) was right. I had disconnected the network function of my Viasat modem/router and checked doing so twice. Nowhere in the online Viasat instructions did it also point out that having done a hard reset was also necessary which required t depressing a small pin hole button with a paperclip for a minimum of 30 seconds. Prior to my doing so ter Viasat was still trying to provide the old network confusing Roon. As soon as I did the hard reset my remotes were able to connect to Roon. Psheew! .

3 Likes

I knew because I hang around on this forum too much :joy:

2 Likes

To my great surprise, as well as resolving another issue of mine involving ‘missing metadata and artwork’ in Roon Radio, release 571 also appears to have resolved the issue I outlined above. I was losing connection from my iPad to my NUC whenever my Sky TV (PVR) box was connected to the network. Following the update of release 571, this problem has disappeared. I can now connect from my iPad to the NUC on which Roon Rock is installed even when my Sky Q box is connected to th enetwork.

1 Like

Unfortunately, I have to report that this problem has recurred. Today, for whatever reason my iPad was not able to find the Roon core on my NUC until I disconnected my Sky Q (PVR) box from my network.

Oh well!

At least the other more irritating metadata related couple of issues that I had post release 1.7 and which appear to have been resolved by build 571 have still not recurred.

I just started using an Ipad and had a problem finding the Roon Core on my Windows 10 PC. My Android phone also failed after working all through my Roon trial. A new router was installed and I believe this changed some settings in Windows 10… After many attempts to connect from the controllers I changed the setting for network type from Public to Private and my Ipad and Android phone connected instantly. Hope this helps.